[SOLVED] LightWrap Module Missing


(Lee) #1

I was following a tutorial on chroma key. All was going well, until the tutor loaded the LightWrap module, which is not with my version 2.3.13 with natron-plugins 437-2 (Extra OpenFX plugins for Natron) installed on Manjaro Linux. If I disable the default plugin locations for OpenFx, the whole project breaks because of other missing modules. It seems strange because the module is listed in the docs.

Where can I get/enable the light wrap module? Maybe there are other missing modules that I’m not aware of.

Thanks.


(Frédéric Devernay) #2

How did you install natron? Portable or installer or package from distrib or flatpak?


(Lee) #3

Hello.
I got it from the Arch repository (AUR). EDIT: I tried flatpak for something else not Natron.


(Lee) #4

Trying flatpak now.


(Frédéric Devernay) #5

The arch linux package seems to be missing the PyPlugs, I just signalled it: https://aur.archlinux.org/packages/natron/#news

I only maintain the portable distrib and the installer from the natron web site. Anything wrong with Natron should be tested with these, and if it’s working with these, then it’s a problem with the package: signal it to the package maintainer.


(Lee) #6

Thank you for your help and signalling.

I just installed from flatpak and everything is there. Flatpak seems to be a better option at this time.

Thanks again.


(Frédéric Devernay) #7

Aleksey Samoilov (https://github.com/Sunderland93) is to be thanked for the flatpak package.
I think he updated the flatpak to 2.3.13 yesterday: https://github.com/flathub/fr.natron.Natron