[SOLVED] Node created from interprete mode script does not have the same parameters as script editor.

I’ve been trying for a long time to find out what’s going on but I can’t. I hope you can help me.
I want to create a write node from script and then change the Bit Depth.

The problem is that when I want to modify the parameter from a Natron script in interpreter mode, the bitDepth parameter does not appear, neither the processAllPlanes parameter and others.

Here an example of printing the parameters of the write node:

write_channels_node = natron_app.createNode('fr.inria.built-in.Write')
print([x.getScriptName() for x in write_channels_node.getParams()])

So I cant change the bitDepth parameter because it doesn’t appear.

This is an example of executing the same lines in script editor from GUI (it works):

If it helps, this is how I run Natron:

START /B /WAIT "" "C:\Program Files\Natron\bin\Natron.exe" -t %MYSCRIPT%

Thank you very much! :blush:


The bonalex01 discord user from Natron Digital VFX server has found the solution:

bonalex01: My guess is:
parameters of the write node change according to the file format. Because all formats don’t allow to choose the bit depth.
So try to:

  • first set file format (exr, tif, tga) , file name…
  • then (cross fingers) the bit depth should “appears” in the list