[SOLVED] OpenGL rendering issues and crashes.

Hi there :slight_smile:

Unfortunately I am having very unstable results using GPU rendering in Natron 2.3.14 and I was encouraged to make this post by some people from the Natron discord as I don’t seem to be the only one.

I will focus this example on the cryptomatte keyer node, as that is best example I have, and most important to me. But it happens with other community plugin nodes too.

When using the Cryptomatte Keyer node the renderer stalls and prompts me to kill it and restart Natron if I wanted to continue working.

This image shows what error messages I get when using the cryptomatte keyer node in the community plugins ( The one by CGVirus on youtube) with OpenGL rendering turned on. (Note: It doesn’t matter what kind of node the renderer was crashing on, it was just a matter of the Crypto keyer node was part of anywhere in the composition)

I asked for help on the Natron discord and that gave me the idea to try and disable my GPU rendering. And doing so have gotten rid of any error logs or hanging renders that need to be killed and Natron restarted. So it seemed that the issue was the GPU rendering. and not the nodes. :slight_smile:

I am on windows 10, Using a RTX 2060, OpenGL version 4.6 with the latest Nvidia studio driver. 441.28( I’ve tried going back to older version too. 434 from july.)

I hope to hear back with any feedback on what can be done about this. And if there are any fixes I could apply to stabilize my use of GPU rendering, as using CPU rendering only seems to run very slow in comparison.

Thanks for reading :blush:

1 Like

@cgvirus I don’t think the issue is with cryptomatte because I can use it with GPU rendering with zero problems.
I’ve also been having this issue where Natron randomly refuses to recognize the graphics drivers and I know some other people also have had this issue. Most of the time, restarting Natron or the computer, reinstalling the graphics driver and similar rudimentary solutions fix the issue but in this case its not helping.
Do you think the issue is the RTX 2000 series graphics card? I haven’t tested Natron on any newer Nvidia cards. I have a GTX 1080ti and Natron runs on it perfectly.
Does Natron have poor support for the newer RTX cards? Because if yes, then that might be the issue here.

@Zuntrix here’s something you can try to check whether it is really a graphics issue or not. I forgot to mention it in the discord earlier. Turn on GPU rendering for this.

In a new comp, add the Shadertoy node.

in the node properties, click on “Renderer Info”
A popup window will open and you should see something like this:

If it says “N/A” instead of how it shows the information for me, then it’s probably an issue with the communication between Natron and the GPU…

@Zuntrix Hi, can you go to>edit>preference>Gpu Rendering and attach a screenshot here?

This is what it shows in the GPU rendering tab

And this is what the shadertoy node shows of my graphics info.

Hmmmmm… then Natron is actually able to communicate with the graphic card and driver… Something else must be the issue then… Is it only the Cryptomatte_Keyer node or does any other node also give you the error?

You said you were using Studio Drivers. Try switching to Gaming Drivers and see if that fixes it. It might be that Natron is unable to communicate properly with Studio Drivers.

In the screenshot the error is that the GL_VERSION fails, I think this is related to an old issue. Will check.

This happens with many of the community plugin nodes I’ve tried to use. Especially the G’MIC ones.

@El_Artista I was already using the gaming drivers. And tried to switch to studio.


I was also wondering about that… I thought Nvidia had a different GL version in the Studio Drivers…
If there is an old issue that causes Natron to randomly forget the GL version or get it wrong, it should be fixed. If i recall correctly, this issue has been present for quite some time…

Got any idea what might be the root cause of this? =)
Or if there may be a work around.


What I am seeing, your GPU driver is not configured properly. It is using MESA instead. You can do the following:

  1. remove all NVIDIA components from add/remove program (windows control panel)
  2. restart PC
  3. Download and Install your driver with this configuration from here:


The DCH mode has some issues with OpenGL vs DX

The driver is clearly installed and working, seems like the Shadertoy node fallback to Mesa for some reason (maybe a setting?).

After updating to the new Nvidia driver from today (11th dec). The shadertoy now recognizes Nvidia as driver instead of Mesa. Will report back if I still get the issue.

Version is 441.66 studio version from 12th Dec


1 Like

@Zuntrix was this an issue on Windows, or Linux? OpenGL rendering on Windows is a little bit clumsy I think (I’m not a Windows user).

This was on Windows 10 :slight_smile:
I do my best to keep it updated.