[Solved] Problem with gradient background rendering

Hello everybody! I’m having a problem with a gradient background.

I have a Ramp node as a gradient background. In the View, the gradient is smooth, but when I render, the shades of the gradient looks like solid bars, as shown in the images attached.

I tried to change the container, codecs, color profiles, render quality, etc. but no luck! How can I make the gradient of the render look as smooth as in the View?

In the View

After render


Can you add a dither or some noise over the gradient? This is quantization.

Oh, right! Man, I’m new with video compositing software, but now I understood the issue. I added a bit of noise and the gradient looks smooth now! Thank you very much!

Note that the viewer in Natron uses dithering, but if you render to 8-bit without dithering you will get that “solid bar” effect

1 Like

Dither is always on the viewport? In some cases it can be problematic.

You can disable it in the prefs if you prefer to see the banding effect.
Since the display is 8-bit, that’s still the best way to display floating-point images. Nuke does the same and no one complains about it.

Also not that you can also enable dithering in the write node. It should be checked by default:

I check this in Nuke too, I’m curious.
I found it in docs:

Thank you

My Write node don’t show this dithering option. I don’t know if it is relevant, but I’m using the 2.3.14 version.

Here is the options that is shown to me.

What I did is to use a Quantize node, it has a dither option.

Yes, dither is only available when writing image files. It doesn’t make much sense when writing videos, because noise doesn’t compress well, so most of your video bandwidth is used to compress noise. If you’re writing 10 or 12 bit videos (as in the example above), there should be no visible banding effect, thus no need to dither.