[SOLVED] Problem with mask layers in Photoflow

I’m having a problem with path based mask layers in Photoflow on macOS. If I save a .pfi, and then quit and relaunch Photoflow the mask will not show (it behaves as if the mask is empty). Making a change to the mask layer such as clicking the ‘invert’ checkbox fixes the problem. Exporting the image as a JPG produces a correct image even though the preview is wrong.
I have tried removing the ~/.photoflow directory in case I had a bad setting or something, but that makes no difference.
The problem occurs 100% repeatably for me on all .pfi files I have tried.

mask_test.pfi (21.7 KB)

The image before saving:

After quitting Photoflow and reloading the .pfi:

Open up the mask on the basic adjustments layer and click ‘Invert’:

I am currently fixing some bugs related to interactive tools like the path mask. What I discovered is that in recent versions the image is not properly updated when controls points are added or moved in the preview - this is a consequence of the recent changes to the processing pipeline.

I do not know yet if this is related to what you are reporting, however in my private development version I apparently cannot reproduce the issue, so it might be fixed already by the changes I am introducing.

I should be able to provide a new version for testing later today or tomorrow.

The issue with the path mask seems to be fixed in the current stable branch. This is how your test image looks like right after opening it:

Could you please check from your side?


1 Like

I can confirm that the problem is fixed in stable 0f635.

1 Like