[Solved]Ricoh GXR conversion missing


(Pierre Edelman) #1

Hello,
I use a GXR camera from Ricoh and RT on Linux/Ubuntu. On the DCRaw page it says that my camera is supported. I figured that RT would dematrice my pix since it calls DCRAW upon for the job (so the same page says).
Is this a bug ?


(Morgan Hardwood) #2

Hey

Please upload a sample raw file to https://raw.pixls.us/


(Roman Lebedev) #3

(IT’s DNG. It should work in any software that supports DNG, with no special per-camera-support needed.)


(Pierre Edelman) #4

Hi @Morgan_Hardwood,

I just did. I do not know how long it will take to show in the repo for you to see.

Thanks for your help

Le jeu. 13 sept. 2018 à 18:04, Morgan Hardwood noreply@discuss.pixls.us a écrit :


(Morgan Hardwood) #5

@pierpiotr your RICOH GXR works fine in the RawTherapee 5.4:

That said, the embedded JPEG preview image stored in your DNG is borked:
Ricoh%20-%20GXR%20-%2012bit%20(4_3)_PreviewImage

I recommend you format your memory card, check it thoroughly for defects (bad sectors, etc), then take and upload a new raw photo so that we can verify whether it’s a single corrupt occurence or whether it’s the camera doing funky stuff. Upload this new photo either directly as an attachment in this forum, or use https://filebin.net/ and paste the resulting link here.


(Pierre Edelman) #6

Here is what I see in RT 5.4 (KUbuntu17.10).
Your borked image is what I get in RT.
Did you de-matrice the picture above ?
And I’ll do what you suggest later this WE (I need to backup the SD card).


(Roman Lebedev) #7

Please upload proper (less corrupted?) sample afterwards!


(Morgan Hardwood) #8

You don’t have a borked image, you have a borked auto-matched tone curve (Exposure > Tone curve 1), because the curve was generated based on the borked embedded JPEG preview.

screenshot_20180914_180302


(Pierre Edelman) #9

You just solved my problem !
When I reset the matched tone curve it gets back to normal. I’m sorry if this is the normal way to use RT. I’m quite new to it.
Thank you very much @Morgan_Hardwood