-solved- RPD / install.py not starting (Ubuntu 19.10)

Hi there,

after a reinstall of Ubuntu (don’t ask me why :wink: … ) I tried to get RPD again back to work.
Reinstalling done via Ubuntu-Software.

Then trying to restart via Apps-Icon does not show anything.

When starting in shell, I see the following output:

Traceback (most recent call last):
File “/usr/bin/rapid-photo-downloader”, line 11, in
load_entry_point(‘rapid-photo-downloader==0.9.16’, ‘gui_scripts’, ‘rapid-photo-downloader’)()
File “/home/martin/.local/lib/python3.7/site-packages/pkg_resources/init.py”, line 490, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File “/home/martin/.local/lib/python3.7/site-packages/pkg_resources/init.py”, line 2859, in load_entry_point
return ep.load()
File “/home/martin/.local/lib/python3.7/site-packages/pkg_resources/init.py”, line 2450, in load
return self.resolve()
File “/home/martin/.local/lib/python3.7/site-packages/pkg_resources/init.py”, line 2456, in resolve
module = import(self.module_name, fromlist=[‘name’], level=0)
ModuleNotFoundError: No module named ‘raphodo.rapid’

Anyone an idea what is going on here? Any hint is welcome.
Cheers, and stay safe, Martin

Do this from a terminal:

python3 -m pip show rapid-photo-downloader

what is the output?

Also this:

ls ~/.local/lib/python3.7/site-packages/

here we go …

 martin@ubuntumartin:~$ python3 -m pip show rapid-photo-downloader
    Name: rapid-photo-downloader
    Version: 0.9.16
    Summary: Downloads, renames and backs up photos and videos from cameras, phones, memory cards and other devices
    Home-page: http://www.damonlynch.net/rapid
    Author: Damon Lynch
    Author-email: damonlynch@gmail.com
    License: GPL
    Location: /usr/lib/python3/dist-packages

martin@ubuntumartin:~$ ls ~/.local/lib/python3.7/site-packages/
arrow pyprind
arrow-0.14.5.dist-info PyPrind-2.11.2.dist-info
babel PyQt5
Babel-2.8.0.dist-info PyQt5-5.14.1.dist-info
colorlog PyQt5_sip-12.7.1.dist-info
colorlog-4.0.2.dist-info python_dateutil-2.8.0.dist-info
colour-0.1.5.dist-info pyxdg-0.26.dist-info
colour.py pyzmq-18.1.0.dist-info
dateutil raphodo
easygui rawkit
easygui-0.97.4.dist-info rawkit-0.6.0.dist-info
easy_install.py requests
gphoto2 requests-2.22.0.dist-info
gphoto2-2.0.0.dist-info setuptools
libraw setuptools-46.1.3.dist-info
PIL sortedcontainers
Pillow-7.1.1.dist-info sortedcontainers-2.1.0.dist-info
Pillow.libs tenacity
pip tenacity-5.0.4.dist-info
pip-20.0.2.dist-info tornado
pkg_resources tornado-6.0.3.dist-info
psutil wheel
psutil-5.6.3.dist-info wheel-0.34.2.dist-info
pycache xdg
pymediainfo zmq

Hi Damon,

first of all thank you for getting back to me.
But as I anyway am currently preparing for another re-install of my system due to other issues, I just would give it another try after a new clean install of kubuntu. … …

Okay at some point in the past, you had Rapid Photo Downloader installed using the install.py script. I suggest doing this:


wget https://launchpad.net/rapid/pyqt/0.9.23a1/+download/install.py


python3 install.py --devel

That should fix it. Install the devel version because that’s the most stable version currently available. You may need to reboot to have it appear in the menu, or may not. Let’s see.

hmmm …
looks like wget is running here in timeouts?

wget https://launchpad.net/rapid/pyqt/0.9.23a1/download/install.py
--2020-04-16 16:48:52--  https://launchpad.net/rapid/pyqt/0.9.23a1/download/install.py
Auflösen des Hostnamens launchpad.net (launchpad.net) … 2001:67c:1560:8003::8004, 2001:67c:1560:8003::8003,, ...
Verbindungsaufbau zu launchpad.net (launchpad.net)|2001:67c:1560:8003::8004|:443 …

Yes launchpad has been doing that a few times in the last month or so! :cry:

Hi Damon,

okay, then I assume my current installation issues also with a clean installed kubuntu are derived from actual launchpad instabilities…
I will give it a try again tomorrow or so …

Also new from your website downloaded script seems to stall after starting. so perhaps also here during script execution timeouts are halts …

Thx for your great tool! Hands-down the best photo-copying tool out there. Hope to have it again up and running soon …

Thx, Martin

You are facing two independent issues:

  1. You have in the past installed Rapid Photo Downloader using the install.py script in your home directory, but when you reinstalled your distro keeping your home dir, and then install Rapid Photo Downloader from the distro archive, things are not working. The easiest solution is to install Rapid Photo Downloader again using the install.py script, ignoring the distro version.
  2. launchpad is having some timeouts, meaning the download of the script or the tar.gz file fails sometimes. Bummer.


strange thing is that for

  1. I really had a clean install without complete conservation of the home directory.
  2. Download of the install.py from your website works fine, but execution is stalled. I not even get output when executing “python3 install.py --help”. So I feel, that I even have another issue here …

Even running the --help command generates a network request, to https://pypi.python.org/ to determine the latest version of PyQt5.

Perhaps you are having some intermittent network problems at your end? Either that or https://pypi.python.org/ was down when you ran it.


honestly no clue what is going on here.
Ping etc. out of console work, no issues with this.

Just install.py stalls after invoking it.

Curious as I am I just installed the version provided by Discover library of kubuntu (ubuntu-eoan-universe)
This version 0.9.16 installs and I am able to run it.

Guess I will check if that works for me …


again, thank you very much for taking your time to help me here.
I indeed now figured out, that the issue had been related to the way my ipv6 DNS had been configured.
ipV6 “automatic” did not work, while “IPv6 automatic only DHCP” … So now I am up and runnig with v0.9.23 !! thx !

1 Like