Some problems with RT 5.3 and 5.4

Some bugs (?) in RT 5.3 and 5.4:

-When I set the Main Font in the Prefs from Helvetica 10 to 12 or 14, the tool bars at top and botton of the File Browser and Editor windows are truncated at right, and the ‘Fit whole image to screen’ button does not work, i.e. the image is clipped at right.

Uff, and now it stays that way even after I have set back the font to size 10, deleted the Options file, and restarted the Mac!

-In the Editor/Exposure pane, if I set the Clip to 0 and then save that as part of a processing profile, when I then load that profile, the Clip has snapped back to 0.02. That may be a wise choice, but…

-Strange sequence of subfolders, see screen shot.
Uff, I see no possibility to add screen shots. So it’s here, a folder called ‘Strange subfolder sequence in RT’.

Fixed in dev.

How to write useful bug reports… Sorry for being sloppy!

My Mac is a Mac Pro from early 2009 with a 2,66 GHz Quad-Core Intel Xeon processor, 24 GB of RAM, Graphics card NVIDIA GeForce GT 120512 MB.

RT is downloaded today from RT 5.4,

-Copy from About in Prefs:-

Version: 5.4

Branch: 5.4

Commit: a5e8eb9c8

Commit date: 2018-03-20

Compiler: clang-mp-3 3.9.1

Processor: generic x86

System: Apple

Bit depth: 64 bits

Gtkmm: V3.22.2

Lensfun: V0.3.2.0

Build type: release

Build flags: -std=c++11 -mtune=generic -Werror=unused-label -mmacosx-version-min=10.9 -flto -fopenmp=libiomp5 -Werror=unknown-pragmas -Wall -Wno-unused-result -Wno-deprecated-declarations -O3 -DNDEBUG -ftree-vectorize

Link flags: -mtune=generic -headerpad_max_install_names -flto

OpenMP support: ON

MMAP support: ON

Now a new report on clipping:

Font left at Helvetica 10. Processing profile set to Neutral. The monitor is in portrait orientation. This has worked earlier.

The RT window is maximized in relation to the screen using Alt-click on the green button at top left.

The Editor size is maximized, ie the History panel at left and the Exposure panel at right are minimized.

The tool bars are truncated at right. See screen shots, named Toolbar Top and Toolbar Bottom.

After clicking ‘Fit whole image to screen’:

The image, which is in portrait orientation, is turned 90 degrees clockwise and cut by about 25% at right. After turning it 90 degrees counter-clockwise, the side which now is the right hand side is cut. The amount is difficult to estimate, because the red frame in the Navigator is now gone. The image is displayed completely in the direction which now is up-down.

If I manually (ie by using the Minus button in the tool bar) make the image substantially smaller than the size of the Editor window in left-right direction (while the image is still in the original orientation) and THEN click ‘Fit whole image to screen’, the image is displayed completely in the initial orientation, ie turned 90 degrees clockwise. After turning it 90 degrees counter-clockwise, it is snapped to the left edge of the Editor window, and there is room left at right. If I then click ‘Fit whole image to screen’ again, the image is again clipped at right.

The Navigator and the little preview image in the film strip (?) at top (over the tool bar) show the complete image.

The image is a RAF from a Fuji E900, 9MPx.

There is another clipping problem: The Name field in the top of the Queue window is clipped, see screen shot ‘Name field clipped’.

I have uploaded the raw, the pp3 and 3 screen shots in a folder called ‘RT upload 2018.09.16’:

Have you tried the other themes? Please try the toowaboo dark theme to see if it is better. The theme is selectable in the preferences window.

It is worse. The tool bars in the Editor are clipped so much that the ‘Fit whole image to screen’ button is not visible. And the image is correspondingly more clipped (but larger). Also the font in the File Browser seems larger.

I use the default theme and font sizes 8 or 9. Also try changing the Editor Layout. Restart when you are done with the preferences. Things are better in the dev releases if you want to give them a try. See: Download RawTherapee development builds.

Hi afre,

thank for your post. But already text size 10 is almost unreadable for me on my 96 ppi screen. Also I’m afraid that dev builds are not for me.

If I can contribute by supplying further info, let me know. For the rest, I settle with 5.4 as is, adjusting the image size manually.

Thanks again to all who replied!

dev is the only way to test changes the devs make to RT.

Hi Hiram,

there are no dev builds for Mac.

BTW I understand that bug reports should be posted on Github, not on the forum. But Github is unaccessible. The combination of user name and password I have on file for myself is rejected. If I try to create a new one, the user name is “already taken” - regardless what I enter.

Check again. I see it now.

You are welcome to post your concerns here; however, filing the issue at GitHub is the fastest way to bring about change.

No, I don’t see dev builds for Mac 9/10/11. I can wait until changes have found their way to a stable version.

I see. Don’t know if @HIRAM would be interested in building for legacy Mac OS X.

He shall not bother for me. As said, I can wait for a stable version.
– Well I did not see my Mac version as ‘legacy’. But yes I delay using new versions as long as possible.

Officially Apple supports only the current and previous versions of macOS. So lots of things are “legacy.” :wink:

You could always use virtualization or dual boot Linux. In fact, when I had a Mac in the past, virtualization seemed to be faster on my Mac than a PC.

Check in the link @afre posted above. Download RawTherapee development builds
Should work for OS X 10.9 and above. Just built this morning.

So I tested the dev version.


The clipping of the tool bars is the same.

After I loaded my processing profile, changed the Output profile form RTv4_large to RT_v2Large and overwrote my processing profile with this change, i.e. keeping the same name, RT froze, so I could not test more. I had to force quit.

So I think I go back to the stable version of 5.4…

All the above was with a Fuji image, and Fuji has sometimes peculiar file formats. But I just tried with a file from the Canon 5D2, and it was the same.