Specific ARW files are simply black

I am using Rawtherapee with McGimp. Everything is working fine.
I came across some same files (https://www.imaging-resource.com/lenses/sony/fe-24mm-f1.4-gm-sel24f14gm/gallery-images/), and I downloaded a large test ARW file, Y-JS-24MM-DSC00049.ARW, and opened with McGimp 2.10.20. Rawtherapee (5.8.0) opened like it’s supposed to and indicated that the file was open. Everything reflects that the file is open, BUT there is no image, only a black rectangle. A pp3 file is created. Everything seems just fine, but no image.
I have no problems with any other formats in any other sizes.

What am I missing? What is the problem?

Not sure what is going on with those files. RawTherapee detects the camera as Sonly ILCE-7RM3, but all files on https://raw.pixls.us with that type open fine (12 or 14 bit, compressed or uncompressed, and pixel shift).
@heckflosse This is a bug?

I get this in console:

...Y-JS-24MM-DSC00049.ARW: Unexpected end of file

You are right Ingo, @Marc_Grober that specific file seems corrupted.

hmmmmm…
tried two others from same repository to same effect.
not a stopper for me on any project, but just thought I should run it up the pole in case it was a bug - have you tried any of the other ARW files at that site?

There is an open issue on github concerning this issue. Mainly it’s about not failing on uncompressed raw files during decode. Have to dig it out …

Edit: to be more precise: the metadata of the raw files tells to read x*y values. If there are less then x*y values to read, you get the black result. The solution is to not error in this case, but give you only a black result for the missing pixels.