ST mapping does not work for me


#1

Hi, I am trying to make ST mapping work.

I put a multipass EXR-file to a STmap-node, defined a source image and set U and V to their according channels. What am I doing wrong?

Here are my diffuse and UV passes:
passes

postcard_test.exr (1.2 MB)

Here is a screenshot:


#2

Just make sure the incoming Alpha is correct. For testing purposes you can set it to white (1):

Cheers,
Josef


#3

Thank you Josef, it works, which is great! But how can I prevent the dark borders around my postcards?

I played around with some (un)premultiply settings and switched the shuffleUV`s alpha to one of my channels called “Front.R”, but it still remains .


#4

How does your alpha look like? The artefacts shouldn’t appear in case your alpha is correct.


#5

The alpha channels (red and green) are included in the file above and they are razor sharp:

I was able to reduce the unwanted borders slightly by disabling “black outside” on the STmap-node. Nevertheless, its still very much visible:


#6

After shifting the UV offset values in the STmap-node a bit I think it has more to do with my ST map overlapping than with the alpha map. There are some transition zones that on the edges that mix up the ST-coordinates.

ST_overlapping

I should probably separate my ST-map in front and back sides (and maybe even apply some bleeding which gets cut away by alpha later?).