Starless .fit file blank, or flat gray, in Siril

My OS is WIN11
Siril version 1.2.3
multiple night stack in Sirilic V1.15.2
My flow includes: crop, background extraction, remove green, photometric colour calibration
then starnet with prestretch checked and starmask checked.

Most of the time this produces great results, however, occasionally, the starless image is blank, a gray image. The starless image opens normally with a stretched view; when I open histogram transformation, the stretched view becomes linear (normal), but when I stretch the view the image is blank, a flat grey screen.

I found that the starless image is a good file, because, I can open and process it it pixinsight. Siril is not able to process the file tho.

Any ideas on how to solve this?

Hello, and welcome.
Pictures shot from smartphone are awful. There’s nothing we can say on these low quality images.
We need:

  • Screenshot taken from the computer
  • A FITS file, to test it.

This page could help you to report issue you encountered: How to report issues — Siril 1.2.0 documentation

Thank-you for the help.

is the wetransfer link.

I deleted the processing and .fits file that generated the attached phone pics. I have had this issue a few times and I’ve tried restacking/processing the data a few times in the hope of getting a good result. I stacked the images and processed again to include the result with you.

I include the starless .fits, log, and screenshot of starless in autostretch and starless in linear with the autostretch algorithm applied which has resulted in a black screen this time.

I also have the cropped, calibrated .fits file as it is prior to applying starnet that I could also include, if this may help.

versions and OS are still the same as originally posted.



I think that I created a gitlab bug.
I included the bkg calibrated fits file that I was trying to process as well as the same files in this thread.