Strange artifacts, stretching, pixelating...

Hi. I am new to darktable and ran in to problems with editing photos. Tried working with several different files (Png, Jpg, Tiff, CR2) and i am getting strange artifacts and blown out images as soon i move any slider. Basically the photos are imported correctly but as soon as i move ANY slider and start adjusting the photos i get random stretching and artifacts, sometimes it takes up to 30 sec to get the photo to apply the setting or to undo.
I work on laptop Win10, all hardware up to date ( Rizen5 8Cores, Nvidia 1660Ti dedicated card, 8GB RAM) I use a lot astrophotography images and different stacking, image processing software w/o any issues and good processing times.
I already tried reinstalling darkroom, bring all defaults and still ran in to same issue. The screenshot is one of the examples.
Thanks in advance, and i greatly appreciate an advice or if you need some more info i will provide it.

You could try an image from the playraw section here for comparision. Also, you could deactivate OpenCL if active and see if this helps.

Thanks Thomas. Deactivating Open CL fixed the problem. So far works well, no artifacts and speed is instant

I also use a Ryzen with an NVidia card (1060), with OpenCL enabled (on Linux), and have no problems. Is it specifically the astrophoto denoise module that causes issued? Could you please upload such an image, along with the XMP sidecar file?
If you run from the command-line, with -d perf -d opencl, do you see any errors?

Hi. It was not specifically to denoise, it was doing on pretty much all modules light, contrast, sat, exposure…etc. I just turned ON and OFF OpenCL few times. With OpenCL ON it it kind of sluggish and i see some artifacts, With OpenCL OFF it runs smooth and no artifacts.
As for the test, where should i ran it, the CMD or built in from darktable? I would like to figure out too and maybe report to the devs as a bug or some other issue.

Maybe something like DDU/clean video driver install may help.

I’ll try the video drivers for sure, may be some GPU driver related issue.
Like i said, i am new to the darkroom, and i love it so far. I have some experience with LR but DR definitely offer some great possibilities.
With that said, what would be a down/UP side of running OpenCL OFF or ON? Any quality/performance pro’s/cons?

OpenCL uses your video card to accelerate operations – some may take 20x as much without OpenCL, even on a fast CPU (e.g. the new diffuse or sharpen that will come with 3.8).

Without OpenCL (Ryzen 5 5600X):
diffuse or sharpen:
3879.615652 [dev_pixelpipe] took 1.135 secs (12.343 CPU) processed 'diffuse or sharpen' on CPU, blended on CPU [export]
complete export pipeline:
3880.551319 [dev_process_export] pixel pipeline processing took 2.793 secs (30.141 CPU)

With OpenCL (NVidia 1060):
diffuse or sharpen:
3860.361571 [dev_pixelpipe] took 0.200 secs (0.160 CPU) processed 'diffuse or sharpen' on GPU, blended on GPU [export]
complete export pipeline:
3860.475269 [dev_process_export] pixel pipeline processing took 0.550 secs (0.758 CPU)

Running from the command-line: darktable 3.6 user manual - darktable
I simply use:
darktable -d opencl -d perf
(-d stands for debug (more verbose logging))

Thank you all for the quick response. I will try little bit later to work on updating the GPU’s latest drivers, or reinstalling them. Seems to be some GPU issue. I will try that before anything and i will keep you posted.