SVG Files: Showing Wrong Pixel Format Errors - Natron

Natron 2.3.13 has a problem with displaying SVG files from Inkscape and Adobe illustrator color layer channels and layer alpha channels.

The image below shows the image as Color.RGB when no problems.

The image below gives an error about wrong pixel values when trying to display and animate the additional color channel layers.

If anyone experiencing this current problem and have a workaround for the time being, please advise.

Can you post the sample SVG file here (zipped) ?
Does Natron 2.3.12 have this problem?


I had a copy of Natron 2.3.12 installed and the SVG file from AI or Inkscape worked. Its just Natron 2.3.13 that are having issues.

SVG.7z (2.2 KB)

Attached is the SVG file.Untitled-1

Thanks Fred

will be fixed, see SVG Files: Showing Wrong Pixel Format Errors · Issue #292 · NatronGitHub/Natron · GitHub
I just need a bit of time

Thanks. Its not a show stopper. A workaround would be only to activate and save the layers that will be in a background and save the layers that are to be animated to a separate file. Merge in Natron for animation.

Attached is an example of that:

Should be fixed in next snapshot, please try.

Will do and thanks.

I have this issue in 2.4 is that a regression?

Can you specify the problem and the platform you are using?

Did it work in 2.3.15?

Platform is Linux. I can show a whole Inkscape SVG, but as soon as I select any individual path in the Merge node, I get the error Read1 error: Wrong pixel format.
I haven’t tested previous versions just found this thread when searching for this error related to SVG.

Sorry for the late reply, are you able to provide a SVG where this problem happens?

:wave: Hi, I am facing the same problem too.

I am running Natron 2.4.0 from on Fedora 33.

I am attaching the SVG I face this problem with.

It’s a white colored set of graphics, it looks like the preview makes it show up as a white on white thumbnail. It might be easier to download from this link:

1 Like

I just did some testing by rolling back the flatpak back each version until this feature worked.

The 2.3.14 version (2020-06-09) allows me to select individual paths from the SVG I attached and linked to above without any issue and they display perfectly. The commit I used to roll back to this version is 27e83684c545e26300b04add69c68aa37e8936c73394a4fec5a7b4a7257d97aa

The following newer versions I also tested and they had the bug:

Commit: 57c4883d980de2dfeeb804ebc8bffff7231bd8e03a1acd1e8465f128f7b5c5dc
Parent: 32e3abdd66dd0f8630ad11c0dea98134c7982e275706b895df80c2219e350f96

Subject: Fix libheif (36dc6805)
Date: 2021-05-31 18:44:45 +0000

Commit: 32e3abdd66dd0f8630ad11c0dea98134c7982e275706b895df80c2219e350f96

Subject: Build fixes (9d2d744a)
Date: 2021-04-22 20:51:09 +0000

Commit: 9a18809dea322ea79411cbffebcf7b897bf8f860e909cfa2d570144514905fbe

Subject: Move openfx-misc to CMake (fe01f15f)
Date: 2020-06-18 10:54:45 +0000

That first version in the list there is 2.4.0.

So the bug must have been reintroduced between 2.3.14 and the version released 2020-06-18

1 Like

The SVG works fine, please try the official binaries for Linux.

@rodlie I used the flatpak from the official linux on -

Download > Linux > Flatpak, links me to here:

I followed the instructions there, it installs 2.4.0, and that has the pixel format bug

I tried to install via RPM but it doesnt seem it is in the repos

official: Release Natron 2.4.0 · NatronGitHub/Natron · GitHub

1 Like

Oh thank you! I tried that and it does indeed work. So is there bug here with the flatpak? Do you know where I file an issue, if so?

Probably, the flatpak has had several issues in the past.

1 Like

FWIW if anyone wants to follow along

1 Like