System file dialog hidden when importing/exporting presets

When we import or export presets in darktable, a file manager window from the OS is used. In this case, on Mac, a Finder window. When I do this, the Finder window places itself behind the darktable popup window and is impossible to bring to the front. If I do it from the Preferences window, it looks like this for the global import/export:

and like this for single presets:

The same happens when exporting from the modules in darkroom:

It seems to be something specific to my system, because I have now tried on two Macs and one Linux system, ant this only appears on this one Mac. Both Macs (MacBook Pro) first had Ventura 13.5.2, then I updated mine to 13.6, but that didn’t help. All three systems have darktable 4.4.2. The only significant difference I can find between the Macs are that mine has an M1 Max and the other one has M2 Max.

I tried with OpenCL on and off, no difference.

I’ll report a bug at Github if it is confirmed by others, but so far it seems to be something local to my system. Anybody got an idea what might be wrong? @MStraeten perhaps?

Cannot reproduce this on my Intel MacBook Pro (2019).
The Finder window opens in foreground in all cases you described.

Just an idea: Do you have darktable assigned to open on a specific desktop? (right-click on the dock icon, options → assign to desktop…)
I have found some reports on this for other apps, but these are several years old.

No, I don’t even have it in the dock at the moment. Just open via Spotlight search (cmd-space). And other icons in the dock don’t have this option, so I never knew about it :slight_smile:

Are you using multiple screens? Do you have for example a second monitor attached to the laptop?

I normally do, but this also happens when I don’t.