Test the latest RawTherapee AppImage


(Morgan Hardwood) #1

@Carmelo_DrRaw created a new RawTherapee AppImage and we need you to simply run it and tell us if it works, and especially tell us if it doesn’t run.

An AppImage is a single file which contains all the components necessary to run a program in any Linux distro. As some distros provide old versions of certain programs, the AppImage is a great solution for letting users of those systems run the latest version of a given program.

To test:

  1. Download the AppImage [106MB].
  2. Open a terminal, make the downloaded file it executable and run it:
    chmod +x RawTherapee-dev-5.4-693-gb80abe6.AppImage
    ./RawTherapee-dev-5.4-693-gb80abe6.AppImage
    
  3. Reply and let us know how it went. If it didn’t run, tell us which distro you’re using (name + version number) and paste the log from the terminal.

(Silvio) #2

Hello everyone,

I only run Windows 10 on my computers but with VirtualBox I have tested this AppImage on Kubuntu 18.04.01 (Kde desktop)
Everything looks fine: no crash so far! :slight_smile:

Thanks a lot for your hard work: It is really appreciated!
RawTherapee rocks !


(Eduardo Pérez) #3

Despite some warnings, works perfectly on Fedora 28:

AILIBDIR=/tmp/ailibdir.G1WE
deleting /tmp/ailibdir.G1WE/libxcb-dri3.so*
System stdc++ library: "/lib64/libstdc++.so.6"
System stdc++ library version: "3.4.25"
Bundled stdc++ library version: "3.4.22"
Newest stdc++ library version: "3.4.25"
Using system stdc++ library
fcv: "1.11.1"  fcv2: "1.7.0"
echo "1.11.1 1.7.0" | tr " " "\n" | sort -V | tail -n 1
Newest fontconfig library version: "1.11.1"
Using system fontconfig library
	linux-vdso.so.1 (0x00007ffde653d000)
	libcanberra-gtk3.so.0 => /tmp/ailibdir.G1WE/libcanberra-gtk3.so.0 (0x00007f0946d8b000)
	libX11.so.6 => /lib64/libX11.so.6 (0x00007f0946a4a000)
	libcanberra.so.0 => /tmp/ailibdir.G1WE/libcanberra.so.0 (0x00007f0946839000)
	libgtk-3.so.0 => /tmp/ailibdir.G1WE/libgtk-3.so.0 (0x00007f0945f26000)
	libgdk-3.so.0 => /tmp/ailibdir.G1WE/libgdk-3.so.0 (0x00007f0945c3a000)
	libatk-1.0.so.0 => /tmp/ailibdir.G1WE/libatk-1.0.so.0 (0x00007f0945a14000)
	libgio-2.0.so.0 => /tmp/ailibdir.G1WE/libgio-2.0.so.0 (0x00007f0945679000)
	libpangocairo-1.0.so.0 => /tmp/ailibdir.G1WE/libpangocairo-1.0.so.0 (0x00007f094546c000)
	libgdk_pixbuf-2.0.so.0 => /tmp/ailibdir.G1WE/libgdk_pixbuf-2.0.so.0 (0x00007f0945244000)
	libcairo-gobject.so.2 => /tmp/ailibdir.G1WE/libcairo-gobject.so.2 (0x00007f094503b000)
	libpango-1.0.so.0 => /tmp/ailibdir.G1WE/libpango-1.0.so.0 (0x00007f0944df0000)
	libcairo.so.2 => /tmp/ailibdir.G1WE/libcairo.so.2 (0x00007f0944ac8000)
	libgobject-2.0.so.0 => /tmp/ailibdir.G1WE/libgobject-2.0.so.0 (0x00007f0944877000)
	libglib-2.0.so.0 => /tmp/ailibdir.G1WE/libglib-2.0.so.0 (0x00007f0944563000)
	libexpat.so.1 => /lib64/libexpat.so.1 (0x00007f0944328000)
	libfftw3f.so.3 => /tmp/ailibdir.G1WE/libfftw3f.so.3 (0x00007f0943faf000)
	libfftw3f_omp.so.3 => /tmp/ailibdir.G1WE/libfftw3f_omp.so.3 (0x00007f0943da8000)
	libgiomm-2.4.so.1 => /tmp/ailibdir.G1WE/libgiomm-2.4.so.1 (0x00007f09439ea000)
	libglibmm-2.4.so.1 => /tmp/ailibdir.G1WE/libglibmm-2.4.so.1 (0x00007f094376a000)
	libsigc-2.0.so.0 => /tmp/ailibdir.G1WE/libsigc-2.0.so.0 (0x00007f0943563000)
	libgthread-2.0.so.0 => /tmp/ailibdir.G1WE/libgthread-2.0.so.0 (0x00007f0943361000)
	libgtkmm-3.0.so.1 => /tmp/ailibdir.G1WE/libgtkmm-3.0.so.1 (0x00007f0942bb3000)
	libatkmm-1.6.so.1 => /tmp/ailibdir.G1WE/libatkmm-1.6.so.1 (0x00007f0942965000)
	libgdkmm-3.0.so.1 => /tmp/ailibdir.G1WE/libgdkmm-3.0.so.1 (0x00007f0942711000)
	libpangomm-1.4.so.1 => /tmp/ailibdir.G1WE/libpangomm-1.4.so.1 (0x00007f09424e3000)
	libcairomm-1.0.so.1 => /tmp/ailibdir.G1WE/libcairomm-1.0.so.1 (0x00007f09422bd000)
	libiptcdata.so.0 => /tmp/ailibdir.G1WE/libiptcdata.so.0 (0x00007f09420b1000)
	libjpeg.so.62 => /tmp/ailibdir.G1WE/libjpeg.so.62 (0x00007f0941e5c000)
	liblcms2.so.2 => /tmp/ailibdir.G1WE/liblcms2.so.2 (0x00007f0941c02000)
	libpng15.so.15 => /tmp/ailibdir.G1WE/libpng15.so.15 (0x00007f09419d7000)
	libz.so.1 => /lib64/libz.so.1 (0x00007f09417c0000)
	libtiff.so.5 => /tmp/ailibdir.G1WE/libtiff.so.5 (0x00007f0941549000)
	liblensfun.so.1 => /tmp/ailibdir.G1WE/liblensfun.so.1 (0x00007f094132a000)
	libm.so.6 => /lib64/libm.so.6 (0x00007f0940f96000)
	libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007f0940c04000)
	libgomp.so.1 => /lib64/libgomp.so.1 (0x00007f09409d4000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f09407bc000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f094059d000)
	libc.so.6 => /lib64/libc.so.6 (0x00007f09401de000)
	libvorbisfile.so.3 => /tmp/ailibdir.G1WE/libvorbisfile.so.3 (0x00007f093ffd5000)
	libvorbis.so.0 => /tmp/ailibdir.G1WE/libvorbis.so.0 (0x00007f093fda8000)
	libogg.so.0 => /tmp/ailibdir.G1WE/libogg.so.0 (0x00007f093fba1000)
	libtdb.so.1 => /tmp/ailibdir.G1WE/libtdb.so.1 (0x00007f093f98a000)
	libltdl.so.7 => /tmp/ailibdir.G1WE/libltdl.so.7 (0x00007f093f780000)
	libxcb.so.1 => /lib64/libxcb.so.1 (0x00007f093f557000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007f093f353000)
	libgmodule-2.0.so.0 => /tmp/ailibdir.G1WE/libgmodule-2.0.so.0 (0x00007f093f14f000)
	libXi.so.6 => /tmp/ailibdir.G1WE/libXi.so.6 (0x00007f093ef3f000)
	libXfixes.so.3 => /tmp/ailibdir.G1WE/libXfixes.so.3 (0x00007f093ed39000)
	libatk-bridge-2.0.so.0 => /tmp/ailibdir.G1WE/libatk-bridge-2.0.so.0 (0x00007f093eb0a000)
	libepoxy.so.0 => /tmp/ailibdir.G1WE/libepoxy.so.0 (0x00007f093e815000)
	libpangoft2-1.0.so.0 => /tmp/ailibdir.G1WE/libpangoft2-1.0.so.0 (0x00007f093e5ff000)
	libfontconfig.so.1 => /lib64/libfontconfig.so.1 (0x00007f093e3bb000)
	libXinerama.so.1 => /tmp/ailibdir.G1WE/libXinerama.so.1 (0x00007f093e1b8000)
	libXrandr.so.2 => /tmp/ailibdir.G1WE/libXrandr.so.2 (0x00007f093dfad000)
	libXcursor.so.1 => /tmp/ailibdir.G1WE/libXcursor.so.1 (0x00007f093dda2000)
	libXcomposite.so.1 => /tmp/ailibdir.G1WE/libXcomposite.so.1 (0x00007f093db9f000)
	libXdamage.so.1 => /tmp/ailibdir.G1WE/libXdamage.so.1 (0x00007f093d99c000)
	libxkbcommon.so.0 => /tmp/ailibdir.G1WE/libxkbcommon.so.0 (0x00007f093d75c000)
	libwayland-cursor.so.0 => /tmp/ailibdir.G1WE/libwayland-cursor.so.0 (0x00007f093d554000)
	libwayland-egl.so.1 => /tmp/ailibdir.G1WE/libwayland-egl.so.1 (0x00007f093d352000)
	libwayland-client.so.0 => /lib64/libwayland-client.so.0 (0x00007f093d143000)
	libXext.so.6 => /tmp/ailibdir.G1WE/libXext.so.6 (0x00007f093cf31000)
	librt.so.1 => /lib64/librt.so.1 (0x00007f093cd29000)
	libffi.so.6 => /tmp/ailibdir.G1WE/libffi.so.6 (0x00007f093cb21000)
	libpcre.so.1 => /tmp/ailibdir.G1WE/libpcre.so.1 (0x00007f093c8bf000)
	libselinux.so.1 => /lib64/libselinux.so.1 (0x00007f093c696000)
	libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f093c47f000)
	libmount.so.1 => /tmp/ailibdir.G1WE/libmount.so.1 (0x00007f093c23d000)
	libthai.so.0 => /tmp/ailibdir.G1WE/libthai.so.0 (0x00007f093c031000)
	libharfbuzz.so.0 => /tmp/ailibdir.G1WE/libharfbuzz.so.0 (0x00007f093bdce000)
	libfreetype.so.6 => /tmp/ailibdir.G1WE/libfreetype.so.6 (0x00007f093bb28000)
	libpixman-1.so.0 => /tmp/ailibdir.G1WE/libpixman-1.so.0 (0x00007f093b87f000)
	libEGL.so.1 => /lib64/libEGL.so.1 (0x00007f093b66b000)
	libxcb-shm.so.0 => /tmp/ailibdir.G1WE/libxcb-shm.so.0 (0x00007f093b467000)
	libxcb-render.so.0 => /tmp/ailibdir.G1WE/libxcb-render.so.0 (0x00007f093b259000)
	libXrender.so.1 => /tmp/ailibdir.G1WE/libXrender.so.1 (0x00007f093b04e000)
	libGL.so.1 => /lib64/libGL.so.1 (0x00007f093adbd000)
	liblzma.so.5 => /tmp/ailibdir.G1WE/liblzma.so.5 (0x00007f093ab97000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f0946f90000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007f093a96e000)
	libXau.so.6 => /tmp/ailibdir.G1WE/libXau.so.6 (0x00007f093a76a000)
	libatspi.so.0 => /tmp/ailibdir.G1WE/libatspi.so.0 (0x00007f093a53a000)
	libdbus-1.so.3 => /tmp/ailibdir.G1WE/libdbus-1.so.3 (0x00007f093a2ea000)
	libuuid.so.1 => /lib64/libuuid.so.1 (0x00007f093a0e3000)
	libpcre2-8.so.0 => /lib64/libpcre2-8.so.0 (0x00007f0939e63000)
	libblkid.so.1 => /tmp/ailibdir.G1WE/libblkid.so.1 (0x00007f0939c24000)
	libgraphite2.so.3 => /tmp/ailibdir.G1WE/libgraphite2.so.3 (0x00007f09399f6000)
	libGLdispatch.so.0 => /lib64/libGLdispatch.so.0 (0x00007f093973c000)
	libGLX.so.0 => /lib64/libGLX.so.0 (0x00007f093950a000)
	libsystemd.so.0 => /tmp/ailibdir.G1WE/libsystemd.so.0 (0x00007f09392d9000)
	libcap.so.2 => /tmp/ailibdir.G1WE/libcap.so.2 (0x00007f09390d4000)
	liblz4.so.1 => /tmp/ailibdir.G1WE/liblz4.so.1 (0x00007f0938ebf000)
	libgcrypt.so.11 => /tmp/ailibdir.G1WE/libgcrypt.so.11 (0x00007f0938c3e000)
	libgpg-error.so.0 => /lib64/libgpg-error.so.0 (0x00007f0938a1e000)
	libdw.so.1 => /tmp/ailibdir.G1WE/libdw.so.1 (0x00007f09387d7000)
	libattr.so.1 => /tmp/ailibdir.G1WE/libattr.so.1 (0x00007f09385d2000)
	libelf.so.1 => /tmp/ailibdir.G1WE/libelf.so.1 (0x00007f09383ba000)
	libbz2.so.1 => /tmp/ailibdir.G1WE/libbz2.so.1 (0x00007f09381aa000)
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"

(rawtherapee:14446): Gtk-WARNING **: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/check-symbolic.svg.
This may indicate that pixbuf loaders or the mime database could not be found.

(Mica) #4

Working well on KDE Neon 16.04


(Fernando Ossandon) #5

Works fine under Ubuntu 16.04.5 LTS. Just a Gtk-WARNING at the end. Terminal log:

fer@fer-ThinkPad-T61:/mnt/418GB/fer/Downloads2$ ./RawTherapee-dev-5.4-693-gb80abe6.AppImage
AILIBDIR=/tmp/ailibdir.Fime
System stdc++ library: “/usr/lib/x86_64-linux-gnu/libstdc++.so.6”
System stdc++ library version: “3.4.21”
Bundled stdc++ library version: “3.4.22”
Newest stdc++ library version: “3.4.22”
Using bundled stdc++ library
fcv: “1.9.0” fcv2: “1.7.0”
echo “1.9.0 1.7.0” | tr " " “\n” | sort -V | tail -n 1
Newest fontconfig library version: “1.9.0”
Using system fontconfig library
linux-vdso.so.1 => (0x00007ffe719dc000)
libcanberra-gtk3.so.0 => /tmp/ailibdir.Fime/libcanberra-gtk3.so.0 (0x00007f0b9c93b000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f0b9c601000)
libcanberra.so.0 => /tmp/ailibdir.Fime/libcanberra.so.0 (0x00007f0b9c3f0000)
libgtk-3.so.0 => /tmp/ailibdir.Fime/libgtk-3.so.0 (0x00007f0b9badd000)
libgdk-3.so.0 => /tmp/ailibdir.Fime/libgdk-3.so.0 (0x00007f0b9b7f1000)
libatk-1.0.so.0 => /tmp/ailibdir.Fime/libatk-1.0.so.0 (0x00007f0b9b5cb000)
libgio-2.0.so.0 => /tmp/ailibdir.Fime/libgio-2.0.so.0 (0x00007f0b9b230000)
libpangocairo-1.0.so.0 => /tmp/ailibdir.Fime/libpangocairo-1.0.so.0 (0x00007f0b9b023000)
libgdk_pixbuf-2.0.so.0 => /tmp/ailibdir.Fime/libgdk_pixbuf-2.0.so.0 (0x00007f0b9adfb000)
libcairo-gobject.so.2 => /tmp/ailibdir.Fime/libcairo-gobject.so.2 (0x00007f0b9abf2000)
libpango-1.0.so.0 => /tmp/ailibdir.Fime/libpango-1.0.so.0 (0x00007f0b9a9a7000)
libcairo.so.2 => /tmp/ailibdir.Fime/libcairo.so.2 (0x00007f0b9a67f000)
libgobject-2.0.so.0 => /tmp/ailibdir.Fime/libgobject-2.0.so.0 (0x00007f0b9a42e000)
libglib-2.0.so.0 => /tmp/ailibdir.Fime/libglib-2.0.so.0 (0x00007f0b9a11a000)
libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f0b99ef1000)
libfftw3f.so.3 => /tmp/ailibdir.Fime/libfftw3f.so.3 (0x00007f0b99b78000)
libfftw3f_omp.so.3 => /tmp/ailibdir.Fime/libfftw3f_omp.so.3 (0x00007f0b99971000)
libgiomm-2.4.so.1 => /tmp/ailibdir.Fime/libgiomm-2.4.so.1 (0x00007f0b995b3000)
libglibmm-2.4.so.1 => /tmp/ailibdir.Fime/libglibmm-2.4.so.1 (0x00007f0b99333000)
libsigc-2.0.so.0 => /tmp/ailibdir.Fime/libsigc-2.0.so.0 (0x00007f0b9912c000)
libgthread-2.0.so.0 => /tmp/ailibdir.Fime/libgthread-2.0.so.0 (0x00007f0b98f2a000)
libgtkmm-3.0.so.1 => /tmp/ailibdir.Fime/libgtkmm-3.0.so.1 (0x00007f0b9877c000)
libatkmm-1.6.so.1 => /tmp/ailibdir.Fime/libatkmm-1.6.so.1 (0x00007f0b9852e000)
libgdkmm-3.0.so.1 => /tmp/ailibdir.Fime/libgdkmm-3.0.so.1 (0x00007f0b982da000)
libpangomm-1.4.so.1 => /tmp/ailibdir.Fime/libpangomm-1.4.so.1 (0x00007f0b980ac000)
libcairomm-1.0.so.1 => /tmp/ailibdir.Fime/libcairomm-1.0.so.1 (0x00007f0b97e86000)
libiptcdata.so.0 => /tmp/ailibdir.Fime/libiptcdata.so.0 (0x00007f0b97c7a000)
libjpeg.so.62 => /tmp/ailibdir.Fime/libjpeg.so.62 (0x00007f0b97a25000)
liblcms2.so.2 => /tmp/ailibdir.Fime/liblcms2.so.2 (0x00007f0b977cb000)
libpng15.so.15 => /tmp/ailibdir.Fime/libpng15.so.15 (0x00007f0b975a0000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f0b97386000)
libtiff.so.5 => /tmp/ailibdir.Fime/libtiff.so.5 (0x00007f0b9710f000)
liblensfun.so.1 => /tmp/ailibdir.Fime/liblensfun.so.1 (0x00007f0b96ef0000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f0b96be7000)
libstdc++.so.6 => /tmp/ailibdir.Fime/libstdc++.so.6 (0x00007f0b96867000)
libgomp.so.1 => /tmp/ailibdir.Fime/libgomp.so.1 (0x00007f0b9663b000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f0b96425000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f0b96208000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f0b95e3e000)
libvorbisfile.so.3 => /tmp/ailibdir.Fime/libvorbisfile.so.3 (0x00007f0b95c35000)
libvorbis.so.0 => /tmp/ailibdir.Fime/libvorbis.so.0 (0x00007f0b95a08000)
libogg.so.0 => /tmp/ailibdir.Fime/libogg.so.0 (0x00007f0b95801000)
libtdb.so.1 => /tmp/ailibdir.Fime/libtdb.so.1 (0x00007f0b955ea000)
libltdl.so.7 => /tmp/ailibdir.Fime/libltdl.so.7 (0x00007f0b953e0000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f0b951be000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f0b94fba000)
libgmodule-2.0.so.0 => /tmp/ailibdir.Fime/libgmodule-2.0.so.0 (0x00007f0b94db6000)
libXi.so.6 => /tmp/ailibdir.Fime/libXi.so.6 (0x00007f0b94ba6000)
libXfixes.so.3 => /tmp/ailibdir.Fime/libXfixes.so.3 (0x00007f0b949a0000)
libatk-bridge-2.0.so.0 => /tmp/ailibdir.Fime/libatk-bridge-2.0.so.0 (0x00007f0b94771000)
libepoxy.so.0 => /tmp/ailibdir.Fime/libepoxy.so.0 (0x00007f0b9447c000)
libpangoft2-1.0.so.0 => /tmp/ailibdir.Fime/libpangoft2-1.0.so.0 (0x00007f0b94266000)
libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f0b94023000)
libXinerama.so.1 => /tmp/ailibdir.Fime/libXinerama.so.1 (0x00007f0b93e20000)
libXrandr.so.2 => /tmp/ailibdir.Fime/libXrandr.so.2 (0x00007f0b93c15000)
libXcursor.so.1 => /tmp/ailibdir.Fime/libXcursor.so.1 (0x00007f0b93a0a000)
libXcomposite.so.1 => /tmp/ailibdir.Fime/libXcomposite.so.1 (0x00007f0b93807000)
libXdamage.so.1 => /tmp/ailibdir.Fime/libXdamage.so.1 (0x00007f0b93604000)
libxkbcommon.so.0 => /tmp/ailibdir.Fime/libxkbcommon.so.0 (0x00007f0b933c4000)
libwayland-cursor.so.0 => /tmp/ailibdir.Fime/libwayland-cursor.so.0 (0x00007f0b931bc000)
libwayland-egl.so.1 => /tmp/ailibdir.Fime/libwayland-egl.so.1 (0x00007f0b92fba000)
libwayland-client.so.0 => /usr/lib/x86_64-linux-gnu/libwayland-client.so.0 (0x00007f0b92dab000)
libXext.so.6 => /tmp/ailibdir.Fime/libXext.so.6 (0x00007f0b92b99000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f0b92991000)
libffi.so.6 => /tmp/ailibdir.Fime/libffi.so.6 (0x00007f0b92789000)
libpcre.so.1 => /tmp/ailibdir.Fime/libpcre.so.1 (0x00007f0b92527000)
libselinux.so.1 => /lib/x86_64-linux-gnu/libselinux.so.1 (0x00007f0b92305000)
libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f0b920ea000)
libmount.so.1 => /tmp/ailibdir.Fime/libmount.so.1 (0x00007f0b91ea8000)
libthai.so.0 => /tmp/ailibdir.Fime/libthai.so.0 (0x00007f0b91c9c000)
libharfbuzz.so.0 => /tmp/ailibdir.Fime/libharfbuzz.so.0 (0x00007f0b91a39000)
libfreetype.so.6 => /tmp/ailibdir.Fime/libfreetype.so.6 (0x00007f0b91793000)
libpixman-1.so.0 => /tmp/ailibdir.Fime/libpixman-1.so.0 (0x00007f0b914ea000)
libEGL.so.1 => /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1 (0x00007f0b912b0000)
libxcb-shm.so.0 => /tmp/ailibdir.Fime/libxcb-shm.so.0 (0x00007f0b910ac000)
libxcb-render.so.0 => /tmp/ailibdir.Fime/libxcb-render.so.0 (0x00007f0b90e9e000)
libXrender.so.1 => /tmp/ailibdir.Fime/libXrender.so.1 (0x00007f0b90c93000)
libGL.so.1 => /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 (0x00007f0b90a1f000)
liblzma.so.5 => /tmp/ailibdir.Fime/liblzma.so.5 (0x00007f0b907f9000)
/lib64/ld-linux-x86-64.so.2 (0x00007f0b9cb40000)
libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007f0b905c1000)
libXau.so.6 => /tmp/ailibdir.Fime/libXau.so.6 (0x00007f0b903bd000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f0b901b7000)
libatspi.so.0 => /tmp/ailibdir.Fime/libatspi.so.0 (0x00007f0b8ff87000)
libdbus-1.so.3 => /tmp/ailibdir.Fime/libdbus-1.so.3 (0x00007f0b8fd37000)
libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f0b8fac7000)
libblkid.so.1 => /tmp/ailibdir.Fime/libblkid.so.1 (0x00007f0b8f888000)
libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f0b8f683000)
libgraphite2.so.3 => /tmp/ailibdir.Fime/libgraphite2.so.3 (0x00007f0b8f455000)
libxcb-dri2.so.0 => /tmp/ailibdir.Fime/libxcb-dri2.so.0 (0x00007f0b8f250000)
libX11-xcb.so.1 => /tmp/ailibdir.Fime/libX11-xcb.so.1 (0x00007f0b8f04e000)
libxcb-dri3.so.0 => /tmp/ailibdir.Fime/libxcb-dri3.so.0 (0x00007f0b8ee4b000)
libxcb-present.so.0 => /tmp/ailibdir.Fime/libxcb-present.so.0 (0x00007f0b8ec48000)
libxcb-xfixes.so.0 => /tmp/ailibdir.Fime/libxcb-xfixes.so.0 (0x00007f0b8ea40000)
libxcb-sync.so.1 => /tmp/ailibdir.Fime/libxcb-sync.so.1 (0x00007f0b8e839000)
libxshmfence.so.1 => /tmp/ailibdir.Fime/libxshmfence.so.1 (0x00007f0b8e636000)
libgbm.so.1 => /usr/lib/x86_64-linux-gnu/libgbm.so.1 (0x00007f0b8e428000)
libwayland-server.so.0 => /usr/lib/x86_64-linux-gnu/libwayland-server.so.0 (0x00007f0b8e216000)
libmirclient.so.9 => /usr/lib/x86_64-linux-gnu/libmirclient.so.9 (0x00007f0b8df6f000)
libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007f0b8dd5d000)
libglapi.so.0 => /tmp/ailibdir.Fime/libglapi.so.0 (0x00007f0b8db2d000)
libxcb-glx.so.0 => /tmp/ailibdir.Fime/libxcb-glx.so.0 (0x00007f0b8d912000)
libXxf86vm.so.1 => /tmp/ailibdir.Fime/libXxf86vm.so.1 (0x00007f0b8d70c000)
libsystemd.so.0 => /tmp/ailibdir.Fime/libsystemd.so.0 (0x00007f0b8d4db000)
libmircommon.so.7 => /usr/lib/x86_64-linux-gnu/libmircommon.so.7 (0x00007f0b8d294000)
libmirprotobuf.so.3 => /usr/lib/x86_64-linux-gnu/libmirprotobuf.so.3 (0x00007f0b8d022000)
libcapnp-0.5.3.so => /usr/lib/x86_64-linux-gnu/libcapnp-0.5.3.so (0x00007f0b8cd9a000)
libmircore.so.1 => /usr/lib/x86_64-linux-gnu/libmircore.so.1 (0x00007f0b8cb91000)
libboost_system.so.1.58.0 => /usr/lib/x86_64-linux-gnu/libboost_system.so.1.58.0 (0x00007f0b8c98d000)
libprotobuf-lite.so.9 => /usr/lib/x86_64-linux-gnu/libprotobuf-lite.so.9 (0x00007f0b8c75c000)
libcap.so.2 => /tmp/ailibdir.Fime/libcap.so.2 (0x00007f0b8c557000)
liblz4.so.1 => /tmp/ailibdir.Fime/liblz4.so.1 (0x00007f0b8c342000)
libgcrypt.so.11 => /tmp/ailibdir.Fime/libgcrypt.so.11 (0x00007f0b8c0c1000)
libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f0b8bead000)
libdw.so.1 => /tmp/ailibdir.Fime/libdw.so.1 (0x00007f0b8bc66000)
libboost_filesystem.so.1.58.0 => /usr/lib/x86_64-linux-gnu/libboost_filesystem.so.1.58.0 (0x00007f0b8ba4e000)
libkj-0.5.3.so => /usr/lib/x86_64-linux-gnu/libkj-0.5.3.so (0x00007f0b8b825000)
libattr.so.1 => /tmp/ailibdir.Fime/libattr.so.1 (0x00007f0b8b620000)
libelf.so.1 => /tmp/ailibdir.Fime/libelf.so.1 (0x00007f0b8b408000)
libbz2.so.1 => /tmp/ailibdir.Fime/libbz2.so.1 (0x00007f0b8b1f8000)

(rawtherapee:7763): Gtk-WARNING **: Theme parsing error: gtk.css:1:66: Failed to import: The resource at “/org/numixproject/gtk-3.20/dist/gtk.css” does not exist
fer@fer-ThinkPad-T61:/mnt/418GB/fer/Downloads2$


(Felix) #6

Works, but when I launch GIMP from within RT to edit a picture, I get a prompt asking me to integrate RawTherapee(!) with my system. This does not happen on launch of RT and RT already has a .desktop file installed.


(Carmelo Dr Raw) #7

Dear all,

first of all, thanks a lot for the feedback!

I have done some more work on the AppImage package, and a new version is available here: https://github.com/Beep6581/RawTherapee/releases/download/nightly/RawTherapee-dev-5.4-752-g5471b34.AppImage

The main improvements are the following:

  • the appimage now correctly handles input images with relative paths
  • it is now possible to run the CLI version of RT by adding the --cli command line switch as first parameter, followed by the usual RT CLI options

Please give this newest version a try. If it works OK, I will recreate all other RT AppImage packages so that official downloads can also be updated.

Thanks!


(Syv) #8

doesn’t work for me:

Manjaro current. I get the following error message when loading:

/tmp/.mount_rawthe3DzqBx/usr/bin/rawtherapee: error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory

I do not have any libselinux library installed. Would this be appimage be built with redhat/centos?

Thanks

Syv


(Carmelo Dr Raw) #9

Yes, it is built under CentOS7. I have prepared yet another new package that provides the missing libselinux library. Could you give it a try?

Thanks!


(Syv) #10

Still doesn’t work. Now it does with an GTK error. Here the output:
(see the last 2 lines for the actual error)

$ downloads/appimages/RawTherapee-dev-5.4-752-g5471b34.AppImage 
AILIBDIR=/tmp/ailibdir.vLZi
deleting /tmp/ailibdir.vLZi/libxcb-dri3.so*
System stdc++ library: "/usr/lib/libstdc++.so.6"
System stdc++ library version: "3.4.25"
Bundled stdc++ library version: "3.4.22"
Newest stdc++ library version: "3.4.25"
Using system stdc++ library
atomiclib: /usr/lib/libatomic.so.1
fcv: "1.11.1"  fcv2: "1.7.0"
echo "1.11.1 1.7.0" | tr " " "\n" | sort -V | tail -n 1
Newest fontconfig library version: "1.11.1"
Using system fontconfig library
    linux-vdso.so.1 (0x00007ffcedbeb000)
    libcanberra-gtk3.so.0 => /tmp/ailibdir.vLZi/libcanberra-gtk3.so.0 (0x00007f236a268000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f2369f28000)
    libcanberra.so.0 => /tmp/ailibdir.vLZi/libcanberra.so.0 (0x00007f2369d10000)
    libgtk-3.so.0 => /tmp/ailibdir.vLZi/libgtk-3.so.0 (0x00007f23693f8000)
    libgdk-3.so.0 => /tmp/ailibdir.vLZi/libgdk-3.so.0 (0x00007f2369108000)
    libatk-1.0.so.0 => /tmp/ailibdir.vLZi/libatk-1.0.so.0 (0x00007f2368ee0000)
    libgio-2.0.so.0 => /tmp/ailibdir.vLZi/libgio-2.0.so.0 (0x00007f2368b40000)
    libpangocairo-1.0.so.0 => /tmp/ailibdir.vLZi/libpangocairo-1.0.so.0 (0x00007f2368930000)
    libgdk_pixbuf-2.0.so.0 => /tmp/ailibdir.vLZi/libgdk_pixbuf-2.0.so.0 (0x00007f2368708000)
    libcairo-gobject.so.2 => /tmp/ailibdir.vLZi/libcairo-gobject.so.2 (0x00007f23684f8000)
    libpango-1.0.so.0 => /tmp/ailibdir.vLZi/libpango-1.0.so.0 (0x00007f23682a8000)
    libcairo.so.2 => /tmp/ailibdir.vLZi/libcairo.so.2 (0x00007f2367f80000)
    libgobject-2.0.so.0 => /tmp/ailibdir.vLZi/libgobject-2.0.so.0 (0x00007f2367d28000)
    libglib-2.0.so.0 => /tmp/ailibdir.vLZi/libglib-2.0.so.0 (0x00007f2367a10000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f23677d8000)
    libatomic.so.1 => /usr/lib/libatomic.so.1 (0x00007f23677c8000)
    libfftw3f.so.3 => /tmp/ailibdir.vLZi/libfftw3f.so.3 (0x00007f2367448000)
    libfftw3f_omp.so.3 => /tmp/ailibdir.vLZi/libfftw3f_omp.so.3 (0x00007f2367240000)
    libgiomm-2.4.so.1 => /tmp/ailibdir.vLZi/libgiomm-2.4.so.1 (0x00007f2366e80000)
    libglibmm-2.4.so.1 => /tmp/ailibdir.vLZi/libglibmm-2.4.so.1 (0x00007f2366c00000)
    libsigc-2.0.so.0 => /tmp/ailibdir.vLZi/libsigc-2.0.so.0 (0x00007f23669f8000)
    libgthread-2.0.so.0 => /tmp/ailibdir.vLZi/libgthread-2.0.so.0 (0x00007f23667f0000)
    libgtkmm-3.0.so.1 => /tmp/ailibdir.vLZi/libgtkmm-3.0.so.1 (0x00007f2366040000)
    libatkmm-1.6.so.1 => /tmp/ailibdir.vLZi/libatkmm-1.6.so.1 (0x00007f2365df0000)
    libgdkmm-3.0.so.1 => /tmp/ailibdir.vLZi/libgdkmm-3.0.so.1 (0x00007f2365b98000)
    libpangomm-1.4.so.1 => /tmp/ailibdir.vLZi/libpangomm-1.4.so.1 (0x00007f2365968000)
    libcairomm-1.0.so.1 => /tmp/ailibdir.vLZi/libcairomm-1.0.so.1 (0x00007f2365740000)
    libiptcdata.so.0 => /tmp/ailibdir.vLZi/libiptcdata.so.0 (0x00007f2365530000)
    libjpeg.so.62 => /tmp/ailibdir.vLZi/libjpeg.so.62 (0x00007f23652d8000)
    liblcms2.so.2 => /tmp/ailibdir.vLZi/liblcms2.so.2 (0x00007f2365078000)
    libpng15.so.15 => /tmp/ailibdir.vLZi/libpng15.so.15 (0x00007f2364e48000)
    libz.so.1 => /usr/lib/libz.so.1 (0x00007f2364c30000)
    libtiff.so.5 => /tmp/ailibdir.vLZi/libtiff.so.5 (0x00007f23649b8000)
    liblensfun.so.1 => /tmp/ailibdir.vLZi/liblensfun.so.1 (0x00007f2364798000)
    libm.so.6 => /usr/lib/libm.so.6 (0x00007f2364610000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f2364480000)
    libgomp.so.1 => /usr/lib/libgomp.so.1 (0x00007f2364450000)
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f2364430000)
    libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f2364408000)
    libc.so.6 => /usr/lib/libc.so.6 (0x00007f2364240000)
    libvorbisfile.so.3 => /tmp/ailibdir.vLZi/libvorbisfile.so.3 (0x00007f2364030000)
    libvorbis.so.0 => /tmp/ailibdir.vLZi/libvorbis.so.0 (0x00007f2363e00000)
    libogg.so.0 => /tmp/ailibdir.vLZi/libogg.so.0 (0x00007f2363bf8000)
    libtdb.so.1 => /tmp/ailibdir.vLZi/libtdb.so.1 (0x00007f23639e0000)
    libltdl.so.7 => /tmp/ailibdir.vLZi/libltdl.so.7 (0x00007f23637d0000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f23635a0000)
    libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f2363598000)
    libgmodule-2.0.so.0 => /tmp/ailibdir.vLZi/libgmodule-2.0.so.0 (0x00007f2363390000)
    libXi.so.6 => /tmp/ailibdir.vLZi/libXi.so.6 (0x00007f2363180000)
    libXfixes.so.3 => /tmp/ailibdir.vLZi/libXfixes.so.3 (0x00007f2362f78000)
    libatk-bridge-2.0.so.0 => /tmp/ailibdir.vLZi/libatk-bridge-2.0.so.0 (0x00007f2362d48000)
    libepoxy.so.0 => /tmp/ailibdir.vLZi/libepoxy.so.0 (0x00007f2362a50000)
    libpangoft2-1.0.so.0 => /tmp/ailibdir.vLZi/libpangoft2-1.0.so.0 (0x00007f2362838000)
    libfontconfig.so.1 => /tmp/ailibdir.vLZi/libfontconfig.so.1 (0x00007f23625f8000)
    libXinerama.so.1 => /tmp/ailibdir.vLZi/libXinerama.so.1 (0x00007f23623f0000)
    libXrandr.so.2 => /tmp/ailibdir.vLZi/libXrandr.so.2 (0x00007f23621e0000)
    libXcursor.so.1 => /tmp/ailibdir.vLZi/libXcursor.so.1 (0x00007f2361fd0000)
    libXcomposite.so.1 => /tmp/ailibdir.vLZi/libXcomposite.so.1 (0x00007f2361dc8000)
    libXdamage.so.1 => /tmp/ailibdir.vLZi/libXdamage.so.1 (0x00007f2361bc0000)
    libxkbcommon.so.0 => /tmp/ailibdir.vLZi/libxkbcommon.so.0 (0x00007f2361980000)
    libwayland-cursor.so.0 => /tmp/ailibdir.vLZi/libwayland-cursor.so.0 (0x00007f2361778000)
    libwayland-egl.so.1 => /tmp/ailibdir.vLZi/libwayland-egl.so.1 (0x00007f2361570000)
    libwayland-client.so.0 => /tmp/ailibdir.vLZi/libwayland-client.so.0 (0x00007f2361360000)
    libXext.so.6 => /tmp/ailibdir.vLZi/libXext.so.6 (0x00007f2361148000)
    librt.so.1 => /usr/lib/librt.so.1 (0x00007f2361138000)
    libffi.so.6 => /tmp/ailibdir.vLZi/libffi.so.6 (0x00007f2360f30000)
    libpcre.so.1 => /tmp/ailibdir.vLZi/libpcre.so.1 (0x00007f2360cc8000)
    libselinux.so.1 => /tmp/ailibdir.vLZi/libselinux.so.1 (0x00007f2360aa0000)
    libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007f2360a80000)
    libmount.so.1 => /tmp/ailibdir.vLZi/libmount.so.1 (0x00007f2360838000)
    libthai.so.0 => /tmp/ailibdir.vLZi/libthai.so.0 (0x00007f2360628000)
    libharfbuzz.so.0 => /tmp/ailibdir.vLZi/libharfbuzz.so.0 (0x00007f23603c0000)
    libfreetype.so.6 => /tmp/ailibdir.vLZi/libfreetype.so.6 (0x00007f2360118000)
    libpixman-1.so.0 => /tmp/ailibdir.vLZi/libpixman-1.so.0 (0x00007f235fe68000)
    libEGL.so.1 => /tmp/ailibdir.vLZi/libEGL.so.1 (0x00007f235fc30000)
    libxcb-shm.so.0 => /tmp/ailibdir.vLZi/libxcb-shm.so.0 (0x00007f235fa28000)
    libxcb-render.so.0 => /tmp/ailibdir.vLZi/libxcb-render.so.0 (0x00007f235f818000)
    libXrender.so.1 => /tmp/ailibdir.vLZi/libXrender.so.1 (0x00007f235f608000)
    libGL.so.1 => /usr/lib/libGL.so.1 (0x00007f235f570000)
    liblzma.so.5 => /tmp/ailibdir.vLZi/liblzma.so.5 (0x00007f235f348000)
    /lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f236a470000)
    libcrypt.so.1 => /usr/lib/libcrypt.so.1 (0x00007f235f308000)
    libXau.so.6 => /tmp/ailibdir.vLZi/libXau.so.6 (0x00007f235f100000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f235eef8000)
    libatspi.so.0 => /tmp/ailibdir.vLZi/libatspi.so.0 (0x00007f235ecc8000)
    libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007f235ea70000)
    libblkid.so.1 => /tmp/ailibdir.vLZi/libblkid.so.1 (0x00007f235e830000)
    libuuid.so.1 => /usr/lib/libuuid.so.1 (0x00007f235e628000)
    libgraphite2.so.3 => /tmp/ailibdir.vLZi/libgraphite2.so.3 (0x00007f235e3f8000)
    libxcb-dri2.so.0 => /tmp/ailibdir.vLZi/libxcb-dri2.so.0 (0x00007f235e1f0000)
    libX11-xcb.so.1 => /tmp/ailibdir.vLZi/libX11-xcb.so.1 (0x00007f235dfe8000)
    libxcb-dri3.so.0 => /usr/lib/libxcb-dri3.so.0 (0x00007f235dde0000)
    libxcb-xfixes.so.0 => /tmp/ailibdir.vLZi/libxcb-xfixes.so.0 (0x00007f235dbd8000)
    libxcb-present.so.0 => /tmp/ailibdir.vLZi/libxcb-present.so.0 (0x00007f235d9d0000)
    libxcb-sync.so.1 => /tmp/ailibdir.vLZi/libxcb-sync.so.1 (0x00007f235d7c8000)
    libxshmfence.so.1 => /tmp/ailibdir.vLZi/libxshmfence.so.1 (0x00007f235d5c0000)
    libgbm.so.1 => /tmp/ailibdir.vLZi/libgbm.so.1 (0x00007f235d3b0000)
    libwayland-server.so.0 => /tmp/ailibdir.vLZi/libwayland-server.so.0 (0x00007f235d198000)
    libdrm.so.2 => /usr/lib/libdrm.so.2 (0x00007f235cf80000)
    libGLX.so.0 => /usr/lib/libGLX.so.0 (0x00007f235cf48000)
    libGLdispatch.so.0 => /usr/lib/libGLdispatch.so.0 (0x00007f235ce88000)
    libsystemd.so.0 => /tmp/ailibdir.vLZi/libsystemd.so.0 (0x00007f235cc50000)
    libcap.so.2 => /tmp/ailibdir.vLZi/libcap.so.2 (0x00007f235ca48000)
    liblz4.so.1 => /tmp/ailibdir.vLZi/liblz4.so.1 (0x00007f235c830000)
    libgcrypt.so.11 => /tmp/ailibdir.vLZi/libgcrypt.so.11 (0x00007f235c5a8000)
    libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007f235c388000)
    libdw.so.1 => /tmp/ailibdir.vLZi/libdw.so.1 (0x00007f235c140000)
    libattr.so.1 => /tmp/ailibdir.vLZi/libattr.so.1 (0x00007f235bf38000)
    libelf.so.1 => /tmp/ailibdir.vLZi/libelf.so.1 (0x00007f235bd20000)
    libbz2.so.1 => /tmp/ailibdir.vLZi/libbz2.so.1 (0x00007f235bb10000)
Fontconfig warning: line 5: unknown element "its:rules"
Fontconfig warning: line 6: unknown element "its:translateRule"
Fontconfig error: line 6: invalid attribute 'translate'
Fontconfig error: line 6: invalid attribute 'selector'
Fontconfig error: line 7: invalid attribute 'xmlns:its'
Fontconfig error: line 7: invalid attribute 'version'
Fontconfig warning: line 9: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/45-generic.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/45-generic.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/45-generic.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/45-generic.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/45-latin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/45-latin.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/45-latin.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/45-latin.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/45-latin.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/45-latin.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/45-latin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/49-sansserif.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/49-sansserif.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/49-sansserif.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/49-sansserif.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/49-sansserif.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/49-sansserif.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/49-sansserif.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/50-user.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/50-user.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/50-user.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/50-user.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/51-local.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/51-local.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/51-local.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/51-local.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/51-local.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/51-local.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/51-local.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/60-generic.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/60-generic.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/60-generic.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/60-generic.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/60-latin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/60-latin.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/60-latin.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/60-latin.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/60-latin.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/60-latin.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/60-latin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-persian.conf", line 34: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-persian.conf", line 35: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/65-fonts-persian.conf", line 35: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/65-fonts-persian.conf", line 35: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/65-fonts-persian.conf", line 36: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/65-fonts-persian.conf", line 36: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/65-nonlatin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/65-nonlatin.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/65-nonlatin.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/65-nonlatin.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/65-nonlatin.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/65-nonlatin.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/65-nonlatin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/69-unifont.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/69-unifont.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/69-unifont.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/69-unifont.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/69-unifont.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/69-unifont.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/70-no-bitmaps.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/70-no-bitmaps.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/70-no-bitmaps.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/70-no-bitmaps.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/70-no-bitmaps.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/70-no-bitmaps.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/70-no-bitmaps.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/80-delicious.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/80-delicious.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/80-delicious.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/80-delicious.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/80-delicious.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/80-delicious.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/90-synthetic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/90-synthetic.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 6: invalid attribute 'version'
Fontconfig error: Cannot load default config file

(rawtherapee:20261): Gtk-WARNING **: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/check-symbolic.svg.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /usr/share/icons/elementary-xfce/status/16/image-missing.svg: Unable to load image-loading module: ./lib/gdk-pixbuf-2.0/loaders/libpixbufloader-svg.so: ./lib/gdk-pixbuf-2.0/loaders/libpixbufloader-svg.so: cannot open shared object file: No such file or directory (gdk-pixbuf-error-quark, 5)
/tmp/.mount_RawTheJnnHHz/AppRun: line 40: 20261 Aborted                 (core dumped) "${APPDIR}/usr/bin/rawtherapee.wrapper" "$@"

Thanks

Syv


#11

Tried RawTherapee-dev-5.4-752-g5471b34.AppImage

Lubuntu 14.04 64 bit

Doesn’t work.

AILIBDIR=/tmp/ailibdir.e3MA
System stdc++ library: "/usr/lib/x86_64-linux-gnu/libstdc++.so.6"
System stdc++ library version: "3.4.19"
Bundled stdc++ library version: "3.4.22"
Newest stdc++ library version: "3.4.22"
Using bundled stdc++ library
atomiclib: /usr/lib/x86_64-linux-gnu/libatomic.so.1
fcv: "1.8.0"  fcv2: "1.7.0"
echo "1.8.0 1.7.0" | tr " " "\n" | sort -V | tail -n 1
Newest fontconfig library version: "1.8.0"
Using system fontconfig library
	linux-vdso.so.1 =>  (0x00007ffe5e93e000)
	libcanberra-gtk3.so.0 => /tmp/ailibdir.e3MA/libcanberra-gtk3.so.0 (0x00007f028fd9e000)
	libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f028fa69000)
	libcanberra.so.0 => /tmp/ailibdir.e3MA/libcanberra.so.0 (0x00007f028f858000)
	libgtk-3.so.0 => /tmp/ailibdir.e3MA/libgtk-3.so.0 (0x00007f028ef45000)
	libgdk-3.so.0 => /tmp/ailibdir.e3MA/libgdk-3.so.0 (0x00007f028ec59000)
	libatk-1.0.so.0 => /tmp/ailibdir.e3MA/libatk-1.0.so.0 (0x00007f028ea33000)
	libgio-2.0.so.0 => /tmp/ailibdir.e3MA/libgio-2.0.so.0 (0x00007f028e698000)
	libpangocairo-1.0.so.0 => /tmp/ailibdir.e3MA/libpangocairo-1.0.so.0 (0x00007f028e48b000)
	libgdk_pixbuf-2.0.so.0 => /tmp/ailibdir.e3MA/libgdk_pixbuf-2.0.so.0 (0x00007f028e263000)
	libcairo-gobject.so.2 => /tmp/ailibdir.e3MA/libcairo-gobject.so.2 (0x00007f028e05a000)
	libpango-1.0.so.0 => /tmp/ailibdir.e3MA/libpango-1.0.so.0 (0x00007f028de0f000)
	libcairo.so.2 => /tmp/ailibdir.e3MA/libcairo.so.2 (0x00007f028dae7000)
	libgobject-2.0.so.0 => /tmp/ailibdir.e3MA/libgobject-2.0.so.0 (0x00007f028d896000)
	libglib-2.0.so.0 => /tmp/ailibdir.e3MA/libglib-2.0.so.0 (0x00007f028d582000)
	libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f028d358000)
	libatomic.so.1 => /tmp/ailibdir.e3MA/libatomic.so.1 (0x00007f028d150000)
	libfftw3f.so.3 => /tmp/ailibdir.e3MA/libfftw3f.so.3 (0x00007f028cdd7000)
	libfftw3f_omp.so.3 => /tmp/ailibdir.e3MA/libfftw3f_omp.so.3 (0x00007f028cbd0000)
	libgiomm-2.4.so.1 => /tmp/ailibdir.e3MA/libgiomm-2.4.so.1 (0x00007f028c812000)
	libglibmm-2.4.so.1 => /tmp/ailibdir.e3MA/libglibmm-2.4.so.1 (0x00007f028c592000)
	libsigc-2.0.so.0 => /tmp/ailibdir.e3MA/libsigc-2.0.so.0 (0x00007f028c38b000)
	libgthread-2.0.so.0 => /tmp/ailibdir.e3MA/libgthread-2.0.so.0 (0x00007f028c189000)
	libgtkmm-3.0.so.1 => /tmp/ailibdir.e3MA/libgtkmm-3.0.so.1 (0x00007f028b9db000)
	libatkmm-1.6.so.1 => /tmp/ailibdir.e3MA/libatkmm-1.6.so.1 (0x00007f028b78d000)
	libgdkmm-3.0.so.1 => /tmp/ailibdir.e3MA/libgdkmm-3.0.so.1 (0x00007f028b539000)
	libpangomm-1.4.so.1 => /tmp/ailibdir.e3MA/libpangomm-1.4.so.1 (0x00007f028b30b000)
	libcairomm-1.0.so.1 => /tmp/ailibdir.e3MA/libcairomm-1.0.so.1 (0x00007f028b0e5000)
	libiptcdata.so.0 => /tmp/ailibdir.e3MA/libiptcdata.so.0 (0x00007f028aed9000)
	libjpeg.so.62 => /tmp/ailibdir.e3MA/libjpeg.so.62 (0x00007f028ac84000)
	liblcms2.so.2 => /tmp/ailibdir.e3MA/liblcms2.so.2 (0x00007f028aa2a000)
	libpng15.so.15 => /tmp/ailibdir.e3MA/libpng15.so.15 (0x00007f028a7ff000)
	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f028a5e6000)
	libtiff.so.5 => /tmp/ailibdir.e3MA/libtiff.so.5 (0x00007f028a36f000)
	liblensfun.so.1 => /tmp/ailibdir.e3MA/liblensfun.so.1 (0x00007f028a150000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f0289e4a000)
	libstdc++.so.6 => /tmp/ailibdir.e3MA/libstdc++.so.6 (0x00007f0289aca000)
	libgomp.so.1 => /tmp/ailibdir.e3MA/libgomp.so.1 (0x00007f028989e000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f0289688000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f028946a000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f02890a1000)
	libvorbisfile.so.3 => /tmp/ailibdir.e3MA/libvorbisfile.so.3 (0x00007f0288e98000)
	libvorbis.so.0 => /tmp/ailibdir.e3MA/libvorbis.so.0 (0x00007f0288c6b000)
	libogg.so.0 => /tmp/ailibdir.e3MA/libogg.so.0 (0x00007f0288a64000)
	libtdb.so.1 => /tmp/ailibdir.e3MA/libtdb.so.1 (0x00007f028884d000)
	libltdl.so.7 => /tmp/ailibdir.e3MA/libltdl.so.7 (0x00007f0288643000)
	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f0288424000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f0288220000)
	libgmodule-2.0.so.0 => /tmp/ailibdir.e3MA/libgmodule-2.0.so.0 (0x00007f028801c000)
	libXi.so.6 => /tmp/ailibdir.e3MA/libXi.so.6 (0x00007f0287e0c000)
	libXfixes.so.3 => /tmp/ailibdir.e3MA/libXfixes.so.3 (0x00007f0287c06000)
	libatk-bridge-2.0.so.0 => /tmp/ailibdir.e3MA/libatk-bridge-2.0.so.0 (0x00007f02879d7000)
	libepoxy.so.0 => /tmp/ailibdir.e3MA/libepoxy.so.0 (0x00007f02876e2000)
	libpangoft2-1.0.so.0 => /tmp/ailibdir.e3MA/libpangoft2-1.0.so.0 (0x00007f02874cc000)
	libfontconfig.so.1 => /tmp/ailibdir.e3MA/libfontconfig.so.1 (0x00007f028728f000)
	libXinerama.so.1 => /tmp/ailibdir.e3MA/libXinerama.so.1 (0x00007f028708c000)
	libXrandr.so.2 => /tmp/ailibdir.e3MA/libXrandr.so.2 (0x00007f0286e81000)
	libXcursor.so.1 => /tmp/ailibdir.e3MA/libXcursor.so.1 (0x00007f0286c76000)
	libXcomposite.so.1 => /tmp/ailibdir.e3MA/libXcomposite.so.1 (0x00007f0286a73000)
	libXdamage.so.1 => /tmp/ailibdir.e3MA/libXdamage.so.1 (0x00007f0286870000)
	libxkbcommon.so.0 => /tmp/ailibdir.e3MA/libxkbcommon.so.0 (0x00007f0286630000)
	libwayland-cursor.so.0 => /tmp/ailibdir.e3MA/libwayland-cursor.so.0 (0x00007f0286428000)
	libwayland-egl.so.1 => /tmp/ailibdir.e3MA/libwayland-egl.so.1 (0x00007f0286226000)
	libwayland-client.so.0 => /tmp/ailibdir.e3MA/libwayland-client.so.0 (0x00007f0286017000)
	libXext.so.6 => /tmp/ailibdir.e3MA/libXext.so.6 (0x00007f0285e05000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f0285bfd000)
	libffi.so.6 => /tmp/ailibdir.e3MA/libffi.so.6 (0x00007f02859f5000)
	libpcre.so.1 => /tmp/ailibdir.e3MA/libpcre.so.1 (0x00007f0285793000)
	libselinux.so.1 => /tmp/ailibdir.e3MA/libselinux.so.1 (0x00007f028556c000)
	libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f0285351000)
	libmount.so.1 => /tmp/ailibdir.e3MA/libmount.so.1 (0x00007f028510f000)
	libthai.so.0 => /tmp/ailibdir.e3MA/libthai.so.0 (0x00007f0284f03000)
	libharfbuzz.so.0 => /tmp/ailibdir.e3MA/libharfbuzz.so.0 (0x00007f0284ca0000)
	libfreetype.so.6 => /tmp/ailibdir.e3MA/libfreetype.so.6 (0x00007f02849fa000)
	libpixman-1.so.0 => /tmp/ailibdir.e3MA/libpixman-1.so.0 (0x00007f0284751000)
	libEGL.so.1 => /tmp/ailibdir.e3MA/libEGL.so.1 (0x00007f028451b000)
	libxcb-shm.so.0 => /tmp/ailibdir.e3MA/libxcb-shm.so.0 (0x00007f0284317000)
	libxcb-render.so.0 => /tmp/ailibdir.e3MA/libxcb-render.so.0 (0x00007f0284109000)
	libXrender.so.1 => /tmp/ailibdir.e3MA/libXrender.so.1 (0x00007f0283efe000)
	libGL.so.1 => /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 (0x00007f0283c98000)
	liblzma.so.5 => /tmp/ailibdir.e3MA/liblzma.so.5 (0x00007f0283a72000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f028ffa3000)
	libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007f0283839000)
	libXau.so.6 => /tmp/ailibdir.e3MA/libXau.so.6 (0x00007f0283635000)
	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f028342f000)
	libatspi.so.0 => /tmp/ailibdir.e3MA/libatspi.so.0 (0x00007f02831ff000)
	libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f0282fba000)
	libblkid.so.1 => /tmp/ailibdir.e3MA/libblkid.so.1 (0x00007f0282d7b000)
	libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f0282b76000)
	libgraphite2.so.3 => /tmp/ailibdir.e3MA/libgraphite2.so.3 (0x00007f0282948000)
	libxcb-dri2.so.0 => /tmp/ailibdir.e3MA/libxcb-dri2.so.0 (0x00007f0282743000)
	libX11-xcb.so.1 => /tmp/ailibdir.e3MA/libX11-xcb.so.1 (0x00007f0282541000)
	libxcb-dri3.so.0 => /tmp/ailibdir.e3MA/libxcb-dri3.so.0 (0x00007f028233e000)
	libxcb-xfixes.so.0 => /tmp/ailibdir.e3MA/libxcb-xfixes.so.0 (0x00007f0282136000)
	libxcb-present.so.0 => /tmp/ailibdir.e3MA/libxcb-present.so.0 (0x00007f0281f33000)
	libxcb-sync.so.1 => /tmp/ailibdir.e3MA/libxcb-sync.so.1 (0x00007f0281d2c000)
	libxshmfence.so.1 => /tmp/ailibdir.e3MA/libxshmfence.so.1 (0x00007f0281b29000)
	libgbm.so.1 => /tmp/ailibdir.e3MA/libgbm.so.1 (0x00007f028191b000)
	libwayland-server.so.0 => /tmp/ailibdir.e3MA/libwayland-server.so.0 (0x00007f0281708000)
	libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007f02814fa000)
	libglapi.so.0 => /tmp/ailibdir.e3MA/libglapi.so.0 (0x00007f02812ca000)
	libxcb-glx.so.0 => /tmp/ailibdir.e3MA/libxcb-glx.so.0 (0x00007f02810af000)
	libXxf86vm.so.1 => /tmp/ailibdir.e3MA/libXxf86vm.so.1 (0x00007f0280ea9000)

** (process:3046): WARNING **: [Lensfun] /home/giulio/.local/share/lensfun/canon_fd.xml:14:1: Invalid lens definition (Canon/Canon Lens FDn 24mm 1:2.8)


** (process:3046): WARNING **: [Lensfun] /home/giulio/.local/share/lensfun/giulio.xml:2:1: Inappropiate context for <lens>!


(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:52:19: The :insensitive pseudo-class is deprecated. Use :disabled instead.





A LOT OF GTW WARNING DELETED



(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:55:50: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:56:51: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:57:39: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:58:45: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:59:46: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:92:21: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:93:23: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:113:29: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:114:29: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:115:24: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:135:36: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:140:36: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-widgets-radiance.css:145:31: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: unity.css:107:15: The 'icon-shadow' property has been renamed to '-gtk-icon-shadow'

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: nautilus.css:4:27: The style property GtkPaned:handle-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: nautilus.css:36:47: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: nautilus.css:81:14: not a number

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: nautilus.css:81:14: Expected a string.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: nautilus.css:91:41: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: nautilus.css:104:30: The style property GtkButton:image-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: nautilus.css:105:29: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gnome-panel.css:56:29: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gnome-panel.css:70:35: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gnome-panel.css:71:35: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gnome-panel.css:81:28: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gnome-panel.css:82:28: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:5:13: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:36:29: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:37:29: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:43:39: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:46:39: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:80:33: The :focused pseudo-class is deprecated. Use :focus instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:96:38: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:97:40: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:98:53: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:99:55: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:100:53: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:101:55: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:102:48: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:103:50: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:104:44: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:105:46: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:106:52: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:107:54: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:108:52: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:109:54: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:110:47: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:111:49: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:112:21: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:113:23: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:118:34: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:148:26: The style property GtkRange:trough-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:149:26: The style property GtkRange:arrow-scaling is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:150:25: The style property GtkRange:slider-width is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:151:25: The style property GtkRange:stepper-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:152:34: The style property GtkScrollbar:min-slider-length is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:153:28: The style property GtkRange:stepper-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:154:34: The style property GtkRange:trough-under-steppers is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:163:28: The style property GtkRange:slider-width is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:201:35: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:202:37: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:213:35: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:214:37: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:225:29: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:229:29: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:3046): Gtk-WARNING **: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/check-symbolic.svg.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /usr/share/icons/lubuntu/mimes/16/image-missing.svg: Impossibile aprire il modulo «./lib/gdk-pixbuf-2.0/loaders/libpixbufloader-svg.so» per il caricamento delle immagini: ./lib/gdk-pixbuf-2.0/loaders/libpixbufloader-svg.so: impossibile aprire il file oggetto condiviso: File o directory non esistente (gdk-pixbuf-error-quark, 5)
/tmp/.mount_RawThe3FioVb/AppRun: riga 40:  3046 Annullato               (core dump creato) "${APPDIR}/usr/bin/rawtherapee.wrapper" "$@"

(Silvio) #12

Hello everyone,

Just tested again myself on Kubuntu 18.04.01 (LTS) - kde desktop.
As usual this distro is installed through VirtuaBox : the host is Windows 10 - 64 bit.
RawTherapee works fine and I have experienced no crash so far while quickly trying it.

Here it is:


(Carmelo Dr Raw) #13

@foto @ggc @Silvio_Grosso thanks a lot for the feedback!

Indeed, the RSVG library was not included in the bundle, this is now fixed in the latest package: https://github.com/Beep6581/RawTherapee/releases/download/nightly/RawTherapee-dev-5.4-752-g5471b34.AppImage

Hopefully this fixes the issues with desktop environments that use SVG icons… could you please check it?


#14

Thank you. Unfortunatly it still doesn’t seem to work…

65119bef7836ff2275fd7bf45dbe19f4 RawTherapee-dev-5.4-752-g5471b34(1).AppImage

(rawtherapee:2419): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:163:28: The style property GtkRange:slider-width is deprecated and shouldn't be used anymore. It will be removed in a future version

(rawtherapee:2419): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:201:35: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:2419): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:202:37: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:2419): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:213:35: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:2419): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:214:37: The :prelight pseudo-class is deprecated. Use :hover instead.

(rawtherapee:2419): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:225:29: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:2419): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:229:29: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(rawtherapee:2419): Gtk-WARNING **: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/check-symbolic.svg.
This may indicate that pixbuf loaders or the mime database could not be found.
S    **


Gtk:ERROR:gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /usr/share/icons/lubuntu/mimes/16/image-missing.svg: Impossibile aprire il modulo «./lib/gdk-pixbuf-2.0/loaders/libpixbufloader-svg.so» per il caricamento delle immagini: ./lib/gdk-pixbuf-2.0/loaders/libpixbufloader-svg.so: impossibile aprire il file oggetto condiviso: File o directory non esistente (gdk-pixbuf-error-quark, 5)
/tmp/.mount_RawTheBagxtv/AppRun: riga 40:  2419 Annullato               (core dump creato) "${APPDIR}/usr/bin/rawtherapee.wrapper" "$@"

(Carmelo Dr Raw) #15

@ggc It looks like that the gdk-pixbuf loaders are harder to handle than expected… here is yet another version, with a more robust configuration for the bundled gdk-pixbuf loaders: https://github.com/Beep6581/RawTherapee/releases/download/nightly/RawTherapee-dev-5.4-753-g8b57aa4.AppImage

Could you please test it again? Unfortunately I do not have such a Lubuntu system at hand…


#16

Works fine now! Thank you!


(Silvio) #17

Just tested again the latest build on Kubuntu 18.04.01 (Kde desktop)

It works fine: all icons are displayed correctly as well in the GUIs.
In the previous build some of them were missing: see my previous screenshot were the + - buttons are missing altogether.

Thanks a lot !


(Syv) #18

Manjaro current, xfce
Still doesn’t work for me. (removed all the other warnings)

$ downloads/appimages/RawTherapee-dev-5.4-753-g8b57aa4.AppImage 
/tmp/.mount_RawTheR0c8KU/usr/bin/rawtherapee: symbol lookup error: /usr/lib/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var

fixed with ld_preload but still crashes on pixbuf

$ env LD_PRELOAD="/usr/lib/libfreetype.so" downloads/appimages/RawTherapee-dev-5.4-753-g8b57aa4.AppImage 

(rawtherapee:1805): Gtk-WARNING **: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/check-symbolic.svg.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /usr/share/icons/elementary-xfce/status/16/image-missing.svg: Unable to load image-loading module: /tmp/.mount_RawTheWigpJf/usr/lib/gdk-pixbuf-2.0/loaders/libpixbufloader-svg.so: /usr/lib64/librsvg-2.so.2: undefined symbol: cairo_tag_begin (gdk-pixbuf-error-quark, 5)
/tmp/.mount_RawTheWigpJf/AppRun: line 44:  1805 Aborted                 (core dumped) "${APPDIR}/usr/bin/rawtherapee.wrapper" "$@"
$ 

Thanks

Syv


(Carmelo Dr Raw) #19

@foto could you please post the full terminal log of the above command? It is strange that the program uses the system librsvg instead of the bundled one…


(Syv) #20

Here it is:

$ env LD_PRELOAD="/usr/lib/libfreetype.so" downloads/appimages/RawTherapee-dev-5.4-753-g8b57aa4.AppImage 
AILIBDIR=/tmp/ailibdir.2YEy
deleting /tmp/ailibdir.2YEy/libxcb-dri3.so*
System stdc++ library: "/usr/lib/libstdc++.so.6"
System stdc++ library version: "3.4.25"
Bundled stdc++ library version: "3.4.22"
Newest stdc++ library version: "3.4.25"
Using system stdc++ library
atomiclib: /usr/lib/libatomic.so.1
fcv: "1.11.1"  fcv2: "1.7.0"
echo "1.11.1 1.7.0" | tr " " "\n" | sort -V | tail -n 1
Newest fontconfig library version: "1.11.1"
Using system fontconfig library
    linux-vdso.so.1 (0x00007ffe5a9fb000)
    /usr/lib/libfreetype.so (0x00007f42ef038000)
    libcanberra-gtk3.so.0 => /tmp/ailibdir.2YEy/libcanberra-gtk3.so.0 (0x00007f42eee30000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f42eecf0000)
    libcanberra.so.0 => /tmp/ailibdir.2YEy/libcanberra.so.0 (0x00007f42eead8000)
    libgtk-3.so.0 => /tmp/ailibdir.2YEy/libgtk-3.so.0 (0x00007f42ee1c0000)
    libgdk-3.so.0 => /tmp/ailibdir.2YEy/libgdk-3.so.0 (0x00007f42eded0000)
    libatk-1.0.so.0 => /tmp/ailibdir.2YEy/libatk-1.0.so.0 (0x00007f42edca8000)
    libgio-2.0.so.0 => /tmp/ailibdir.2YEy/libgio-2.0.so.0 (0x00007f42ed908000)
    libpangocairo-1.0.so.0 => /tmp/ailibdir.2YEy/libpangocairo-1.0.so.0 (0x00007f42ed6f8000)
    libgdk_pixbuf-2.0.so.0 => /tmp/ailibdir.2YEy/libgdk_pixbuf-2.0.so.0 (0x00007f42ed4d0000)
    libcairo-gobject.so.2 => /tmp/ailibdir.2YEy/libcairo-gobject.so.2 (0x00007f42ed2c0000)
    libpango-1.0.so.0 => /tmp/ailibdir.2YEy/libpango-1.0.so.0 (0x00007f42ed070000)
    libcairo.so.2 => /tmp/ailibdir.2YEy/libcairo.so.2 (0x00007f42ecd48000)
    libgobject-2.0.so.0 => /tmp/ailibdir.2YEy/libgobject-2.0.so.0 (0x00007f42ecaf0000)
    libglib-2.0.so.0 => /tmp/ailibdir.2YEy/libglib-2.0.so.0 (0x00007f42ec7d8000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f42ec798000)
    libatomic.so.1 => /usr/lib/libatomic.so.1 (0x00007f42ec788000)
    libfftw3f.so.3 => /tmp/ailibdir.2YEy/libfftw3f.so.3 (0x00007f42ec408000)
    libfftw3f_omp.so.3 => /tmp/ailibdir.2YEy/libfftw3f_omp.so.3 (0x00007f42ec200000)
    libgiomm-2.4.so.1 => /tmp/ailibdir.2YEy/libgiomm-2.4.so.1 (0x00007f42ebe40000)
    libglibmm-2.4.so.1 => /tmp/ailibdir.2YEy/libglibmm-2.4.so.1 (0x00007f42ebbc0000)
    libsigc-2.0.so.0 => /tmp/ailibdir.2YEy/libsigc-2.0.so.0 (0x00007f42eb9b8000)
    libgthread-2.0.so.0 => /tmp/ailibdir.2YEy/libgthread-2.0.so.0 (0x00007f42eb7b0000)
    libgtkmm-3.0.so.1 => /tmp/ailibdir.2YEy/libgtkmm-3.0.so.1 (0x00007f42eb000000)
    libatkmm-1.6.so.1 => /tmp/ailibdir.2YEy/libatkmm-1.6.so.1 (0x00007f42eadb0000)
    libgdkmm-3.0.so.1 => /tmp/ailibdir.2YEy/libgdkmm-3.0.so.1 (0x00007f42eab58000)
    libpangomm-1.4.so.1 => /tmp/ailibdir.2YEy/libpangomm-1.4.so.1 (0x00007f42ea928000)
    libcairomm-1.0.so.1 => /tmp/ailibdir.2YEy/libcairomm-1.0.so.1 (0x00007f42ea700000)
    libiptcdata.so.0 => /tmp/ailibdir.2YEy/libiptcdata.so.0 (0x00007f42ea4f0000)
    libjpeg.so.62 => /tmp/ailibdir.2YEy/libjpeg.so.62 (0x00007f42ea298000)
    liblcms2.so.2 => /tmp/ailibdir.2YEy/liblcms2.so.2 (0x00007f42ea038000)
    libpng15.so.15 => /tmp/ailibdir.2YEy/libpng15.so.15 (0x00007f42e9e08000)
    libz.so.1 => /usr/lib/libz.so.1 (0x00007f42e9bf0000)
    libtiff.so.5 => /tmp/ailibdir.2YEy/libtiff.so.5 (0x00007f42e9978000)
    liblensfun.so.1 => /tmp/ailibdir.2YEy/liblensfun.so.1 (0x00007f42e9758000)
    libm.so.6 => /usr/lib/libm.so.6 (0x00007f42e95d0000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f42e9440000)
    libgomp.so.1 => /usr/lib/libgomp.so.1 (0x00007f42e9410000)
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f42e93f0000)
    libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f42e93c8000)
    libc.so.6 => /usr/lib/libc.so.6 (0x00007f42e9200000)
    libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007f42e8ff0000)
    libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007f42e8db8000)
    libharfbuzz.so.0 => /tmp/ailibdir.2YEy/libharfbuzz.so.0 (0x00007f42e8b50000)
    libvorbisfile.so.3 => /tmp/ailibdir.2YEy/libvorbisfile.so.3 (0x00007f42e8940000)
    libvorbis.so.0 => /tmp/ailibdir.2YEy/libvorbis.so.0 (0x00007f42e8710000)
    libogg.so.0 => /tmp/ailibdir.2YEy/libogg.so.0 (0x00007f42e8508000)
    libtdb.so.1 => /tmp/ailibdir.2YEy/libtdb.so.1 (0x00007f42e82f0000)
    libltdl.so.7 => /tmp/ailibdir.2YEy/libltdl.so.7 (0x00007f42e80e0000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f42e7eb0000)
    libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f42e7ea8000)
    libgmodule-2.0.so.0 => /tmp/ailibdir.2YEy/libgmodule-2.0.so.0 (0x00007f42e7ca0000)
    libXi.so.6 => /tmp/ailibdir.2YEy/libXi.so.6 (0x00007f42e7a90000)
    libXfixes.so.3 => /tmp/ailibdir.2YEy/libXfixes.so.3 (0x00007f42e7888000)
    libatk-bridge-2.0.so.0 => /tmp/ailibdir.2YEy/libatk-bridge-2.0.so.0 (0x00007f42e7658000)
    libepoxy.so.0 => /tmp/ailibdir.2YEy/libepoxy.so.0 (0x00007f42e7360000)
    libpangoft2-1.0.so.0 => /tmp/ailibdir.2YEy/libpangoft2-1.0.so.0 (0x00007f42e7148000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007f42e7100000)
    libXinerama.so.1 => /tmp/ailibdir.2YEy/libXinerama.so.1 (0x00007f42e6ef8000)
    libXrandr.so.2 => /tmp/ailibdir.2YEy/libXrandr.so.2 (0x00007f42e6ce8000)
    libXcursor.so.1 => /tmp/ailibdir.2YEy/libXcursor.so.1 (0x00007f42e6ad8000)
    libXcomposite.so.1 => /tmp/ailibdir.2YEy/libXcomposite.so.1 (0x00007f42e68d0000)
    libXdamage.so.1 => /tmp/ailibdir.2YEy/libXdamage.so.1 (0x00007f42e66c8000)
    libxkbcommon.so.0 => /tmp/ailibdir.2YEy/libxkbcommon.so.0 (0x00007f42e6488000)
    libwayland-cursor.so.0 => /tmp/ailibdir.2YEy/libwayland-cursor.so.0 (0x00007f42e6280000)
    libwayland-egl.so.1 => /tmp/ailibdir.2YEy/libwayland-egl.so.1 (0x00007f42e6078000)
    libwayland-client.so.0 => /tmp/ailibdir.2YEy/libwayland-client.so.0 (0x00007f42e5e68000)
    libXext.so.6 => /tmp/ailibdir.2YEy/libXext.so.6 (0x00007f42e5c50000)
    librt.so.1 => /usr/lib/librt.so.1 (0x00007f42e5c40000)
    libffi.so.6 => /tmp/ailibdir.2YEy/libffi.so.6 (0x00007f42e5a38000)
    libpcre.so.1 => /tmp/ailibdir.2YEy/libpcre.so.1 (0x00007f42e57d0000)
    libselinux.so.1 => /tmp/ailibdir.2YEy/libselinux.so.1 (0x00007f42e55a8000)
    libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007f42e5588000)
    libmount.so.1 => /tmp/ailibdir.2YEy/libmount.so.1 (0x00007f42e5340000)
    libthai.so.0 => /tmp/ailibdir.2YEy/libthai.so.0 (0x00007f42e5130000)
    libpixman-1.so.0 => /tmp/ailibdir.2YEy/libpixman-1.so.0 (0x00007f42e4e80000)
    libEGL.so.1 => /tmp/ailibdir.2YEy/libEGL.so.1 (0x00007f42e4c48000)
    libxcb-shm.so.0 => /tmp/ailibdir.2YEy/libxcb-shm.so.0 (0x00007f42e4a40000)
    libxcb-render.so.0 => /tmp/ailibdir.2YEy/libxcb-render.so.0 (0x00007f42e4830000)
    libXrender.so.1 => /tmp/ailibdir.2YEy/libXrender.so.1 (0x00007f42e4620000)
    libGL.so.1 => /usr/lib/libGL.so.1 (0x00007f42e4588000)
    liblzma.so.5 => /tmp/ailibdir.2YEy/liblzma.so.5 (0x00007f42e4360000)
    /lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f42ef308000)
    libgraphite2.so.3 => /tmp/ailibdir.2YEy/libgraphite2.so.3 (0x00007f42e4130000)
    libcrypt.so.1 => /usr/lib/libcrypt.so.1 (0x00007f42e40f0000)
    libXau.so.6 => /tmp/ailibdir.2YEy/libXau.so.6 (0x00007f42e3ee8000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f42e3ce0000)
    libatspi.so.0 => /tmp/ailibdir.2YEy/libatspi.so.0 (0x00007f42e3ab0000)
    libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007f42e3858000)
    libuuid.so.1 => /usr/lib/libuuid.so.1 (0x00007f42e3650000)
    libblkid.so.1 => /tmp/ailibdir.2YEy/libblkid.so.1 (0x00007f42e3410000)
    libxcb-dri2.so.0 => /tmp/ailibdir.2YEy/libxcb-dri2.so.0 (0x00007f42e3208000)
    libX11-xcb.so.1 => /tmp/ailibdir.2YEy/libX11-xcb.so.1 (0x00007f42e3000000)
    libxcb-dri3.so.0 => /usr/lib/libxcb-dri3.so.0 (0x00007f42e2df8000)
    libxcb-xfixes.so.0 => /tmp/ailibdir.2YEy/libxcb-xfixes.so.0 (0x00007f42e2bf0000)
    libxcb-present.so.0 => /tmp/ailibdir.2YEy/libxcb-present.so.0 (0x00007f42e29e8000)
    libxcb-sync.so.1 => /tmp/ailibdir.2YEy/libxcb-sync.so.1 (0x00007f42e27e0000)
    libxshmfence.so.1 => /tmp/ailibdir.2YEy/libxshmfence.so.1 (0x00007f42e25d8000)
    libgbm.so.1 => /tmp/ailibdir.2YEy/libgbm.so.1 (0x00007f42e23c8000)
    libwayland-server.so.0 => /tmp/ailibdir.2YEy/libwayland-server.so.0 (0x00007f42e21b0000)
    libdrm.so.2 => /usr/lib/libdrm.so.2 (0x00007f42e1f98000)
    libGLX.so.0 => /usr/lib/libGLX.so.0 (0x00007f42e1f60000)
    libGLdispatch.so.0 => /usr/lib/libGLdispatch.so.0 (0x00007f42e1ea0000)
    libsystemd.so.0 => /tmp/ailibdir.2YEy/libsystemd.so.0 (0x00007f42e1c68000)
    libcap.so.2 => /tmp/ailibdir.2YEy/libcap.so.2 (0x00007f42e1a60000)
    liblz4.so.1 => /tmp/ailibdir.2YEy/liblz4.so.1 (0x00007f42e1848000)
    libgcrypt.so.11 => /tmp/ailibdir.2YEy/libgcrypt.so.11 (0x00007f42e15c0000)
    libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007f42e13a0000)
    libdw.so.1 => /tmp/ailibdir.2YEy/libdw.so.1 (0x00007f42e1158000)
    libattr.so.1 => /tmp/ailibdir.2YEy/libattr.so.1 (0x00007f42e0f50000)
    libelf.so.1 => /tmp/ailibdir.2YEy/libelf.so.1 (0x00007f42e0d38000)
    libbz2.so.1 => /tmp/ailibdir.2YEy/libbz2.so.1 (0x00007f42e0b28000)

(rawtherapee:4328): Gtk-WARNING **: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/check-symbolic.svg.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /usr/share/icons/elementary-xfce/status/16/image-missing.svg: Unable to load image-loading module: /tmp/.mount_RawThe1oB2BP/usr/lib/gdk-pixbuf-2.0/loaders/libpixbufloader-svg.so: /usr/lib64/librsvg-2.so.2: undefined symbol: cairo_tag_end (gdk-pixbuf-error-quark, 5)
/tmp/.mount_RawThe1oB2BP/AppRun: line 44:  4328 Aborted                 (core dumped) "${APPDIR}/usr/bin/rawtherapee.wrapper" "$@"

BTW, the forum is complaining about me posting too much in this forum and not allowing for a diversity of views.

Thanks

Syv