Test the latest RawTherapee AppImage


(Morgan Hardwood) #81

No jerky scrolling issues in Sabayon.


(Carmelo Dr Raw) #82

What is your desktop environment (MATE/Cinnamon/GNOME)?


#83

Apologies - I should have mentioned that.
My environment is MATE


#84

Thank youi it works! Only deleting the settings folder ( $HOME/.config/RawTherapee5-dev-ai ).


(Carmelo Dr Raw) #85

Happy to hear that!


(Colin Pittendrigh) #86

I’m very happy with the new AppImage rawtherapee. I’ve been re-editing 5 year old images. The results are gratifying.

Is there a corresponding rawtherapee-cli ?

I do a lot of focus stacking and cannot live without the command line interface. I poked around and couldn’t find it.

If I run the (Minit Linux Tara) rawtherapee-cli from sudo apt-get install on a *.pp3 from a recent AppImage version the images are all washed out and over-exposed.


(Morgan Hardwood) #87

@pittendrigh use the --cli option on the AppImage to access the CLI version.


(Colin Pittendrigh) #88

Ah. Thank you.


(Carmelo Dr Raw) #89

I have done some work to improve the desktop integration of the RT AppImage, in particular:

  • menu items in the applications menu and “Open woth…” contextual menus should now work properly, if the user enables the desktop integration (a dialog will ask confirmation when the AppImage is launched)
  • updates are searched and downloaded automatically (a dialog of course asks the user if he/she wants to download the update or not).

You can get more details about this now features here, or go straight to download the experimental AppImage from here.

Any feedback is very much appreciated as usual!


(Ingo Weyrich) #90

How does this work?


(Carmelo Dr Raw) #91

I am using the GitHub API to access the nightly release and list the available assets that match the pattern RawTherapee-${RT_BRANCH}-${RT_VERSION}*.AppImage. The available assets are sorted, the last one is selected and compared with the version of the AppImage currently being executed (I store the information in a VERSION.txt file inside the appimage for this). If a newer file is available on GitHub, it is downloaded (again using the GitHub API) and run.

You can inspect all the scripts by downloading the experimental package, making it executable and running

RawTherapee-dev-5.4-684-gab79434.AppImage --appimage-extract

This will extract the contents of the AppImage into a squashfs-root folder. The relevant scripts are all in the root of the extracted package:

  • squashfs-root/AppRun is the script that is executed by the AppImage launcher
  • squashfs-root/check_updates.sh is the script that lists and sorts the GitHub release assets

If you have suggestions, you are more than welcome!


#92

MY OS is 64bit Mint 18.3 - MATE.
I have Flatpak Gimp 2.10 and the RT 5.4 Experimental AppImage installed.

I started with RawTherapee-dev-5.4-911 and everything ran very fast and smoothly, including LensFun, Desktop Integration and Menu Application List.

To invoke GIMP as external editor for a jpg from within RT I inserted the following command line in the Preferences dialogue:-

“flatpak run org.gimp.GIMP” and this worked perfectly.

A few days later I restarted RT and activated the the pop-up inviting an update.

The update went smoothly and my RT installation was now RawTherapee-dev-5.4-913 (replacing the 911 version)

However the above command line to invoke Gimp as external editor had now ceased to function.

I hope there is a solution to this small irritation because the Linux AppImage is very impressive compared to the RT 5.4 running on my Windows 7 HDD


(Carmelo Dr Raw) #93

Could you please check the latest version from today? You can get it at the following link: https://github.com/Beep6581/RawTherapee/releases/download/nightly/RawTherapee-dev-5.4-918-gae12a41.AppImage

Meanwhile I will have a look to see if I find some obvious mistake in the latest changes that I have introduced in the AppImage scripts…


#94

Thanks Carmelo_DrRaw,

I have run the RawTherapee-dev-5.4-918-gae12a41.Appimage and the Gimp is working perfectly again with command line as follows:-

“flatpak run org.gimp.GIMP”


(Carmelo Dr Raw) #95

Great! Glad to hear it works!


(Syv) #96

I have found a couple of bugs/inconvenience (minor) with:
RT rawtherapee-dev-5.4-918-gae12a41.appimage

  1. If exporting first as TIFF (Ctrl-S), and the next image (Ctrl-S) is changed to JPEG, the filename doesn’t change (including the “.tif” portion). So RT creates a a jpeg file with the name abc.tif instead of abc.jpg. (I just have to make sure that I manually change the extension)
  2. color tab > rgb curve > I select the channel Red > control cage, the red tone curve box doesn’t expand fully. The bottom of the box is cut off. The size of the cut off depends on how much “toward the bottom” is left, so that the color toning and color management headers as always displayed. The fix is to fold the rgb curve and unfold it again.

Thanks

Syv


(Morgan Hardwood) #97

These issues are not specific to the AppImage, they affect normal builds as well.

Bug 1: https://github.com/Beep6581/RawTherapee/issues/4446
Bug 2: https://github.com/Beep6581/RawTherapee/issues/3525


(Syv) #98

It shows that the issue: 3525 is closed on 19-Aug-2018. But it’s still happening on all the curves boxes that are closer to the end of the tab (exposure, colour, …)

Graphics:  Device-1: NVIDIA GK106 [GeForce GTX 650 Ti] driver: nvidia v: 396.54 
       Display: x11 server: N/A driver: nvidia resolution: <xdpyinfo missing> 
       OpenGL: renderer: GeForce GTX 650 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 396.54 

and

 archlinux: 
 gtk3 3.22.30-1
 gtk-xfce-engine 2.10.1-1.1

Thanks

Syv


(Carmelo Dr Raw) #99

Dear all, I have prepared a new update of the RT AppImage packages. The most notable improvement is the automated download of updated packages.

This feature is still quite experimental. Moreover, since some users might not appreciate that the program accesses the internet to check for updates, the feature is disabled by default. To enable it, run the appimage with the --enable-auto-update argument. For example:

./RawTherapee-dev-5.4-918-gae12a41.AppImage --enable-auto-update

Next time you will run the AppImage, it will fetch the list of available packages from the nightly builds GitHub release, and will download a more recent package if available. The downloaded files are saved in $HOME/.local/appimages.
Notice that a confirmation dialog will always ask permission to the user before downloading and executing the new package. Moreover, if the sha256sum command is installed in the host system, the downloaded file will be checked against the SHA256 checksum from the same “nightly” release.

The automated updates can be disabled with

./RawTherapee-dev-5.4-918-gae12a41.AppImage --disable-auto-update

Any feedback is very much appreciated, as I am still improving the code.

Enjoy!!!


#100

I have been running the most recent RawTherapee-dev-5.4-928-XXX and all’s well with that - no problems.

However, recently on each run of this dev I’m getting the pop-uo inviting an update to a new version, namely RawTherapee-waveletsnew-5.4-1031-XXX

When this version installs I have noticed that the Preferences Button (Bottom LHS) fails to function and it simply closes down RT.

So I have removed it from /home/.local/appimages and reverted back to the dev-928 version