The app stopped working once I upgraded to Gnome 45

Pretty much what the title says.

Traceback (most recent call last):
  File "/usr/bin/rapid-photo-downloader", line 33, in <module>
    sys.exit(load_entry_point('rapid-photo-downloader==0.9.34', 'gui_scripts', 'rapid-photo-downloader')())
  File "/usr/bin/rapid-photo-downloader", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.11/importlib/metadata/", line 202, in load
    module = import_module('module'))
  File "/usr/lib/python3.11/importlib/", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1204, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1176, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1147, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 690, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 940, in exec_module
  File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
  File "/usr/lib/python3.11/site-packages/raphodo/", line 53, in <module>
    import pkg_resources as pkgr
  File "/usr/lib/python3.11/site-packages/pkg_resources/", line 3327, in <module>
  File "/usr/lib/python3.11/site-packages/pkg_resources/", line 3302, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.11/site-packages/pkg_resources/", line 3340, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.11/site-packages/pkg_resources/", line 631, in _build_master
  File "/usr/lib/python3.11/site-packages/pkg_resources/", line 968, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.11/site-packages/pkg_resources/", line 829, in resolve
    dist = self._resolve_dist(
  File "/usr/lib/python3.11/site-packages/pkg_resources/", line 870, in _resolve_dist
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'types-python-dateutil>=2.8.10' distribution was not found and is required by arrow

Doesn’t look like it has anything to do with GNOME, but rather that a python library version has shifted underneath you.

Did you use the installer? If yes try reinstalling.

If its a distro package, report it to your packager.

1 Like

I tried both reinstalling and uninstalling and installing again, via pacman.


Installing python-types-python-dateutil fixed it.

If you didn’t already, as @paperdigits says, please report the bug to whatever distribution you are using. If the bug is not reported, it will not be fixed. Packaging is difficult and time-consuming. The kind people doing the work need all the help they can get from such bug reports.

1 Like

I posted this, together with the solution, to the Arch Linux forum. I’m not sure if there is more that I can do.

If you had to manually install a python package, that package should be added as a dependency

1 Like


I did not see a bug report filed against the appropriate package, so I filed it myself:

1 Like