The unofficial builds by André Gauthier: missing library

Hi,
RawTherapee Development Builds
The unofficial builds by André Gauthier:
RawTherapee_dev_5.8-2948-g6189a0e81_W64_generic_210524.7z

missing library: libjbig-0.dll

A new dépendency appeared mysteriously :worried:
Should be corrected

@ [arturoisilvia this missing library is in the built.
A simple to copy stick should be enough
@ganaaed32 builts Skylake works well but, every time, it is necessary to put MultiUser=false.
It seems to be the case for several users.
Not serious when as everybody knows otherwise white screen.
In option to put it by default?

“cette librairie manquante est dans le built.
Un simple copier-coller devrait suffire.
@ganaaed32 Les builts Skylake fonctionnent bien mais, chaque fois, il faut mettre MultiUser=false dans le dossier ‘option’.
Cela semble le cas pour plusieurs utilisateurs.
Pas grave quand on le sait… sinon écran blanc. Le mettre par défaut?
Et grand merci pour ces builts.”

@ arturoisilvia this missing library is in the built SKYLAKE

Excusez mon oubli

It depends on how you go about using Andre’s new versions. I never need to add in MultiUser=false in the option file if I simply create a shortcut for rawtherapee.exe from the unzipped folder for each new @gaaned92 update. I place the shortcut either on my desktop or in the Taskbar. Once done I delete the old shortcut. I works fine that way on my win 10 computer.

Yes, that’s right. I already have it and it’s working. Thank you.
Arturo.

1 Like

I am not able to reproduce either using a shortcut or double clicking on ART.exe or double clicking on an image or launching from a DOS window.

If you set multi user = false, the cache folder and the settings folders will be located in the directory containing the exe instead of the normal location of the config folder. That’s not always a good idea because you risk to loose some valuable data if you want to erase the installation directory.

So I suspect that ART cannot create the config folder or cannot write at the location defined by the windows variable%LOCALAPPDATA%.
I think it is thus a problem due to the configuration of Windows .

@agriggio @Carmelo_DrRaw @Morgan_Hardwood
Perhaps you will need to add libjbig-0.dll to the builds