This morning I don't like free/libre software

photoflow
darktable
gimp
rawtherapee

(Elle Stone) #1

This morning I don’t like free/libre software . . .

I copied some raw files from my camera card to my hard drive and looked through them using geeqie.Then I right-clicked on one of the files in the qeeqie interface, which only listed PhotoFlow as a way to open the file. Well, OK, I actually wanted RawTherapee, but PhotoFlow would also work.

Except that when I selected to open the raw file from the geeqie interface using PhotoFlow, nothing happened.

So I opened PhotoFlow from the command line and tried to drag and drop the raw file from the Dolphin file manager to PhotoFlow’s window. But nothing happened. Apparently PhotoFlow doesn’t support drag and drop.

So I opened the raw file with RawTherapee, though RT also doesn’t seem to support drag and drop. I wanted to use the RCD demosaicing algorithm (which PhotoFlow also has), so darktable wasn’t an option.

Having finally gotten the raw file open, I saw that RawTherapee now defaults to some hinky set of “make it pretty” editing algorithms that apply a very iffy tone curve. So I selected the RT Neutral profile. Then I used the little tool that allows to set the white balance on a nominally neutral patch in the raw file - this particular raw file included a white balancing target shot under the same light as the raw file I actually wanted to work on.

Then still using RawTherapee I opened the raw file that I actually wanted to work on and dialed in the previously determined white balance using Temp/Tint. I would greatly prefer using RGB sliders, but RT doesn’t supply these sliders.

Then I realized that some RawTherapee “highlight” code still seemed activated and I couldn’t figure out how to make sure it wasn’t actually doing anything. So I closed RawTherapee and went back to PhotoFlow.

PhotoFlow makes getting scene-referred output incredibly simple (no “make it pretty” algorithms are applied by default), and PF does have RGB multipliers for setting the white balance, and does have the RCD algorithm. But the GTK3 interface has issues at least on my system.

So I decided to exit PhotoFlow and recompile it using GTK2, and PhotoFlow very rightly complained that I was missing a couple of libraries - yesterday, I had downloaded the required GTK2 tarballs so I could recompile PhotoFlow using GTK2, but I forgot that I hadn’t actually gotten around to compiling and installing the libraries.

So I uncompressed, compiled, and installed the the GTK2 tarballs and then proceeded to compile and install PhotoFlow using GTK2 instead of GTK3.

While PhotoFlow was compiling, I fired up GIMP to continue working on an XCF file from a different image, and upon dragging a layer out to make a new file, GIMP crashed with the sort of error message that leaves no option except to resort to full-fledged GDB debugging using special commands to actually try to trace the source of the crash - something to do with an X Window System error and asynchronous crashes vs errors.

PhotoFlow did sucessfully compile, install, and run using GTK2. But when I tried to use “Area” color balance, no little square or rectangle appeared and nothing seemed to happen. So I dialed in the Temp/Tint from RT into PhotoFlow’s corresponding sliders, which was a bogus thing to do as RT and PF don’t use the same Temp/Tint algorithm.

So I bought a subscription to Adobe cloud.

Just kidding.


(Sebastien Guyader) #2

:joy:


#3

On my win10 system,

1. The drag and drops work for me.

2.

3. If you are looking for the RGB multipliers in RT, they are somewhere else. Maybe the raw tab?


(Glenn Butcher) #4

There’s a reason for them, Adobe, that is, and that is to abstract all this stuff we talk about here so the majority of folk can just get Adobe’s thing and do their thing. Well and good.

But then, since they’re on this “get better images thing”, and they’re now shooting raw, and things they don’t understand now present themselves: “Why do my images not pop like my jpegs?”, “Why do the lines of this big building look so distorted?”, etc. They are now teetering at the brink of the rabbit hole, just milllimeters from falling into the world within which we wallow… :smile:

It is hard to work on your own car. Airline pilots are presently aghast at realizing the impact of the things the avionics is doing to make them fly safe. The world, particularly the first world, is an over-complicated place, it’s become impossible for anyone to fully understand all the things they use daily. My only real lament about it is that there seems to be a tendency for folk to accept explanations of things at face value, and not critically consider the underlying dynamics of abstractions, so they can use them effectively, even safely.

Me, not tempted by the ‘cloud’. I’m having too much fun bending C++ to my will… :hot_face:


(Elle Stone) #5

I used to be tempted on occasion to go back to Windows and PhotoShop, but the move to the cloud squelched that temptation permanently.

I think the problem is that Linux desktop software increasingly thinks it needs to be smarter than Linux users.

For example, I’ve never seen this before, but today when I right-click on a file and try to open it with a given application, unless it’s already an application to which I previously apparently gave my blessing, a notice pops up like this:

Warning:
This will start the program [insert name of program here].
If you do not trust this program, click Cancel.

If I hadn’t trusted the program I wouldn’t have installed it in the first place and I surely wouldn’t have tried to open the particular file with the particular program.

The particular aspect of “smarter than the user” that’s causing the problem is that apparently there are dozens (exaggeration of course, I hope) of files that keep track of which program is allowed to open which types of files.

On my system somehow there are a whole lot of programs associated with different file types, that just aren’t useful to me, such as the suggestion to use Krita for opening raw files and XCF files.
And those little “file type association” files (wherever they might be hiding) somehow aren’t finding the image ediiting/raw processing programs that I do use to open various file formats, aren’t successfully finding the executables, possibly because I’ve compiled and installed these programs myself.


(Andrew) #6

Does this help?..


(Elle Stone) #7

Hi @RawConvert - what I’m actually looking for is how to remove unwanted existing file type associations. For example, I don’t know how Krita got associated with raw files or with GIMP XCF files and I want to remove/delete this association.

It used to be possible to do this directly through the “open with” dialog. But either this was with a file manager other than dolphin, or else dolphin has changed.

In dolphin there’s a little “spanner” in the Properties dialog for any given file, that on my husband’s computer apparently allows to right-click and modify the list of programs that can open a given file type. But this doesn’t work on my computer. So I’m trying to figure out what to do to make the spanner clicking actually work, or else find a workaround.


(Elle Stone) #8

The list of ways to troubleshoot fixing file type associations is rather long:

https://wiki.archlinux.org/index.php/XDG_MIME_Applications#Troubleshooting

Each link in the above “troubleshooting” guide leads to a page full of information regarding things to check. It’s this “xdg” stuff. It’s supposed to make life simple and automatic. But in my case, on my computer, with my non-standard “not desktop” icewm, with minimal KDE and microscopically minimal GNOME libraries, none of this XDG stuff works. And stuff that used to work without even thinking, doesn’t work any more.


(Glenn Butcher) #9

Oh, that right-click thing has become irritating on both Linuxes and Windows. I recently set up my rawproc icons so I could drag files to them, works on both systems.

My new irritant with Ubuntu is they’ve take the “New File…” selection from their right-click popup menu. I used that a lot to make new .cpp files, now I either do it from the ‘+’ icon in gedit or I do it by hand from a shell window…

Ha, right now, I have four shell windows going. Wrote scripts to generate thumbnails for my new gallery, I’m compiling rawproc to test bug fixes, and I’m grepping libraw code to figure out how they do dcraw processing. Shell is such a powerful and flexible thing; I’m glad I’m old enough to have learned it… :smile:


#10

Elle,

You are on Larry the Cow (a.k.a. Gentoo), right?
What happens if you right-click on a certain file (type)?
Do you get a drop-down with alternatives such as
Open with || Open with other application?

/Claes


(Elle Stone) #11

@Claes - yes, I do get that right-click menu, and adding/deleting file type associations used to be possible within that menu. But somehow now the ability to delete associations is missing.


#12

Me on thin ice here (because I am not on Gentoo),
but if you cannot “delete” an association, you could
at least tell which app to use when you click on a
certain file type? – And click Use as default for this
kind of file


(Elle Stone) #13

OK, I think I just discovered part of the problem. When GTK3 collided with spacefm I switched over to using dolphin, which I actually sort of prefer over spacefm.

But just now I reinstalled spacefm (which now has the option to use GTK2 OR GTK3) and this file manager actually puts the ability to delete file associations right in the “open with” menu where it belongs

Now if I could just get dolphin to do the same, that would be good. But maybe I’m missing the kde library that makes this possible, and so far searching the internet hasn’t provided any light.


(Elle Stone) #14

Genius! These days it’s not sufficient to tell the file manager to use a given executable. Nope, the user must learn how to edit and use desktop files, even if the user isn’t actually using a desktop.

I just created links from the “desktop” entries in the folder “/usr/local/share/applications/” to the folder “/home/elle/Desktop” (there aren’t any icons on my actual screen, my “desktop” is just a vast expanse of middle gray). And when I dragged a png over and dropped it on the link to the PhotoFlow desktop entry, PhotoFlow very nicely opened the png, just exactly as @afre said earlier.

So now to make links to the desktop files for the several versions of GIMP installed on my computer, and to remove unwanted associations using spacefm.

@ggbutcher and everyone - thank you! for all the suggestions! This whole issue of how to easily open image file A using imaging software B without having to navigate through multiple level deep file structures over and over again was just getting out of hand. But I think I see a light at the end of the tunnel.

Tell me you aren’t serious - on Ubuntu you can’t right-click to make a new file? Hopefully I misunderstood your words!


(Glenn Butcher) #15

I’m usually very not serious, but this time I am. Serious. Not ‘not serious’. Also maybe ‘not understandable’… :smile:

I get a 'New Folder…", but no “New File…”. I now just go to one of the umpteen shell windows I have going, cd over there, and touch filename… easy-peasy. No?


(Glenn Butcher) #16

Yes. creating a .desktop file takes a couple of minutes, but I can drag from either Nautilus or Geeqie and it rawproc opens as if typed from the command line. Works the same in Windows, if one cares about such…

I’m collecting my imaging ‘zoo’ of late, AppImages for any who has one. I put them in my ~/bin, make a symbolic link to the appimage, and make a desktop icon to the symbolic link. So I now open images in rawproc, GIMP, or PhotoFlow doing this; will work on RT and dt next.


(Mica) #17

You should be able to make dolphin do that (and whatever you want, really). But I’m not sure of what KDE libs you’d need. I’m running the full plasma desktop and you can put anything anywhere, more or less.


#18

Running Linux Mint here. There is a “Preferred Applications” in the system settings where you can assign default program to open type files.

Desktop ShortCuts also help here. I have a few like Gimp AppImage and G’mic StandAlone, that I can drag and drop any image to. When I used to run Wine, I had a few ShortCuts for those programs as well.


(Ken Moffat) #19

As another icewm user, I sympathise (although as a “build it from source” person I normally avoid kde and file managers).

But I sometimes get a similar problem in texdoc (PDFs get associated with inkscape instead of evince or a better viewer). So I put a message at the end of the script where I build inkscape.

Translating to your problem:

xdg-mime query filetype /path/to/filename.xcf (or whatever your raw file type is)

and then xdg-mime query default image/x-xcf or whatever

  • that is just to confirm that a wrong program has grabbed it

Then to associate xcf files with gimp (because I don’t know they type of your raw files, or which program you prefer to use as the default)

xdg-mime default gimp image/x-xcf

If you don’t have it, xdg-mime comes from xdg-utils.


(Franz Trischberger) #20

Three options:

  1. In dolphin: open with -> Other application -> select your preferred application -> check the “Remember application association” checkbox.
  2. In dolphin right click -> Properties -> In the “General” tab under “File type” the is a button “File type options” where you can change the preference order of associated applications.
  3. In systemsettings got to “Personalization/Applications” and open “File associations”. There you can filter for file types and change preference order as in 2)

I hope you can get one of those working.
If not probably installing systemsettings does the trick.