Tiny interface scale

The interface is in a micro scale I can’t see anything, how can I change it?

Operating System: EndeavourOS
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.15.13-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 5600X 6-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3070/PCIe/SSE2
Display resolution 1920 x 1080

Thank you.

What Natron version are you using?
Can you please test the following :

Please use exclusively the binaries we distribute via the above github links.

thank you

1 Like

Thank you!
The version is the 2.41, downloaded from the Natron’s site.
I downloaded all the versions you recommended me and they all are small, I deleted the old 2.41 and replaced it with the version in your link.
I’m not using scale in the display settings, I have not any window compositor running, there aren’t any window rules or desktop effects.
Is it normal the windows count beginning in 2?

The terminal

It’s probably the window manager numbering the windows that way.

Are you using X or Wayland? (or maybe you don’t know)

Can you try any of the xrandr tricks in HiDPI - ArchWiki ?

If nothing fixes this, you’ll have to set your screen to a lower resolution.

Do you have issues with other applications than Natron?

The good news is that the Qt5 version of Natron (Natron 2.6) should handle this better, so stay tuned!

1 Like

Thank you !!

I tried to use Wayland but doesn’t work, I found the Nvidia drivers could be the reason. I’m using X as far as I know, and obviously I don’t know much about Linux :sweat_smile: The X is for X11, right?

The run_scaled worked!! Thank you for this fix, also thank you for the good news of the next version!
Yes, I had the same problem with Gimp, and G’mic, but never more with run_scaled!

glad to help!

1 Like