Tone equalizer mouse cursor problem

I am using dt 3.2.1 on Win10. I have noticed a strange behavior concerning the mouse cursor. Sometimes when I enable the module the mouse cursor over the image changes to the tone equalizer cursor, but most of the time it remains my regular mouse cursor. Here is a screenshot:

When this happens I discovered that if I move any slider, even just a little, that the mouse cursor will usually then become the tone equalizer cursor:

Am I doing something wrong? Am I supposed to do something to turn on the tone equalizer cursor?

In simple tab you have to select one of the levels (0 to -8EV) to get the cursor related to the tone equalizer, in advanced tab you have to select one node.

Thank you for your reply. The manual says something different though:

“When the tone equalizer module is selected, moving the mouse pointer over the preview image reveals a cursor that displays information about the pixel under the mouse pointer.”

It would be very useful to say a level must be selected to enable the cursor in the manual:

https://darktable-org.github.io/dtdocs/module-reference/processing-modules/tone-equalizer/

Did I miss it somewhere in the manual?

If it is a bug and the manual is correct then I hope it is fixed in 3.4 when it comes out this week.

That’s most likely a Gtk bug on Windows, where the tone EQ widget is not given the focus as it should. The cursor appears if tone EQ is enabled and if its GUI widget has focus (aka is currently capturing key and mouse events, in Gtk slang). Focus should be given when you click somewhere on the widget or enable the module.

Bugs don’t get magically fixed if nobody reports them on the bug tracker.

1 Like

Yes, so it seems. On linux (Ubuntu 20.04) the tone equalizer widget receives focus when the module is enabled (and the cursor changes correctly). No further selection of an other item is necessary.

Okay, likely a Windows problem. Thanks for the reply.

Software development has changed a lot, I guess. I was a software developer in the computer industry for a few decades. I fixed many, many, many bugs that had not been reported. Most of them I found myself. For most users it appeared the bugs had been “magically fixed.” :slight_smile: I fixed bugs officially reported also, but not only them. :slight_smile:

I guess no one has reported this before.

I’m also using 3.2.1 on Windows 10.

If I simply turn on Tone Equaliser the normal mouse cursor remains.

I questioned why I had not noticed this behaviour previously, and realise that it’s because whenever I use Tone Equaliser, I always open it, as opposed to simply turning it on.

Once Tone Equalizer is opened, the mouse cursor changes to the one associated with it.

Cranky, if you look at my screenshot you will see that the tone equalizer is both turned on and opened and yet the cursor has not changed.

Apologies, I was focussed on the text and missed that!

I installed 3.4.0 a couple of hours ago and it seems this problem has been fixed. With 3.2.1 the cursor would change about 10% of the time when I opened the tone equalizer module. With 3.4.0 it seems to do it 100% of the time. I tried it about 10 times and it worked properly each time. Thank you!

Just an update. When I wrote on 2020/12/20 that the problem is fixed in 3.4.0 on Win10 I spoke too soon. In my one session experimenting with it right after installing 3.4.0 it worked, but then since then it behaves the same as 3.2.1, i.e., it randomly works and doesn’t work. Maybe this is just a problem on Windows and not Linux and Mac?

The color zones module has a way to target particular areas by using the eye dropper and then a vertical black line appears on the color graph (which looks similar to the tone graph in the tone equalizer). So far the color zones method seems to work every time.

I really like the tone equalizer method, but sometimes it is difficult to get it to work. Sometimes changing one of the nodes will then cause the mouse cursor to change, but not always. I can’t quite narrow it down to a sequence of events where it won’t work, but it often seems to be when I have been in tone equalizer, the mouse cursor worked properly, then I did something else in a different module, returned to the tone equalizer, and now the mouse cursor doesn’t work. Or sometimes when I turned off the tone equalizer and then later turned it back on and now the mouse cursor no longer works.

I’d suggest filing an issue, if you haven’t done so already: https://github.com/darktable-org/darktable/issues

I’ve reproduced this issue in some scenarios on Linux and am currently investigating a solution.

1 Like

On 3.4 I have noticed on occasion that if I leave and comeback to the module or if I toggle enable or disable sometimes I cannot get the on screen interactive mouse pointer to return unless I reset the module. It seem a bit random and I could work around it but it has happened on a number of occasions. I will try the next time I do some edits to see if I can induce it in a predictable way…

A fix has been merged to master now and will arrive for v3.6.

2 Likes

That’s great! Thank you. After I saw in this thread where other people were experiencing the same problem I had thought I would go ahead and make a bug report, but since you have fixed it already that won’t be necessary.

Thanks again!

Actually, if it was up to me I would slightly change the behavior in the tone equalizer. I think this feature should be enabled by clicking an icon rather than be turned on automatically. Prior to 3.4 it was sort of broken because sometimes it would turn on and sometimes it wouldn’t. In 3.4 it was mostly fixed, but sometimes I find that it still won’t turn on.

Also, you can no longer just turn the mouse wheel to zoom in or zoom out. I think clicking an icon to turn on the feature and turn off the feature would be much better and more consistent with how things work throughout darktable (eyedroppers, etc.).

Tone equalizer needs to be switched on, expanded and have focus in order to work. If the module is on and expanded and you can’t see the altered cursor just collapse the module and re-expand it and it should work. Alternatively you can ctrl+click on the on/off icon or click anywhere inside the module in order to give the module focus. I haven’t had any issues with the cursor not working myself but if you do please raise an issue.

If you hold down the A key while scrolling you should be able to zoom while tone equalizer is active, and similarly when editing masks. You can change this shortcut in preferences > shortcuts > views > darkroom > allow to pan & zoom while editing masks.

2 Likes

I don’t see this issue in current git master in both Linux and Windows.
Tone Equalizer needs to be enabled and expanded for the cursor to appear.
No difference between Linux and Windows