trouble installing G'Mic GIMP plugin on Debian Stretch


(Goo) #1

So, I’ve installed GIMP 2.10.8 via flatpak on Debian Stretch. Then, I downloaded the G’MIC plugin https://gmic.eu/files/linux/gmic_gimp2.10_qt_debian_sid_amd64.zip and unzipped it. Then I placed the gmic_gimp_qt file in the ~/.var/app/org.gimp.GIMP/config/GIMP/2.10/plug-ins folder. However, when I launch GIMP, I see no G’MIC. Am I missing something?


(Mica) #2

Plugins are a bit of a PITA in the flatpak still. Are you opposed to using the AppImage? It has plugins like gmic included.


(Goo) #3

Anything that I can get to work at this point in time is welcome! Could you point me towards how to install via AppImage in Debian?


(Mica) #4

Download it from here: https://github.com/aferrero2707/gimp-appimage/releases/download/continuous/GIMP_AppImage-release-2.10.8-withplugins-x86_64.AppImage

Then chmod a+x gimp.appimage and then double click it, it should run.


(Goo) #5

In theory, that should work. But apparently, ChromeOS doesn’t have FUSE yet (currently in v71 – Debian Stretch).

$ ./GIMP_AppImage-release-2.10.8-withplugins-x86_64.AppImage
fuse: device not found, try ‘modprobe fuse’ first

Cannot mount AppImage, please check your FUSE setup.
You might still be able to extract the contents of this AppImage
if you run it with the --appimage-extract option.
See https://github.com/AppImage/AppImageKit/wiki/FUSE
for more information
open dir error: No such file or directory

Per https://github.com/AppImage/AppImageKit/wiki/FUSE and https://bugs.chromium.org/p/chromium/issues/detail?id=841787 it looks like FUSE will be in ChromeOS v73 in about 3 months from now.

Another dead end. Just wish there was something else I could do to get the qt plugin working with the flatpak!


#6

Hi @Goo & welcome!

Quick idea: how about compiling g’mic yourself?

Have fun!
Claes in Lund, Sweden


(Mica) #7

IIm confused… Are you running chromeOS or Debian? I run this AppImage on my Debian Stretch box and it works fine.


(Goo) #8

@Claes I guess that’s the next step! If I can’t figure out how to compile GIMP 2.10.x with G’MIC … I’ll be back here posting more!

@paperdigits I’m using ChromeOS which this year added Linux app support via it’s own Debian Stretch VM container. Full Linux apps on ChromeOS! (Still a work in progress…)


#9

Oh. Chrome OS with Linux support via a container…?
Sorry, I cannot be of any assistance at all with that combination.

You don’t have a spare harddisk on which you can run a full-fledged Linux?
That would make things easier :slight_smile: Or perhaps run a Live Linux distro from a
USB-stick - a setup which can be a trifle slowish but you can at least see how
things work.

Have fun!
Claes in Lund, Sweden


(G'MIC staff) #10

@Goo, have you tried to install the Debian package we provide on the web site ?


(Goo) #11

@David_Tschumperle earlier this morning I attempted with dpkg to install the .deb – however, after it was completed, I was left with a broken dependency chain and was forced to back it out.


(Mica) #12

Can your container access the network? The ChromeOS container/sandbox might be keeping you from completing the install.


(Goo) #13

Networking isn’t the issue:

$ sudo apt update
Ign:1 htp://deb.debian.org/debian stretch InRelease
Hit:2 htp://deb.debian.org/debian stretch Release
Ign:4 htps://storage.googleapis.com/cros-packages/71 stretch InRelease
Hit:5 htps://storage.googleapis.com/cros-packages/71 stretch Release
Get:7 htp://security.debian.org/debian-security stretch/updates InRelease [94.3 kB]
Fetched 94.3 kB in 1s (75.6 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.


(Goo) #14

@Claes do you have any quick links to build GIMP with G’MIC on Debian Stretch? Could save me a lot of time locating them if you have 'em handy :slight_smile:


#15

Morning, @Goo,

No :slight_smile: Building The Gimp &c from scratch calls for a strong will and has a lot of dependencies. Search this forum for compile gimp and you will see what I mean.

Got a spare partition on a harddisk? A spare USB-stick? (See my post above.)

Good luck,
Claes in Lund, Sweden


(Carmelo Dr Raw) #16

There is still one possibility you can try if you don’t have FUSE support:

  • run the AppImage with the --appimage-extract command-line option to extract the contents
  • re-run GIMP from the extracted bundle with squashfs-root/AppRun

Let me know if this workaround works for you…


(Goo) #17

@Carmelo_DrRaw Absolutely brilliant !! Finally have G’MIC (in GIMP) on ChromeOS! Let the imagery/animation work (for me) continue !!


(Carmelo Dr Raw) #18

Glad to know I was of good help!!!