Trouble Updating G'Mic on Ubuntu via PPA [Solved]

I just realized that my G’Mic is out of date and it’s not updating.

I’m running Ubuntu 18.04.

I’m trying to get the updated LUT generator described here.

My G’Mic version is stuck at 2.4.5. I (try to) keep both G’Mic and GIMP updated via the otto-kesselgulasch PPA. Even though G’mic seems to be up to date @ v2.7.0 in the PPA, it does not update on my machine.

Any tips on how to troubleshoot this and get the 2.7.0 version installed? gmic 2.70 for Bionic only just appeared.
Finally a gmic_gimp_qt for Bionic where the compile has not failed. However, just downloaded the deb and that plugin does not work here. gmic_gimp_qt suspiciously small at 2.4 MB.

You can use the gmic_gimp_qt plugin for Gimp 2.8 from That works ok with Gimp 2.10.12 - just tried it. (Gimp 2.8 is default for Bionic hence that version)

or I keep a “compiled for 'buntu 18.04/Mint 19” here: gmic_gimp_qt and Ubuntu 18.04

Either of those: Get the zip, unzip put in ~/.config/GIMP/2.10/plug-ins

Works here kubuntu 18.04:


Wow! He must have added that just a few minutes after I posted in here.

I just updated via the PPA like usual, and was able to update the G’Mic filters. So the problem is solved.

I’m glad you pointed that out.


1 Like