Two mild GIMP irritations [SOLVED]

GIMP 2.10.34 Win 7 (no, not going to upgrade yet)

  1. In File>Open and File>Open As Layers the drop-down comes up set to my Windows User folder and I would prefer that to be my Desktop folder. Probably related, but sometimes it saves images or itself to the User folder, not the Desktop, grump.

  2. If I ‘Export As’ a TIFF it exports the Layers variety which some viewers e.g. FastStone won’t open as images.

I had a quick look in prefs but the answers didn’t jump off the page (I’m old).

Thanks for looking …

In the GIMP ‘Export As’ dialog, I un-selected the save layers checkbox. Opening the TIFF in FastStone only came up with one “page” this time but it was still black, grump.

I’ve never liked TIFFs that much and don’t care for Adobe anyways, so I’ll probably forget anything Adobe for GIMP work.

Question 1 still open though …

Hi Ted, I suspect an easy solution for you is to add the locations you want as a favourite location. There is a + and - symbol to add or remove favourite folders on your computer. In my screen shot here you will see I have two favourites folders added. One called Gimp Samples and the other Photodownloads and of course GIMP populated its own selections above.

I am not familiar with FastStone but previously have had issues with tiff files from GIMP or DT not opening in other programs. Tiff files unlike PNG files can contain layers and this is a source of incompatibility for some programs so untick the layers option, which you seem to have done. I would also not use any compression if you are having compatibility problems. Another option is that tiff can be spelt with one or two f’s and maybe changing tiff to tif might help. Surely being in capitals or lower case is not an issue, but maybe consider that as well. Also would exporting as PNG resolve the problem for you?


@xpatUSA There are other considerations to be made. If you could share an example GIMP XCF and corresponding TIFF for examination, we can figure out what is relevant to you.

The reverse of @Terry’s folder bookmarking tip is to create a shortcut to the user folder. This will save you the click in GIMP’s save dialog. As a side note, I would recommend against using Desktop as a save folder for two reasons:

  1. Files on the Desktop will slow down your computer. Yes, Windows consumes additional memory to maintain the icons and thumbnails on the Desktop.
  2. It is best practice to save files under a specifically named folder rather than a systems-defined or generically-named location.
1 Like

Thanks for the examples. Played around with the + and - in the ‘Open’ dialog mostly getting ‘can not be removed’ when I hover the mouse over the ‘-’.

Also found these:

and the manual:

Section 2.4.2 refers, sorta.

I’m on GIMP 2.10.4 and I’m trying to change the default working directory that the GIMP opens in which is C>User>Ted and I want it to be C>User>Ted>Desktop

I use TIFFs when going from the GIMP to another app for some reason, so as to avoid JPEG artifacts while moving from app to app. PNG is good enough for that, I reckon.

Here you go:

Opened by double-clicking the shortcut - the working folder on open was the User one - then opened a JPEG on the Desktop - the working folder had to be changed for that.

then saved that as a TIFF with layers de-selected:

Thanks for looking!

There’s always been a shortcut on the Desktop to that folder.

[edit] … FIXED !! …

I found the GIMP exe and sent it to the Desktop as a shortcut. Then edited it’s ‘Start In’ property to be my Desktop path (guess what it was …). Then deleted the old shortcut from the task bar. Then re-started the computer et voila problem 1) has gone away. [/edit]

Thanks Gents!