Unable to import

I had problems getting started with Darktable, and uninstalled and deleted all darktable folders, then reinstalled again.
Now I’m unable to import any image files. When I try to import, darktable only acknowledges that there are 4 images in my folder Photos. There are a dozen folders in Photos, and a dozen folders in each of those, but when I click or double-click on one of the subfolders, the dropdown triangle next to the subfolder name disappears and … nothing else happens. I have tried moving photos into the main Photos folder, but darktable still only lists the initial 4 images.

When I try to add one of the four images that are listed I get the deathface icon and am told the image is not available.

You need to tick the recursive directory box

I’m still not able to see any subfolders:

You select here a folder that doesn’t seems to have subfolders. So it’s normal that you don’t have subfolders…

It has a ton of subfolders and sub-subfolders:
Darktable doesn’t acknowledge they exist.

Do these help?

This is for an older version:

Newer version:

Could you try without the # and & in the main folder?

When I just select the main folder Photos I get a selection of images from the subfolders, with their directory path. This would be fine – ok, a little bit of a hassle – if ALL the pictures were listed, but it seems to be a random selection:

And when I exclude jpg, my selection narrows to just two raw files and some tiffs:

Let me assure you that there are hundreds of raw files I’m trying to access. I currently have a workaround – I open GIMP, then Open a raw file I want to work on in Darktable, and then GIMP automatically causes Darktable Darkroom to open with that one individual file open for editing. I really would like to get Darktable working as it’s supposed to work. Somehow, I corrupted the install the very first time I installed Darktable, and I’ve never been able to get rid of whatever I screwed up.

Can you show in Windows Explorer what you have in the folders Photos, Photos\Favorite Pictures and 2019 keep? (3 screenshots)

try running DT with a clean empty config directory. Create an empty folder and then when you run DT modify the command line in your shortcut and add --configdir “empty dir name” to the end . This will run DT using all new config files…see if that helps

I think I see a problem in the image. It looks like you are navigating to your photo folders via windows libraries path (i can see the My PC).

Go back to the left side and try to select from the actual hard drive location. I cant show you with a screenshot since I am not at home.

Can you show (as you showed the folders tree in explorer) the content of one of the sub-folders for which dt remains blind (I would like to see the actual path + file name of those files) ?

The folders tree above is located on a cloud drive. Do you have the same issue with images on a local drive ?

It could be the cloud. I use OneDrive and files in the local sync folder will open if they are actually local. Those set for download on demand do not. Might be something similar??