Unsupported input profile when using Capture NX-D profiles


#1

I wasn’t very happy with the colors I got in some of my pictures, so I decided to try using ICM profiles from Capture NX-D according to the instructions detailed in the RawPedia. I got nicer colors when I applied one of those profiles but I got an “unsupported input profile” error as soon as I started to use any module in darktable. I try all the profiles, some produce the error immediately after selecting them, others seem to be applied but fail when I try to further edit the photo.

I googled the error and only could find a thread from a mailing list where someone suggested having “Nikon sRGB 4.etc” as the default profile in Options / Colour management / Default color space. I cannot find that setting in darktable options, though.

Am I missing something in the process? I’m using the Windows port of darktable 2.4.4 and the latest Capture NX-D


#2

The suggestion about the Nikon sRGB profile concerns the settings of Capture NX-D. Once you set sRGB, Adobe RGB or ProPhoto RGB as your working space in NX-D, you need to restart that program, look for the temp folder where the Nikon .icm profile resides and copy it somewhere. Rename the extension to .icc so that dt can use it (and you can re-name the profile to something shorter than the long, cryptic name NX-D gives it).

Then place that file in the darktable\color\in folder and re-start darktable. You’ll need to use the “unbreak input profile” module. The settings that work for me are: linear (0), gamma (0.4500). You’ll also need to look into the base curve module and reset it to linear (or switch it off).

It works for me for my Nikon Coolpix A, darktable 2.4.4 (Windows), Capture NX-D 1.5.


#3

Thank you! I didn’t think I had to configure Capture NX-D; that was the missing piece. However, it worked for one of my cameras (d3100) but it still generate unusable profiles for the other one (d5600). For the d5600, all profiles produce the error except one, which seems to have negative-like colors.

Anyway, I’m going to keep trying. I’m going to post here again if I get positive results.

Just in case anyone else need it: I already had Capture NX-D using Nikon sRGB4, changing it to IEC 61966-2-1 make it work.


#4

Try this: create a new folder for one NEF file from the D5600. Run Capture NX-D and navigate to that file; apply the Picture Control you’d like as the basis of your conversion – I prefer the Neutral one. NX-D might generate a couple of temporary icm profiles (some of them might give you the problems you describe), so at this point I’d re-start the program once again, open that one photo, go and copy the temporary icm file. It should be fine to work with in darktable.

Also, make sure you check the “Use this instead of…” setting in NX-D preferences:


#5

Thank you for you’re detailed response and sorry for my late reply, I’ve been busy these days. I tried what you said but got the same results. I tried with a photo taken with Neutral Picture Control and Active D-lighting off but Capture NX-D generates two color profile files, one with weird colors and another “unsupported” on darktable. Changing the Picture Control and turning off AD-L in Capture NX-D has no effects in the color profiles. I also tried several color spaces (Nikon sRGB, Adobe RGB and IEC) and made sure the “use this instead of” option was checked. Also, the files are a lot bigger than the ones for the D3100; about 1.6MB each.

I’m starting to think that photos from the D5600 are processed in a slightly different way incompatible with darktable. I’m going to keep trying with different settings, though.