Unusual "block patterns" after applying Style


I’ve been using darktable for a while but I am no expert.
I use a Fuji X-T30 and find that my raw images look very dark after import.
After looking around, I found that some 3D LUTs (see an attached example) and started using them together with a bunch of other adjustments to make the raw image look a little better.

I am now finding that the application of these LUTs causes a weird block pattern after I apply them. It is not consistent and sometimes disappears after zooming in / out. Changing the interpolation method did not help.
See an example in the attached images.

Any ideas?



Hi @Ori and welcome!

When “developing” RAWs from a Fuji,
set EV = +1.2 in exposure.

For additional info, read Aurélien Pierre’s posts on this subject
here in this forum.

Have fun!
Claes in Lund, Sweden

Depending on the dynamic range setting :wink:
Roughly +1 EV for DR 200%, +2 EV for 400%. But! Highlights might be blown then.
The auto-matched tone curve without any exposure correction will give you a hint on what the camera “wanted” to do.

BTW the pattern is very unusual, maybe you want to put an affected RAF into the PlayRaw section?

The Hald CLUT (aka 3D LUT) is 1728*1728 pixels, so a cube 144 on each side. That isn’t a problem, if the software interpolates. But many input colours to the LUT will have the same output colours. This is because the LUT has 2985984 entries but only 1385985 unique values. On average, a bit more than 2 inputs will have the same output.

This may contribute to the blockiness. It certainly suggests something is wrong with the LUT.

Do you have openCL enabled? if so, try turning it off and see if it helps, I remember having a similar issue when I started using dt and haven’t configured my openCL correctly.

I have the same LUT package and there’s nothing wrong when I tried using it.

1 Like

Moinchen, @Sunhillow

a) OP talks about raw files. See conclusions, here:

b) In Scene-referred workflow, default exposure is set to +0.5EV, but Fuji X-Trans
needs an extra 0.7EV, thus +1.2EV. See exposure, here

Claes in Lund, Schweden

Thanks. It looks like a good value.
I’ll look for Aurélien’s posts.
I don’t think this will solve the problem.

@Sunhillow ,


It seems to be the same on most of my raw files. Sorry for the stupid question but where is the PlayRaw section?

Also @adrs - No openCL.

Correct: it will not solve your block pattern problem,
“just” the “too dark” problem :slight_smile:

There is no stupid question :upside_down_face:
Here it is:

BTW, does your problem also appear when you use one of the standard profiles? Or a LUT from another source? I also use these X-Trans III LUTs from time to time, but cannot see such patterns with my X-E1 and X-E2 cameras


It seems to happen only when I use the 3D LUT module.
I tried a different LUT - same phenomena.
I do need to reiterate that these patterns usually go away when I play around with the zoom so it’s more to do with what is rendered on the screen than what is actually going on with the photo.

Anyway, the photo is here:

Tried it with the same and different LUT, with openCL enabled and not, moving around when zooming, and there’s nothing wrong with the preview.

What version of darktable are you use? Is it happening on a different image? Do you have another active module too? If yes, maybe also attach your sidecar xmp as well so we could replicate it.

1 Like

I believe I had the same phenomenon with a LUT I created with G’MIC. I might look if I can recreate it…

Otherwise, the LUT you posted works fine for me.

Edit: Couldn’t reproduce it… :man_shrugging:

@adrs I’m using 3.6.0 (but IIRC it was also there in 3.4).

@apostel338 Thanks for trying!

I guess it must be something to do with my hardware / drivers.