Upgraded Darktable 4.2.1 win64, now DT just quits

These entries are present even on a fresh install (empty config directory when dt is launched) of git master (4.3.0+1143~g6e46d025b4) on Linux. I have no idea what purpose they serve.

After upgrading to 4.2.0 DT is extremely slow, and sometimes crashes. I’ve tried everything suggested in many forums, unfortunately it behaves well after applying the many suggested fixes then a few days later I’m back to turtle speed on a modern i7 with 32GB RAM and a high-end NVIDIA card. I really like DT, it is incredibly rich, but what good is it if it keeps crashing, or slows to a crawl. I use another commercial software which is nowhere near as good but it never crashes, never takes two minutes to export a JPEG, and definitely does not use up 90% CPU. It was a nice run. Maybe after at version 5 we’ll have a leaner and more modular software, and I’m not referring to what appear to be modules on the screen, I am referring to internal software components.

@Karim_Nasser : Remember that for most people darktable is running very fast without issues, so please do not conclude anything bad about your experience.

Are you using Windows-11? We had one report of a user on a French forum having very bad performances on Windows-11. Maybe there is some compatibility issue between both.

1 Like

I use Windows 10. So this forum is about sharing good experiences only? That’s not what I am reading. I am posting my experience not to bash the software but as a feedback for the developer to hopefully address these issues. As I stated this slowness and crashing happened after the upgrade to 4.2.0.

Why getting angry this fast! There is nothing wrong on my message, just trying to understand. This kind of reply are really depressing… I’m a dev and I’m certainly not anymore looking at this.

Taking an extreme approach. Try installing 4.21 now. Might as well use the newest release. Install in a new directory not the default one.

Then create a modified shortcut and run DT with --configdir parameter so --configdir “path” where path is a new blank folder of your choice to house the config files. This is a clean unrelated install with all defaults… how does this work??

Certainly not. But “this application got slow” tells us nothing, and you seem like you’ve already given up trying to figure our what is wrong.

If you don’t want to figure out what is wrong there is nothing we can do to help you.

I am not angry one bit, what gave that impression?
“This kind of reply are really depressing” Why are you depressed? :slight_smile: I too am a developer, and I welcome feedback anytime.

Cheers!

I didn’t experience any slow performance issues, I’d consider that a separate issue.

I think one way or another DT needs to implement a genuinely clean install/uninstall, It was really only after these steps that everything cleared up:

  • Uninstall DT

  • Remove or rename: C:\Program Files\darktable

  • Remove or rename: C:\Users\(username)\AppData\Local\darktable

  • Remove or rename: C:\Users\(username)\AppData\Local\Microsoft\Windows\INetCache\darktable

  • Re-boot, Re-install DT

Some custom settings may be lost, but that might be OK because I noticed some changes once things were cleaned up that i wouldn’t have noticed otherwise, it seems certain things could persist for a long period without the user being aware, even if only one or two steps above is done but not all - if you’re not sure just rename folders instead of deleting.

Doing these on windows as part of an uninstall is considered bad form. Those are user generated files that contain user generated information and they are not recoverable if removed.

Then clean install or clean uninstall options need to be presented.

Do you still have your original darktablerc file from appdata?

I’ve seen multiple report like yours and I’ve tried to understand what’s going on. Ive asked for someone to share the files but so far no volunteers.

Its documented so people can choose to remove it or not. I’m not sure why people the uninstall/reinstall paradigm does any good.

darktablerc.TXT (38.9 KB)

(attached)

Is this the before? The after? I would like both.

OP, sorry for the kinda off topic.

that’s the old one before fixing the issue

Can you send the current?

darktablerc (2).TXT (38.4 KB)

(current)

These are difference:

cache_memory=536870912
host_memory_limit=16347
ui/style/preview_size=250
Plus OpenCL ones that we should not be using anymore

I’m going to add the host_memory_limit to my windows build to see if it causes an issue. Can you try the same to see if your issue returns?

Does darktable use ImageMagick? That’s the only program I know that uses the name “Magick”.