Upgrading challenges from ver 4.0 to 4.2 on Linux Mint 21

Last year began using ver. 4.0 after installing it using Flatpack to install Darktable. However, the Mint software manager shows that the Flatpack current version of Darktable is still set as version 4.0 not 4.2. Do I have to wait for Flatpack or is there an alternative way to install ver. 4.2 on Mint?

Is mint using flathub? Flathub is at 4.2.1, if you can get it from there, please do.

I am using 4.2 on mint from flathub. I expect 4.4 will be out next month.

Thanks Terry, I went to Flathub and tried to Install DT 4.2 from there, however, nothing happened. I must be doing something wrong. I even tried using the manual install instructions, using those I get feedback saying “a stable version already exists”, do I need to remove DT 4.0 first? I don’t recall having to do that in the past.

Do advise waiting until version 4.4 is available?

Thanks again.

I just went to the Darktable download site install | darktable

It installed fine for me. There is a version 4.4 due out next month, so it may be worth just waiting for that unless there is some feature of 4.2 that you really want to use.

Thanks… I’m going to wait for 4.4 then.