Using digikam appimage on Ubuntu 20.04 LTS

I installed digikam from the Ubuntu snap store on Ubuntu 20.04 LTS. It was version 6.x. It worked but did not recognize my smartphone and camera. Then I saw that the latest digikam version is 8.3.x So I uninstalled the snap package and downloaded digikam appimage for Linux. But the appimage doesn’t run. I am using other appimages (like rt 5.10) . I suspect that my system lacks some software that digikam depends on.

Is there a website I could check to know the software pre-requisites for using digikam appimage?

If you launch the digikam appimage from the terminal, what is the output?

Hello, an AppImage bundles all the necessary packages, so no pre-requisites required.

Yeah, that one is not going to fly with 'buntu 20.04

In my kubuntu 20.04 in a terminal this error.

digikam: /lib/x86_64-linux-gnu/ version `GLIBCXX_3.4.29’ not found (required by /tmp/.mount_digiKaRu0mZj/usr/lib/

It does work in a kubuntu 22.04

I guess you are stuck with an old version. A PPA has 7.10

Nothing happens… So I tried to check some logs. Here is a sample.

Looks like there is some basic issue with running this appimage on my system. Other appimages work ok. Will probe.

Yes that’s what I thought. Looks like there is some issue external to appimage on my system. Will probe. Thank you.

Wow Thank you. That might explain it. I will try the ppa. The lower version shouldn’t matter I guess because my use would be basic. 22.04 is in my wishlist but not for this reason :slight_smile: Thanks again.

Hi all!
I also have a similar problem.
Since many years I successfully work with Digikam (appimage) and Ubuntu OS; my last DK working version is 8.1, with Ubuntu 20.04.6 LTS.
Months ago, to solve a problem with camera recognizing, I downloaded DK 8.2 (appimage), but it didn’t start at all.
Now I downloaded version 8.3 64 biot, always appimage, but this version also does not start.
In system monitor appears only a “flash” for digikam 8.3 then disappears quickly.
What can I do?
Thank you.

@Antonio.A Thank you so much for the tip… I tried 8.1 appimage and it seems to be working on my Ubuntu 20.04… Will check functionality and camera recognition soon…

Thank you for the attention, but my problem is with DK versions 8.3 in OS Ubuntu 20.04.
The only problem I have with 8.1 is about camera recognition (I was told it should be solved with ver.8.2).