Using Sirilic issues (and background extraction on each light frame)

Hi all,

With ever on going struggles defeating gradients in my AP images, I stumbled into a a topic on CN describing effective way’s of dealing with gradients on each individual light frame in the stack. This should give really excellent results (for instance if you look into this example)!

Problem is that I do not seem to get it working. To start with: when, I set up my first project with 3 sessions plus light, bias and flat frames for each session.

When I choose “run scripts” I get:

**** copy_link() :Command ‘mklink “C:\temp\SirilTMP\IC417\DSLR\Auriga01\OFFSETS\SRC\IMG_0119.CR2” “E:\astro\foto’s\ruw\2021_02_12\bias\IMG_0119.CR2”’ returned non-zero exit status 1.*
***Symbolic Link Error on Windows: Check if the “Developer Mode” option is enabled

But I already have this option enabled (I assumed the option under preferences “Enable Siril dev …” is what is needed to be set), still it fails. I am on windows 8.1 btw.

(also I would like to setup BG extraction on each light frame, but it is not very clear how to do so. But first priority seems to be getting sirilic to do anything at all, so I hope to get back to BG extraction later :wink: )

If anyone could help this would be most welcome!

Hi, it’s the developer mode of windows, not of siril, that you need.

Ok, that explains a couple of things, thanks! Now I run onto another problem; that is how to get win8.1 into development mode? In win10 this is a build-in option, but this seems not count for win8.1… Or should I install Visual Studio and set it from there?

It’s not available on all versions of windows.
You’ll have to copy the files instead of using symbolic links, I don’t know if sirilic can do it, maybe it’s in the options? @M27trogonondepomme

If the error is from siril, it should fallback to copy instead of making an error and stopping, in that case it’s a siril problem, not sirilic.

Unfortunately, the developer mode of Windows 10 does not exist on previous versions of Windows. To use the symbolic links, you must start Sirilic in administrator mode.
Otherwise, in the preferences, you must uncheck the option ‘use symbolic links ( replace the copy)’.

Thank you @vinvin and @M27trogonondepomme. I will try to run sirilic again on my win8.1 machine in admin mode, to see if that works. Currently I am running a stack on another (Win10) laptop, which does indeed seem to work.

Something still goes wrong, the stacking runs but some read error occur on each seq file:
***Reading sequence failed, file cannot be opened

The script does finish and Siril is launched though, showing a result (which is not looking very good)

So anyone know what’s wrong here?

I know that sirilic is not developped and not tested on macOS.
Maybe there are some issues? @M27trogonondepomme could tell more about that.

However, you can use Siril and remove the background on each image in one click.

Which version of SiriL and Sirilic do you use ?

I am running Siril and sirilic-V1.13.1. On windows 8.1 and windows 10 btw, not Mac.

Since sirilic did not give much succes I now try running scripts directly on Siril. I first ran the “build-in” script OSC_Preprocessing.ssf, after editing it (I do not have darks, so I threw out the darks preprocessing and substraction from the light). This runs fine, but also gives a strange final result with lighter spots all over the frame (It looks a bit like it added flats instead of substracting). This final result looks simular to the result that came out of sirilic btw.

I suspected something fishy in the script (I am not so experienced in scripting stuff) so I found and downloaded the OSC_Preprocessing_noDarks.ssf and ran that script. Now it converts (at least) one of my Canon RAW’s in the series into a FIT that is 1 pixel larger than the rest, which on its turn raises an error during stacking…

So somehow I run into error after error, so it seems…

Could you re-run Sirilic, and then send me the following files: sirilic.log and script/sirilic.ssf.

1 Like

@M27trogonondepomme I run sirilic again and attached the files you asked for (renamed to .txt, otherwise it would not upload).

Edit: corrected an error in uploading the same file twice…

sirilic.log.txt (165.7 KB)
sirilic.ssf.txt (1.7 KB)

I understood the problem that is not a problem.

It appeared with SiriL 0.99.4 .

Indeed, SiriL in ‘single fit’ mode:

  • tries to open the sequence without ‘_’,
  • fails with the message “Reading sequence failed, file cannot be opened:”.
  • opens the sequence with ‘_’ and succeeds
  • then continues the treatment

This is normal operation.

For my part, I prefer to work in “multi-fits” mode which is faster and creates one FITS file per image sequence.


Allright, thank you! Good to know that this is normal behaviour of the tool.

Still I get pretty awful result when stacking in Siril (both with or without Sirilic), not sure how to explain that. For comparison, I took a subset of my Auriga lights and stacked them both in Deepskystacker and Siril, underneath are the results after autostretch in siril and color calibration.

Stacking with deepskystacker:

Stacking with Siril:

I will try the multi image fit option.

can you post an image of the process (process tab) so that I understand the treatments applied to the images?

Looking at the sirilic.ssf file, I noticed that you create a master bias but you don’t use it. In the script, there is no dark: is this normal?

I think you have a problem on your master flat (there are a lot of small round spots visible on your two pictures).

But if @vinvin or @lock042 pass by, they will be able to orient you better than me.