Using third party 2.8 plugins in GIMP 2.10

Does GIMP 2.10 find third-party plugins installed for 2.8?

It seems like it does not in my case: Ubuntu 17.10, I installed GIMP 2.10 from the official flatpak install, and installed the distribution package gimp-plugin-registry.

I saw that the location of plugins has changed in 2.10 (to something like ~/.var/app…). I did not see that documented in the GIMP 2.10 release notes. Anyway, in GIMP 2.10, I changed Edit>Preferences>Folders>Plugins and added paths to the old locations (something like /usr/local/lib/gimp/2.0/plug-ins, which is unique to Ubuntu?) and restarted GIMP, but it still did not seem to find the plugins I expected (specifically, resynthesizer set of .py plugins.)

I also built resynthesizer from source and installed it. Still GIMP 2.10 failed to find it. I suspect the build scripts need to be updated to the new install locations for GIMP plugins. But shouldn’t my changes to the preferences mean 2.10 would find the plugins for earlier versions of GIMP? Maybe I made a silly mistake.

Also, anyone have notes on building plugins for 2.10 using the old automake scripts for the gimp plugin template, e.g. do I need a new libgimp2.0 as well as changing the scripts to define a new install location?

The flatpak install will never see the distribution installed gimp-plugin-registry. The flatpak is sandboxed. ~/.var/app is flatpak’s directory for settings, so it doesn’t interfere with system installed applications.

I’d recommend that you just add the 2.8 plugin path to the 2.10 flatpak. You can do that in the settings.

You can certainly add plugins to the flatpak - this using Kubuntu 16.04 and Gimp 2.10.2

Where to put them. Sorry to have to refer to screenshots and your installation might have installed differently but…

The flatpak profile /home/rich/.var/app/org.gimp.GIMP/config/GIMP/2.10/ was created (originally with gimp 2.10.0) but was empty, why I do not know.

The more regular profile /home/rich/.config/GIMP/2.10/plug-ins/ is there, but I can not remember if I had to add to the Edit -> Preferences -> Folders -> Plug-ins section.

screenshot of that: https://i.imgur.com/T0MJXCa.jpg

What I did add was a more convenient place for resources, scripts, brushes, plug-ins as shown.

Plugins:
Python plugins will work.
Compiled plugins are another matter. Resynthesizer will work without problems. Other compiled plugins might/will have dependencies which because of the flatpak ‘sandboxing’ need to be added.

So at the moment my plug-ins look like this, and all of them work. Some of them I do compile in a 'buntu 16.04 VM. Resynthesizer / nufraw / gmic-gtk for example but many of the old Gimp 2.8 plugins work.

screenshot - resynthesizer / heal-selection: https://i.imgur.com/F2G4ila.jpg

Seem to recall a similar post a week or so ago.

Also if the flatpak sandboxing is a problem, there is an AppImage which has a few plugins like GMIC included. I’ve used it extensively and enjoy it.

I tried again to use Edit>Preferences>…>Folders to point to the location of existing plugin-ins (/usr/local/lib/gimp/2.0/plug-ins on Ubuntu). Restarted GIMP 2.10 failed to show the plugin in the Filters menu. Yet when I copied a .py from that directory to the sandbox location, the plugin appeared in GIMP.

Maybe it has something to do with the sandbox, because what I briefly read about Flatpak, the app must ask permission to access files out of the sandbox, and maybe GIMP is failing to ask permission, a bug in GIMP? I still don’t understand it. A learning curve with flatpak that I must get past.

FYI to start GIMP in a terminal (to see whether it prints errors about plug-ins) the command is: flatpak run org.gimp.GIMP . More traditional ways to find and run the GIMP executable didn’t work for me.

I suppose if GIMP is going to flatpak, then third-party plugins themselves should be packaged as flatpaks?

IMHO your ‘third party’ plugins should be nowhere near /usr/local/lib/gimp/2.0/plug-ins
The correct place is ~/.config/GIMP/2.10/plug-ins or some other folder you designate.

Starting the flatpak from a terminal is ok for a checking missing dependencies but…
The syntax for starting gimp is a bit strange. I do know a Mint user where the correct launcher was added straight into the menu system.

I made one myself, this is the command, straight from the gimp.desktop file included in the flatpak

/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=gimp-2.10 --file-forwarding org.gimp.GIMP @@u %U @@

Nothing complicated apart from that line, this is my kubuntu menu manager. (sorry another screenshot)

I quite like the flatpak, it is quick to open and stable. Only wish the org.gnome.Platform package was a bit more comprehensive.

AFAIK, /usr/local/lib/gimp/2.0/plug-ins is unique to a plugin built and installed using automake tools on an Ubuntu platform. Yes, it is non ordinary, but Ubuntu sometimes does things a little out of the ordinary. And maybe that will change after Ubuntu starts distributing 2.10.

AFAIK, before 2.10, the usual place to install third-party plugins was ~/.gimp2.x/plug-ins, not ~/.config/… Because I think that path was one of the default plugin paths in GIMP. Do you know when that changed?

I don’t understand why any of the older “usual” paths for third-party plug-ins is not one of the default plugin paths in GIMP (in Edit>Preferences>Folders>Plugins). When I installed GIMP 2.10 one of the paths is to the sandbox (/home/foo/.var/…) and the other was to /app/lib/gimp/2.0/plugins. I don’t understand the latter. There is no /app directory on my machine. Maybe that is the intended location of third party plugins, and that anyone that uses flatpak will have that directory and that Ubuntu will start supporting flatpak by creating that directory. That path name “…/gimp/2.0/…” makes more sense than the old path …/gimp2.x/…" since most plugins are mostly dependent only on libgimp2.0 and not any specific features of any GIMP version e.g. 2.7 vs. 2.8. But I haven’t yet found any official documentation about this change in GIMP.

It doesn’t matter what the exact location is, if a user adds a path to the preference, GIMP should look there.

Isn’t Ubuntu already distributing 2.10? I run Kubuntu 17.10. I struggled forever trying to figure out how to compile more recent versions of the Gimp. One day, 2.10 magically appeared after a sudo apt update && upgrade command. I’m now running 2.10.2 which I got the same way.

I am pretty sure that I never added any private PPAs.

I think that is true if typ. using make && install but do you really want your ‘bespoke’ plugin in with all the rest of the default gimp plugins. Although it is a matter of choice.

That changed with the dev Gimp 2.9.x so it has been around a while. Feel sorry for Windows users who have to cope with C:\Users…id…\Appdata\Roaming\GIMP\2.10

That is very true and I do not understand why it does not work for you.

FWIW where the gimp flatpak files are.
/var/lib/flatpak/app/org.gimp.GIMP/x86_64/stable/24…some-long-string-1108/
and the library files
/var/lib/flatpak/runtime/org.gnome.Platform/x86_64/3.28

It is worth looking in the folder that gets installed in home
~/.var/app/org.gimp.GIMP/
fontconfig / thumbnails / even gmic settings.

but for the gimp config files and users resource folders back to ~/.config/GIMP/2.10

I am still on (k)ubuntu 16.04 on the basis that I do not want to reinstall every 9 months or so.

Using 'buntu 17.10 / 18.04 then the place for Gimp 2.10 is the ppa
https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp-edge/

Your resynthesizer compiled without problem. (edit: that is a bit ambiguous - in a 'buntu 16.04 VM with Gimp 2.9.9)

Yes, you’re right, 3rd party, bespoke plugins should probably not install with official plugins. For one thing, it requires sudo (on the other hand, is it safe to not require sudo?)

Also yes, the resynthesizer documentation describes an obsolete location for bespoke plugins, as you say, it changed circa 2.9 to ~/.config/…

Germane discussion at //github.com/flatpak/flatpak/issues/328 . One thing it says is that GIMP installation migrates bespoke plugins say from ~/.gimp2.8/plug-ins to ~/.config/GIMP/2.10. I suppose my installation of 2.10 did not find the existing resynthesizer precisely because resynthesizer was in a strange location. Another reason to install bespoke plugins in ~/.config/…

I still don’t understand why Preferences>Folders>Plugins does not list ~/.config/GIMP/2.10/plug-ins

I think the fix for resynthesizer build scripts will be to make the plugin installation directory a command line option, with a default different from what is now is.

1 Like

I had written this up a while ago to help folks figure out where to point folders for scripts/plugins/assets:

Not sure if it’ll help here.

1 Like