vectorscope in Darktable

I’ve installed the Darktable under development. First of all I would like to thanks to all developers and people involved in Darktable.
One of the upgrades is the vectorscope. I see it very useful combined with the color balance module. I’m focused in color theory studies from the art point of view so this will help me a lot.
I don’t see completely the vectorscope, or in other words, I don’t see the vertex of the vectorscope. I’ve done ctrl+scroll but I see the same window biggerbut not less “zoom”. Am I doing something wrong?


1 Like

From the last few comments on the pull request it appears that the devs are still working on that.


Ok, so let’s merge this now and continue improving all this in separate PR.

Guess we’ll have to wait a bit more for the rescaling part.

1 Like

Ah! Ok!
Thank you! Happy to hear that

1 Like

vectorscope was merged to start a broader discussion on the demands. Just waiting doesn’t help. please follow the discussion on github ( And then please give feedback - no feedback means no demands, means no changes :wink:


Extremely happy to se vectorscope coming to darktable! As a colorist with video/broadcast for more that 30 years, this is one of my daily tools that I have really missed. But no hurry, better to get a good implementation later than rushing it.

1 Like

An option to make the area bigger would be nice. for waveform the size is ok but for vector scope it might be nice to be able to resize the area.

the buttons for hide red/green channel seems to be not working?

not for vectorscope because no usecase for these - just there in case there might be usecases for further toggles.

i guess you talk about the buttons. then hide them until we have an use case?

Okay, let’s call it active waiting :slightly_smiling_face:

Some possibility to see the whole thing is definitely needed.

For linux users you can use the packages for the master branch to try them out.


I’ve done some test and it works very well for me!
Correcting the possibility of seeing the boundaries, the only improvement that I have detect is including the I and Q axis.
I will do a video showing how it can be used. It’s my way to give something to this community :+1:


In the color picker section, if you check the “restrict histogram to selection”, it doesn’t work in the vectorscope mode.
Maybe is not easy to do because it would be only one point in there. But in any case, here is my question/request

Thats not specific for vectorscope. See