Very high contrast of blues in RAW rendering

I’m playing around with DarkTable and I’ve been running into some issues with the default render of RAWs and blown out blues in high brightness.

For example, this is the rendering of a RAW file in DarkTable:


And this is the original image, as rendered by the manufacturers’ software:

Normally I’d be okay with some differences as it gives a different feel to the images, but this is a super distracting level of blue in all of the photos that are shot in bright light and I cannot seem to find a way to remove it in post without causing a lot of changes to the image.

I am wondering if there is a suggested way of approaching handling this to tone down the intensity to something closer to the desired image? (manufacturer) as all images with this blue are blown out like crazy

When you have blown highlights, turn on highlight reconstruction module and compare the different methods. Reconstruct in Lch is a pretty good default. Guided Laplacians can also yield good results with tweaking, but is slow and complex.

You could also use the ‘reconstruct’ tab in filmic. If using filmic, make sure you have set the white and black relative sliders correctly in ‘look’ tab (clicking the auto buttons are a good place to start), then reduce the threshold in ‘reconstruct’ tab - 0EV is a good place to start.

1 Like

Thanks I’ll try that out! :slight_smile:

Hi @nnesbitt, and welcome!

Also: you will find useful information using the forum’s search utility.
Try these search criteria:

darktable blown highlights

Then same search on You Tube.

What operating system are you on?

Have fun!
Claes in Lund, Sweden

Hi N!
Are you using filmic? If so, I’d suggest giving the different preserve chrominance settings (on the last tab) a try - I’ve found it useful with this kind of effect.
If you’re using filmic in V5 (or earlier) mode I wouldn’t set the above to “no” as it can have undesirable effects. In V6 it’s fine though.


I had a similar issue with one of my images. The solution was simple for me. To correct the artifacts which were associated with the clouds go to the highlight reconstruction module which is already activated by default. It is currently set to clip highlights for the method. Using the drop-down menu, select reconstruct in LCh. I hope this works for you.

Second that change the norm…in V6 you get a big bump in blue skies

Tone eq is great …blend in the blue channel…then pull up or down from the right most node of the curve…be sure to set the mask to cover the range and then further use opacity if needed…it can jump a bit too blue or yellow but it is great for clouds too blue and skys not blue enough…

1 Like

Thank you so much! Setting it to “NO” reduced the burn considerably, it’s still different but not quite as bad :slight_smile: I will try out some of the other suggestions to see if I can get it a little more consistent!

For the life of me I don’t understand how I can just adjust the blue channel in the tone equalizer module. I skimmed the user guide for the module and that didn’t enlighten me. Could you please advice how this can be done. Thanks.

Glad if it helped! If you want you could post an image with the problematic blue bits so we could have a go at it… but that may not be practical of course.
I tend to leave filmic on the default settings until something isn’t quite right, then I often switch to one of the other settings.
Another suggestion that you could look at is pulling back the highlight saturation in ‘color balance rgb’, then compensating that by increasing the shadow and midtone saturation. This tends to smooth out colored highlights a bit. This is actually how the default ‘increase colorfulness’ presets are set, as it usually works well.

I think what you do is enable drawn mask by clinking the pen icon at the base of the module, then change the ‘blend mode’ to ‘rgb blue channel’. You don’t actually draw a mask though! I may well be wrong though, as I’ve never done this before… thanks Todd.

Following your suggestion I selected the uniformly mask and then I could select the blend option for either the red, green or blue channel. I may find some use for this option one day. It is not something I had considered before. Thanks for the tip. I probably have done similar with the curves RGB module before.

That is it…try it on a sky you will see…also can help with highlights if you want to bring them to white you can use the individual channels to make small changes to balance then and make them white…and you don’t dim the image overall doing so…