Video Editor Won't Recognize PNG codec inside MOV or MP4 video container Rendered By Natron

For some reason, I have two video editors. Both of them don’t recognize any .mp4 or .mov files that have been rendered from Natron. Is there a solution to this problem?

What did you export (as in codec)? What kind of editors are you using? Could you give me the output of the following command (if not on Windows): ffmpeg -i FILE_YOU_CANT_READ.something.

I use the PNG codec for the alpha channel support. I am on Windows, so what do you mean by giving you the output of the following command?

Try using ProRes (in a mov), supports alpha. PNG in MP4/MOV may not be supported by all applications (NLE’s).

Very few software support reading PNG codec within MOV or MP4.

Apple ProRes may not be recognized by Windows either, it depends on the software used to read it!

If you have software that can make use of an alpha channel (for compositing, probably), then it probably accepts image sequences as well, and you should prefer that.

See also: Video Codecs and Image Sequences with Alpha Channels

@TrueFacts can you please tell us what video editor you are trying to use? You should be a bit more specific when asking for help or support.

I edited the title of this post to be more specific, but you should also name your video editor.

I tested it with Davinci Resolve and Blender Video Editor. Both of the editors wouldn’t load it. Also, I’m sure both of the video editors recognize the PNG codec. I’ve tried Blender for VFX once and used the PNG codec. The video rendered worked on both video editors.

I’ve never even heard of using PNG codec within an MOV or MP4 container so hey, today I learn.

Regardless, here’s my obligatory spiel about PNG being a bad format for VFX interchange and media work in general. For more information see this thread on Stack Exchange and this Twitter post. I highly recommend using frame sequences over compressed video formats, they offer many workflow advantages.

I just exported a test clip in MOV/PNG and I can read the file just fine in Resolve. (196.9 KB)

I’ve found out that the only renders that don’t get recognized are the ones using keyframes. If I render a completely still rectangle, the video editors would recognize them. Is there a solution to this problem?

Are you able to provide a project file where this happens (just do something basic without requiring external media files)?.