What does it mater with export in gimp from darktable?

Hello, I use darktable 4.4.2 for windows for editing my pictures. i have installed script manager for export my picture in gimp version 2.10.34 when I click sur export, several windows are opened and closed but not gimp. Why does it matter?
lua script export 1

Darktable cannot just send its internal format to another program, the other program wouldn’t know what to do with that bunch of bytes. So you need to export the image in a format that GIMP can understand.

That’s what the top dialog you show is for: it lets you decide how you want to transfer the image into GIMP. Dt will then save the image, and should start GIMP with instructions to open that same image.

Btw, don’t use the “Taille en pouce”, it’s only useful for impression to an exact size. Best set the size in pixels and use “0×0” (which means “send the full size”).
For the file format, I’d use 16-bit png (or tiff), I know GIMP can read that. PNG can use lossless compression if needed (contrary to jpeg, which always uses lossy compression, if any). For this use, I don’t think compression is very useful (it can be slow…)

1 Like

Thanks for your answer, I try to change the types options

I try all the options whith png and tiff but it doesn’t work.

Salut @Fly!

darktable 4.4.2 for windows

In order to try to find an answer:
a) from where did you obtain darktable?
b) how did you install it?
c) how do you start darktable?

— and —
the same questions for The Gimp :slight_smile:

Claes à Lund, La Suède

1 Like

Thanks for your answer.
Darktable is from darktable.org
Installation with download files darktable-4.4.2-win64.exe
launch file “C:\Program Files\darktable\bin\darktable.exe” with basics options
Gimp is from GIMP - Downloads
Intallation whith download files gimpt-2.10.34 setup-2.exe
launch file “C:\Program Files\GIMP 2\bin\gimp-2.10.exe” with basics options

The most likely issue is that the script can’t find the gimp executable. In script_manager go to tools, then start executable_manager. Use the drop down menu to select gimp, then use the file selector below the drop down to locate the gimp executable.

1 Like

I’ve tryed to find the path in the two specified files without any success

I tried to install script_manager on windows by following the procedure you mentioned in your attached readme files. But I must be doing it wrong because I can’t install it on windows. I’m not very good at computers

copy script_manager.lua to c:\Isers\AppData\Local\darktable\luarc
What does it mean you copy the file and you rename it without extension?
go to the configuration tab where is it ? dartable options lua ?

Since darktable 3.8, darktable will install the lua-scripts using the included lua-scripts installer provided you already have git installed and in your path.

To check for git, open a command prompt and type in git --version, then hit enter. If git is installed and in your path, then you should see something like git version 2.34.0.windows.3. If you don’t get a response then go to https://gitforwindows.org and download the installer. Run the installer and accept the defaults. Once git is installed, start darktable. In the bottom left you should see the lua-scripts installer. Click the execute button and the scripts will be installed and script_manager started.

1 Like

Thank you very much. I followed the steps, now in the darktable preferences window I have new options that appear see screenshot

And what happens if you click on
the folder icon at far right , having the
informative text executable for external editor 1?

If I click on the icon on the right I can fill in the path of the executable file. I tried to put the one of gimp. I restarted darktable and retry to do an export in gimp but it still doesn’t work

I now have a new menu in the darkroom, I can edit my jpeg photos in gimp (however I do not know how to return to darktable once it is done)
I still can’t export my raw type CR2 or CR3 to gimp, I get a file type not allowed error message

Gimp won’t edit raw files. Send gimp a tiff or similar.

It’s possible
Darktable et Gimp, le lien possible ? - YouTube

4 months earlier it was possible. I had tried to do this by following the instructions in the attached video and it worked very well whether it was export and re-import of the modified file in gimp.

It was possible using gimp.lua

I don’t use it much but it used to work… I feel like with Gimp it was taken care of. I used to use the edit copy option if I used it. I also had added ON1 and Affinity and it worked fine there as well. I think I forgot to save it in affinity in the last round trip so I may have left the macro in a corrupt state…if it uses a cache and I knew where it was I would try to clear it. Normally closing the external editor is the trigger to return to DT if I recall…maybe this is wrong …In any case I am now getting that same error for all three programs…not just GIMP so I think something might have changed…

1 Like

I can confirm, I see the same behavior; Windows 11; latest weekly from Bill Ferguson. Gimp does not open with the export , and gives a “file type not allowed” error with external editor.

1 Like

Could you please list the steps you performed so that I can try and reproduce the problem?