When Will RT Run on Mac OS 10.15.2 Catalina?

There are many older post about RT 5.7 not running on Catalina. No updates have been provided.
There is a closed issue on GitHub " macOS Catalina Crash — Incompatible Library #5385"
macOS Catalina Crash — Incompatible Library #5385

On the RT download page there is a link to a message:

macOS Build Issues

23 Sep 2019 (Monday) by DrSlony

We are aware that the current macOS build of RawTherapee 5.7 (sha256sum 70f7b7f ) crashes when run on some versions of macOS. We are working on the problem.

If you experience this problem, downgrade to RawTherapee 5.6 until a new 5.7 build is ready.

This message was posted 5 months ago.

So, it appears that there will not be a fix? RT will no longer run under the current Mac OS?

Have you tried this build: https://keybase.pub/kd6kxr/RawTherapee_OSX_10.9_64_5.7-135-g911cc85ff.zip ?

There will be a fix when someone makes one. Sorry if this sounds harsh or rude, but there are maybe two macOS developers working on RT. The code is there for the fixing if you have the skill, and I’m sure many other Mac users would like the fix as well.

I understand there will be no fix forthcoming on the official RT site. I have zero development skills so…

BTW, thanks for the link; I do not feel comfortable installing an app from some random website signed by a guy named: Richard Barber

Why?

I think it’s a perfectly valid sentiment to not trust binaries from unofficial sources. And not everyone knows about how keybase works and/or how Richard Barber/kd6kxr/benitoite are related to RT (from the former I found out about the latter: they are an occasional contributor to RT). Also you might argue that the link coming from paperdigits gives it enough credibility, and I agree, however Lysander is new on the forum, so how should they know. A short comment about this build and why it’s trustworthy seems more reasonable than just “Why?” to me.

Simon,

Thanks for your response. I was wishing to try RT based on the recommendations of some folks over at DP Review. I am not a developer and have zero interest in learning about binaries, compiling etc. I understand that many folks on this forum “eat and breath” that stuff and I am super grateful that they do and many great OSS projects have come from people willing to share their skills, time and creativity.

There are many great software products in the market. However, I stopped paying Adobe their never end fees to use their products. I have tried many commercial and OSS programs and will continue to do so.

As you noted, I have no clue who Richard Barber is, nor who the poster Mica is. I was merely trying to find out if there was any information from the RT community if it will ever work with macOS Catalina. There is a message on the official RT site, posted 5 months ago, that the problem was known and it implied a solution was forthcoming. I also realize there is no monetary incentive to do so and the RT project is based on the passion and creativity of those who work on it. I was not complaining or demanding anything. Just trying to learn about the program, but unfortunately I will not be able to do so anytime soon…

I did a little bit of reading and as I understand the following that should have been fixed for 5.7: https://github.com/Beep6581/RawTherapee/issues/5385#issuecomment-513757972 However you are saying it hasn’t so maybe they didn’t actually get around to do the notarization with apple for 5.7. In the future it looks like there’s a push to add a mac CI, see https://github.com/Beep6581/RawTherapee/issues/5550 for progress.

1 Like

I did try one of the dev builds referenced and it still crashes on launch.
Guess I will wait until 5.8 to see it works.

Thanks.

V5.6 crashes and the v5.5 too !

Yes, no version works on Catalina 10.2.5.

Compilation Issues

The issue is being worked on by a brain trust of volunteers. I haven’t had more than an hour or two at a time three or four times a week to contribute, recently, to packaging RT from scratch. There is a plethora of 3rd-party dependent libraries. Several of the dependencies are transitioning from autotools to meson. These libraries are compiled as a chain of versioned dependencies prior to RT.

Notarization:

I haven’t had any problems notarizing RT with my Apple Dev Key. I added the script to handle notarization during the Catalina beta.

Alternatives?

Compilation

Some macOS RT users depend on libraries provided by homebrew or macports to simplify compiling on their own (or automatically) with various degrees of success, which also allows them to compile some parts using native CPU optimizations. Native builds run faster than generic or official builds most people use. Instructions are here.

Docker

Docker users on macOS can utilize the kd6kxr/rawtherapee-dev container to run a recent RT development series build.

In re: Title of Thread

With regard to your original question, here are some hard statistics:

  • Number of people getting paid to make generic macOS builds

    • 0.0
  • Number of people who have donated via PayPal to offset the many many hours spent during each development series of RT to package for macOS:

    • 0.0
  • Amount of time I get paid to think about the issue, per week:

    • 0.0
  • Number of dynamically-loaded 3rd party dependent libraries used by RT on macOS:

    • 46
  • Number of macOS users needed to test new builds when they are ready:

    • IDK, a couple dozen. For 5.7 there were a few testers who successfully ran the build, and a few who obtained various errors. The errors are partially due to Catalina which only went public around the same time as 5.7; packaged under macOS 10.15ß5, compatibility was and is still under development (see above stats).

:barber:

3 Likes

V5.6 crashes and the v5.5 too !

@cezanna More details and crash reports, if you please.
Edit I just found your threads.
RawTherapee freeze on catalina 10.15.2
RT v5.6 and 5.5 crash on catlalina 15.2

Hi Hiram,

First I want to thank you and your fellow volunteers on this project.

If I did not make it clear, I wanted to try this package to see if I liked it for my work. I was not complaining since I know this is a free, volunteer supported project. I am sorry if my question gave you that impression. I was merely inquiring about the September 23 message that stated “We are working on the problem.”

If RT, one day, works on MacOS then I will try it. There are other options for me to try in the meanwhile.

Thanks again!

1 Like

No prob, I use RT a lot. You’re not as frustrated about it as me: I started compiling RT in my kitchen a few years back to see if I could iron out some errors. The latest crop of errors coincided with a huge increase in pro workload on my stack.

HIRAM,

One feature of RT I really wanted to test is the Negative Conversion tool. The only other really good tool is a Lightroom Plugin called Negative Lab Pro which costs $100 by itself plus the Adobe tax.
Since I do not use LR/PS that tool is not an option.

Can’t comment on mac performance issues, but I can attest that RT is pretty solid on Windows 10. You could give wine https://www.winehq.org/ and the windows version of Rawtherapee a try.

I tried the latest version of RT on keybase and it crashes apparently for the same reason

Dyld Error Message:
Library not loaded: /usr/lib/libexpat.1.dylib
Referenced from: /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
Reason: Incompatible library version: ImageIO requires version 7.0.0 or later, but libexpat.1.dylib provides version 1.0.0

This sounds strange. The released RT 5.7 runs on my Catalina 10.15.2, i.e. no dyld errors. It just crashes sometimes when loading previews. Starting it repeatedly until it runs in such cases. Afterwards RT runs reliably.

@Lysander: which specific error do you encounter: quick dyld error or delayed crash at startup?

Were you running RT before upgrading to 10.5.2? I was not.

I gather it has to do with specific libraries.

In any event others have reported the crash on launch error so it not so “strange.”
SEE: Can’t Open 5.7 on a Mac

I did neither run RT before 10.15.2. Luckily the released 5.7 binaries work for me.
I said “strange” because the RawTherapee.app package should contain all required libraries and thus behave alike on each Catalina 10.15.2. There seems to be an issue with packaging, so that the behaviour changes depending on other installed libraries.