why isn't collect images:folders showing all my photos?

Hi darktable gurus,

I’ve been banging my head against this for about a week and could use some help. I’m hoping it’s something obvious.

I’m one of the people with a darktable workflow based around folders, not film rolls, so I use the folders option in collect Images to work through my photos.

For about a week now, folders has been displaying only a small fraction of my photos. Whole folders are missing, and the folders that do display contain only some of their photos. Yet, if I search by tag or hunt through for the appropriate film roll, I can still find all of the missing photos. They’re all still in the darktable database, just not displaying in the folders view. It seems to be only the last few film rolls from 2020 that are showing up in my 2020 folder.

I can’t figure out what I’ve done to cause this. Have I accidentally pressed some quick key? I’ve tried a reset parameters in collect images and in recently used collections. The lighttable view is set to “all”. I’ve gone into settings and turned off “enable timeline” in case the new timeline feature was causing this. I’ve been through the collect images part of the darktable manual but don’t see anything relevant to this.

Now I’m stumped and wondering if I have to delete and rebuild my darktable database, but it’s about 150,000 images so I don’t want to waste that time if I don’t have to.

Any ideas? Thanks for your time.

Jon

The screenshots below show my folders view in darktable, and the relevant folders on my computer (all of which are in daraktable but most are not displaying in the folders option).


Please tell us specifically which version of darktable and which OS version. It seems you’re not using the latest version of dark table based on your screenshot.

Darktable 3.0.0 on MacOS 10.14.6.

I’ll check now for a later version of darktable.

(3.0.0 is still the latest release for MacOS at https://www.darktable.org/install/#macos)

Try downloading it from https://github.com/darktable-org/darktable/releases/download/release-3.0.1/darktable-3.0.1.2.dmg

2 Likes

Thanks! That’s a handy tip. I’ve updated to 3.0.1.2.

That’s not fixed my folders problem though. I can find photos with film roll, and tags, and time, that are not showing up in folders.

Can you start dark able from the terminal, darktable -d all and post any output?

Thanks @paperdigits I’ve not figured out how to install/activate the darktable in command line on a Mac. When I install it from the dmg, it runs as a regular Mac app but Terminal doesn’t recognise the command “darktable”.

I haven’t yet found instructions on how to get darktable working from the Mac Terminal. If a Mac darktable user can give me a prod in the right direction, that would be great!

What OS version you have? Has there been a recent update?
Since you’re working on stable version - has the setup worked previously? I mean - thins were working with 3.0.0 but changed in recent weeks?

@ johnny-bit I’m still on MacOS 10.14.6. I’ve so far stayed away from Catalina (10.15) as I’ve got some old 32-bit apps that I occasionally use.

I’ve been using darktable since 2017 and haven’t had any problems with folders until recently, several weeks after I’d shifted to darktable 3.0. It started when I made a new library for all of my photos for 2016–now. With pre-3.0, I’d had a library for each year because otherwise darktable got too slow. That was always a hassle so with 3.0 I decided to make a library for the last five years. Soon after that, folders started misbehaving, but not until after I’d imported a few sessions of new photos.

I’m wondering if I’m going to have to just rebuild that library again.

Damn… I’d love to get debugging output for us to figure out what’s wrong…

can you try oppening up terminal and using full path do darktable, eg:
/Applications/darktable.app/Contents/MacOS/darktable -d all
?

we’ll see what the problem might be.

The screenshot shows a folder with 389 pictures. The scrollbar on the right of the lt seems to indicate that a very small portion (9 exactly) of the pictures are displayed. But there is nothing striking, the images are there and I suppose that if you scroll you’ll see of of them. So your screenshot just shows nothing wrong to me.

I also don’t really see any problems on your capture screen, except that your D800 folder doesn’t appear on darktable (probably just not imported) but “New downloads” folder on the left show 389 images and on top of lighttable view, I see 0 of 389 images. Of course, you have 9 shown but that just because you have 3 per line and your screen let 3 lines possible to shown. But I also see a scrollbar on the right, so scrolling will show you other images. Or did we miss something?

Said that, @Pascal_Obry: this discussion show that links on install page of darktable.org have not been updated. They are still on 3.0.0. I don’t know who update that page until now.

1 Like

Thanks for the tip on how to get darktable running from Terminal. Good to know! That works a treat. I’ve attached the Terminal code below.

@Pascal_Obry and @Nilvus the issue is that my 2020 folder in darktable folders should be displaying the same folders as in my Finder screenshot. My folders 202001, 202002, and 202003 are missing from the folders view, and New downloads is showing 389 photos but contains over 8,000 photos. And, oddly, all of those other photos are still in darktable if I look for them by time, film roll, or tag.

Thanks everyone for your persistence with this.

darktable launch.txt (452.4 KB)

Do you have the recursive folder import option checked?

Yes, “recursive directory traversal when importing filmrolls” is checked. I’ve not touched that.

I’ve just created a PR for updating dtorg install page.

2 Likes

BTW: is anyone checking redmine? there are new issues till poping there. If you want I can browse as much as possible, try to replicate issues and see if there’s anything more needed so redmine could be effectively closed.

2 Likes

No, Redmine is dead for me now and I certainly don’t have time to look there.

1 Like

I’m quite surprised Redmine is not already on read-only mode. It’s easier to have one place to follow darktable development and Github is the main place. That was discussed few weeks ago. Maybe closing Redmine or put it read-only and advertise people to go on Github would be better.

2 Likes