Why Rawtherapee crash when I save the image?


#1

someone knows why this happen ?
every time after the editing when I try to save a pic from raw to jpeg, the program crash …
please help me


(Ingo Weyrich) #2

Did you see this link at top of ‘Software/RawTherapee’ ?


(Mica) #3

What is your operating system? What version of RawTherapee?

Generally, you should update to latest version.


(TomD) #4

I am still having this problem, frequently. Usually, I can save one. The next save exits, very uncerimoniously, not even saving the pp3 file.

I’ve played around with opening the files on a different drive (networked storage drive), deleting my temp files, and some other stuff.

Windows 7, RT 5.3


#5

Here is the updated link to the article in RawPedia.


(TomD) #6

I hope this helps, in some way. I have a CR2 image open, did some edits (trying to learn wavelets, so just playing around). I had saved once, then after other editing, try to save out a JPG, and it crashes. (Launched with gdb, it is apparently frozen. I’m new to gdb, so bear with me.)

This doesn’t seem to be specific to any certain file type, or location of library and/or export location. No matter what I’ve done, I can sometimes export a few times, then once it starts crashing, I can restart, save one file, then the second will typically crash. I’ve come to manually save the PP3 before trying to write to JPG, so I can just load the edits back up. (Not at all efficient, but saves the trouble of losing the edits.)


[Thread 5244.0x1e4c exited with code 0]
[Thread 5244.0x704 exited with code 0]
[Thread 5244.0x2828 exited with code 0]
[New Thread 5244.0x44bc]
[New Thread 5244.0x2480]
[New Thread 5244.0x39b8]
[Thread 5244.0x44bc exited with code 0]
[Thread 5244.0x2480 exited with code 0]
warning: HEAP[rawtherapee-debug.exe]:
warning: HEAP: Free Heap block 2d347310 modified at 2d347758 after it was freed

Program received signal SIGTRAP, Trace/breakpoint trap.
0x0000000077719e52 in ntdll!EtwpCreateEtwThread () from C:\Windows\SYSTEM32\ntdll.dll
(gdb)


(Ingo Weyrich) #7

iirc there are still problems when saving the output to the same folder you currently have opened in rt. Can you reproduce the crashes when you save to a different folder?


(TomD) #8

Yes, I never save to the location where the raw file is stored. I believe I have tried moving just the export location to an external drive, just the source location, and both to the external. The results are consistently inconsistent. As I said before, sometimes I can edit several files, no problem. Other times, only the first saves without crashing. The only thing that is consistent seems to be when the problem occurs, it does let me save once. The next crashes. I can restart RT, load the PP3, export to JPG once, no problem. On the next one, crash.

If there is anything I can do that would help diagnose (beyond the gdp text I posted above), don’t hesitate to ask, I’d be happy to help (seems I’m not the only one experiencing this). If what I posted isn’t the relevant debug info, let me know. That stuff is a little out of my wheelhouse. I do some programming, but mostly VB.Net for Autocad.

Thanks to all who have taken the time to post.


(Ingo Weyrich) #9

32bit or 64bit OS? how much ram?


(Morgan Hardwood) #10

FWIW, I experienced many crashes when saving to the same location as is currently opened, but these seem to have stopped since version 5.3. @tdivittis what version are you on?
http://rawpedia.rawtherapee.com/How_to_write_useful_bug_reports


(TomD) #11

64 bit, Win 7, 32GB ram, NVIDIA Quadro M1000M (in case that may matter)

At times I process lidar point clouds of 5-10GB, so I would be pretty shocked if this was some kind of RAM or full hard drive issue. I run Civil 3D frequently with files normally in the 10MB-50MB range, with no real performance issues. (Not ruling them out such issues, just trying to provide more background.)

I’ve been using RT for a couple of years, now. I think I first saw this problem with 5. I did find the 5.3 info, so installed that, but the issue is exactly the same. I’m an amateur/hobbyist, so I’m not using RT constantly. It’s probably rare that I go more than a week without using it at least a little bit. At times I’ll spend the majority of a weekend or evening in it.

A thought just occurred to me…I often have mapped drives that are unavailable (work vs. home network locations). This doesn’t cause me any other problems, but is there a chance RT is tripping on these, somehow? I’ll try making sure I have all the drive maps removed later this evening and do some editing, see what happens. There are times when I don’t have any mapped…maybe those are the times I can save without issue. (Sorry for rambling, been a long day, with more work to do.)


(TomD) #12

They mapped drives apparently were not related. Once I removed all of them, I was able to export 4 JPGs, then back to crashing.