Windows 10 running Darktable not using PC at full capacity

Hi, my laptop has a dedicated GC in addition to the integrated one. I have the following, with GC #1 beeing significantly faster than #0.

3.331822 [opencl_init] kernel loading time: 1.0691
3.333816 [opencl_init] OpenCL successfully initialized.
3.336808 [opencl_init] here are the internal numbers and names of OpenCL devices available to darktable:
3.342791 [opencl_init]          0       'Intel(R) UHD Graphics 620'
3.345784 [opencl_init]          1       'GeForce MX150'
3.347778 [opencl_init] FINALLY: opencl is AVAILABLE on this system.

However, Darktable does only use my Intel GC. I’ve tried to edit C:\Users\MyName\AppData\Local\darktable\darktablerc and force GC #1 with the Following line:

opencl_device_priority=1/1/1/1

as described in the documentation (https://www.darktable.org/usermanual/en/darktable_and_opencl_multiple_devices.html) but it doesn’t work. I’ve also tried with:

opencl_device_priority=!0,*/!0,*/!0,*/!0,*

In addition, the Nvidia setting pannel is set with the Nvidia GPU as the preferred GPU.

Of course, I think that OpenCL is properly installed because other SW (like Capture One Pro for instance) use my Nividia GPU.

I don’t know what to do. Any help ?

maybe the MX150 lacks the opencl image extension

I don’t beleive so, because running darktable-cltest.exe probes everything right, with all kernels beeing loaded sucessfully.

Is it an Optimus GPU? If so, can you try to configure Darktable to run on the dedicated card?

2 Likes

My guess would be this as well.

In the nvidia settings you should be able to force a certain application to use the nvidia gpu.

The MX150 is advertised as an Optimus card (whatever it means). With the Nvidia setting pannel, I had the Nvidia GPU set as default for every application. I’ve now tried Something else (sorry for the french thing): global parameters as “automatic” and darktable forced as Nvidia preferred.


And still …

My issue is perhaps a bit deeper since I realize that Capture One Pro does neither use my Nvidia. I’ve performed a clean install of the drivers, and it appears that OpenCl seems to be installed but I can’t make it work.

My Nvidia OpenCL version is 1.2, while the version of Intel’s is 2.1. Could that be the reason ?

optimus means the card might need to be switched on first. like switching from using the intel GPU to Nvidia.

By setting “Multiple GPUs” in the UI, it seems to use the Nvidia GPU. But just a little bit : never more than 5-7% That beeing said, CPU usage does never go beyond 40% (and integrated GPU never beyond 40% as well) while rendering is however currently computed (like after zooming).

How can I make Darktable use all the resources on my Windows 10 PC ? As it, it does use less than 25% of it and it sluggish, as a consequence.

EDIT : after plugin the AC power, ressource usage grows. So it is perhaps a power management issue, related to the OS. I’ll check that.

I’ve made a short video showing how the CPU and GPUs are used while performing basic actions. I also show parameters.

I’d really like to use DT (and switch to Linux if I’m fine on the mid term) but I have to check before if usage is comfortable on my laptop. As it, DT does only use a part of the processing power, so I cannot evaluate. There are many occasions when “working” is showed on the bottom, but only part of the processors is used.

By contrast, on the same PC with the same settings, Capture One Pro better balances load on CPU/GPU#0/GPU#1, and is much more fluid in useage …