Windows 64 build with integration of lensfun


(Alberto) #21

Ok, rereading now I understand what you mean. Here’s how I would do this with dynamic profiles:

  1. create a rule that applies the following partial profile whenever your camera is found:
[LensProfile]
UseLensfun=true
LFAutoMatch=true
LFCameraMake=MY CAMERA MAKE
LFCameraModel=MY CAMERA MODEL

Notice that LFAutoMatch is still set to true here.

  1. add a rule for your lens that is not picked up automatically by lensfun, overriding LFAutoMatch:
[LensProfile]
LFAutoMatch=false
LFLens=MY LENS
  1. Make sure the rule for the lens comes after that for the camera, so that LFAutoMatch is properly overridden. Then you should be good to go.

rawtherapee doesn't have the lens i'm using in it's list.
#22

If I want lDB located in …/share/lensfun, what exactly I have to write in DLENSFUNDBDIR?


(Peter Lavender) #23

Hey everyone,

Given you’re all talking about the lensfun addtion, I just did my usual git pull and compile and I get the following error:

-- Checking for module 'lensfun>=0.2'
--   
CMake Error at /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:367 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:532 (_pkg_check_modules_internal)
  CMakeLists.txt:279 (pkg_check_modules)


-- Configuring incomplete, errors occurred!
See also "/home/pete/repo-rt/build/CMakeFiles/CMakeOutput.log".
make: *** No rule to make target 'install'.  Stop.
mv: cannot stat 'release': No such file or directory

(Flössie) #24

You have to install the liblensfun-dev package (exact name depends on your distribution).


(Peter Lavender) #25

Whoops, yes, thanks. Just read about it in another thread on the site…

Added it and it’s now compiling.

Thanks.


(Ingo Weyrich) #26

Latest dev segfaults at start of RT (Windows 7).

@plaven If you get a segfault at start of rt, you can git checkout 5b3d60b. That should work.


(Peter Lavender) #27

Is this what you mean?

pete@kanga~/rt $ ./rawtherapee

(rawtherapee:16493): GLib-CRITICAL **: g_file_get_contents: assertion 'filename != NULL' failed
Segmentation fault (core dumped)

(Ingo Weyrich) #28

yes, though I only get a segfault without the GLib-CRITICAL…


(Peter Lavender) #29

I’m just waiting for the build to finish now.

88%…

94%…

100%… man that’s fun to watch… :slight_smile:

@heckflosse, I can confirm that RT starts fine now.


(Ingo Weyrich) #30

I just pushed a fix for the segfault to dev


(Peter Lavender) #31

Hey Ingo,

Just pulled and compiled, after the first start up and a crash, starting the second time it worked fine.

Peter.


(Flössie) #32

What kind of crash was that? Can you try to reproduce?


(Peter Lavender) #33

It’s a crash that occurs every now and then, and I think it’s possibly due to PP3 files in a directory.

pete@kanga~/rt $ ./rawtherapee
*** Error in `./rawtherapee': realloc(): invalid pointer: 0x00007fe23281ad00 ***

There’s a back trace, in the console, not sure it’s what you’d need though.

The problem often though is that a second restart clears the issue and RT starts fine.

I have tried in the past to run it under gdb but it doesn’t fail.


(Flössie) #34

Yes, please! :smiley: Please file a bug over at GitHub, so we can track it in the long run. Thanks!


(Ingo Weyrich) #35

I can’t answer this question. But you have to pull again if you want to use cmake variable LENSFUNDIR


(Peter Lavender) #36

Flossie as requested:


(Alberto) #37

What is .. in this context?


#38

@agriggio @heckflosse

-DLENSFUNDBDIR=share/lensfun permit to locate DB in installdir/share/lensfun

I verified in verbose mode that DB is locally accessed. Hope this time it’s ok.

RawTherapee_dev_5.2-168-gbe2b1ed0_WinVista_64.zip is uploaded at
https://drive.google.com/open?id=0B2q9OrgyDEfPS2FpdDAtMVI1RG8

Please test.


(Ingo Weyrich) #39

I renamed my lensfun database folder, installed your build and tested. Works fine :+1:


(Alberto) #40

@gaaned92 perhaps you could update the rawpedia page about building on windows with the above info, if possible?

Thanks!