write node not writing

Hi all,

apologies if this has been asked.

I am trying to write out a reformatted image and I am told that:

write1 error: could not open [file path]

I have made several test:

changing the output format to-from jpg, tga, png etc
just creating a rectangle and outputting that
uninstall and reinstall

in my command prompt I have been notified of:

Info: init.py script not loaded (this is not an error)
Info: initGui.py script not loaded (this is not an error)

not sure if this is normal or not.

I am running version 2.3.15 on win10.



You have write access to the destination?

Hi rodlie,

I should have.

Not sure why I wouldn’t. How do I check?


I have full permissions on the folder and still no luck. I even tried to render to my desktop.

Can you take a screenshot where we can see the node graph and properties of the write node?

No problem, I have attached the image.

Can you try replacing test_v001.####.jpg by test_v001####.jpg?

Still failed :frowning:

You tried running with admin privileges? I know it’s not a great plan to just go about running apps with admin on Windows but Natron runs into similar problems when I don’t.

Hi Shrinks99,

thank you for the suggestion and still it failed.

I am totally stumped on why this is failing.


I’m not able to replicate on Windows 8.1 or 10, don’t know what to say… It’s not Natron fault. Probably due to Natron not being signed, seems like some system don’t like that… I don’t know, just guessing here, as I can’t replicate the issue in any way.

I’ll keep ploughing on but thank you all for your advice and suggestions.

Did you use the installer or portable zip? If you installed Natron through the installer try downloading the zip and extract somewhere, then launch Natron from the extracted folder and see if you get a different result when writing files.

Thanks again, ill try that.

Try making a folder in your desktop and writing to there, and also change the file name to just test, try not to use any special characters. Also, If you’re trying to write an image, you need to set the frame range (project settings) from 1 to 1. Apart from that i don’t know.