Write1 error: can only write RGBA or RGB components images

Can’t write out .mov file… getting this error every time with exr’s and png
“Write1 error: can only write RGBA or RGB components images”

You are probably trying to write images instead of a video. What is the output filename?

.mov extension

just tried .avi as well… same error
windows 10 Name.#.ext

Remove # from the filename.

If you have # or %INTd in the filename it will be interpetrated as an image sequence.

Interesting… it worked yesterday for a few renders, but now it stopped working again…
My work computer is not connected to the internet…is that it?

So I tried manually switching to .mov,… which added the # to the name,… then I tried going back to making the Write node and typing in .mov,… and it worked… odd.

The write node added # ? It shouldn’t do that, you are using the latest version (2.4.3) ? on what platform (Win/Mac/Lin)?

yep,… using 2.4.3 windows 10
all I’m doing is drag and drop image folder into node graph, just like in nuke, and viewer is connected to it,… then hit tab …and add a write node and type in render.mov and click render


Hi. I work with window 11. Here is my problem: I want to write an image -png, 9000 x 12000 pixels- but some effects are missing on the output png image. Actually, what is missing are the flares, a node from the Natron Community Plugins… It is strange, because on my monitor, everything looks good; it only goes wrong when I try to save it with a write node.


Please provide a screenshot of the nodegraph and the write node properties if possible.