Zoom in keyboard/mouse shortcut changes selection mode

Hi everybody, I’m new to this forum but I’ve been using gimp for some years.

If I select a big area using the Rectangle Select Tool, and then zoom in using Ctrl+Mouse Wheel, the select mode changes to “Subtract from the current selection”, and it stays like that. I’d like to keep using “Replace the current selection” and not have it changed to “Subtract from the current selection”. Is there a way to prevent this behavior?

I didn’t find a way to change this shortcut in Configure Keyboard Shortcuts.

There’s also no shortcut to select again “Replace the current selection” so I have to do it manually (clicking it) every time I zoom in.

Any help would be appreciated.

The Ctrl key indeed switches the Rectangle selection to Subtract mode temporarily, like the Shift does for Add and Shift+Control for Intersect. But releasing the key should reset the tool to Replace mode.

So it looks like something in your system is hiding/capturing the release of the Control key. Any keyboard enhancer or security software running?

Sometimes this is true, but it is not true most of the times, especially if you have zoomed in over the selected area.

I’m running a standard XFCE install. I face this issue on many different Linux distros so I don’t think it is distro/DE dependent. I didn’t install any software to intercept key presses, but there’s the standard keyboard shortcut manager from the DE. IMHO I don’t think it’s related.

Could you try and see if you can reproduce this behavior on your system?

  1. Open/Create a file
  2. Rectangle Select Tool, select an area
  3. With your pointer over that selected area, use Ctrl and the mouse wheel to zoom in enough to fill the screen with your selection.
  4. Subtract mode persists!

I found a workaround. Pressing the ALT key reverts to Replace Mode. It’s not the most elegant way to solve this issue but it’s better than having to click the icon with the mouse.

If only I could disable Ctrl as the shortcut to change to Subtract mode! Can it be done at all?

Can’t reproduce (Kubuntu 22.04, so KDE/plasma desktop)… If you have the problem with different distros/DE maybe it’s your keyboard (because there is no reason that “Alt” could change that setting, so it must be a side effect.

These keystrokes are hard-coded in Gimp. So, hard to change.

Interesting. I will have to test other DEs to see if this is an XFCE issue.