5.1/5.2 extremely long start time on my win10 64 bits


(Rural Hunter) #1

Hi,
I used 4.x version on my win10 for quite some time and it works greatly. When I tried to install both 5.1 and 5.2 windows 64 bits versions, they just don’t start. I can see they are running in background with windows task manager. the RT process utilizes 25% of my cpu constantly but just hangs there forever. I also tried to delete the profiles/cache etc or use the -debug versin but it’s the same. Any idea?

update:
well, I left the computer and the process running and checked after about one hour later, I found RT launched!
I tried to launch RT several times and it’s the same. RT needs about 10 mins to start everytime(Meanwhile I kept my computer idle and only RT running). so it is just the extremely long launch time is the issue.

One note: I can reproduce the problem on another win10 computer. Both computers are Thinkpad: One is T400 and another is x260.


(Mica) #2

Virus scanner hanging it up?


#3

@RuralHunter

Following http://rawpedia.rawtherapee.com/How_to_fix_crashes_on_startup , you should:

  • delete the cache folder
  • rename the option file in order to use a fresh and compatible option file
  • always start in an empty folder

If RT starts then open your image folder. There could be a corrupted image in it that prevents RT to start.
André


(Rural Hunter) #4

I didn’t install any anti-virus soft except windows defender.


(Rural Hunter) #5

As I stated, I already deleted the whole RT folder for my account in AppData/Local. I also tried a clean install by uninstalling and deleting any folder related to RT but the result is the same.


(Morgan Hardwood) #6

@RuralHunter have you tried that?


(Rural Hunter) #7

well, I left the computer and the process running and checked after about one hour later, I found RT launched!
I tried to launch RT several times and it’s the same. RT needs about 10 mins to start everytime(Meanwhile I kept my computer idle and only RT running). so it is just the extremely long launch time is the issue.


(Rural Hunter) #8

Yes, I deleted everything related to RT and just run the shortcut on desktop. After I waited about 10 mins, it started and I can see it’s in the windows PICTURE folder and there is only one image file in it.


(Rural Hunter) #9

It seems it’s the same issue as this: Long time to load Rt on Win 10 64bit


(Morgan Hardwood) #10

Try disabling drive A/floppy drives in BIOS.
Do you have any network drives?


(Rural Hunter) #11

I have onedriver not sure if it’s the problem.
Not sure if it’s the same but my ClutsDirectory is set to ./cult by default: https://github.com/Beep6581/RawTherapee/issues/3077


#12

Can you verify with official 5.2 build that, if option file is deleted, the Clut directory is set to null by default.


(Rural Hunter) #13

Yes, this is the official 5.2 version I downloaded from the official website.


#14

On my installation, ./clut default appears as “aucun” (null in english) in the gui and creates no starting issue. So I don’t think it is the problem.
furthermor there is now a timeout on clut loading with a warning message.

check in the Bios and disable floppy if enabled (It can happen even if you don’t have any floppy installed!)

Perhaps corrupted, delete the entire PICTURE folder content.


(Rural Hunter) #15

Nope. This is obviously not the issue. I removed it and it’s still the same. I can also reproduced this on another Win10 computer.


(Andrea Olivotto) #16

I have the same issue. Clean Windows 10 64 bits installation on an old Intel Q9550 8GB RAM PC, latest rawtherapee 5.2 downloaded from main site.
I haven’t the floppy disk A.
Using process explorer it seems to consume very low CPU time, but memory increases from 37MB to 156MB.
Not much I/O activity, some peaks here and there.
Every execution needs 3:45 minute from launch to windows show.

Settings windows needs a couple o minutes as well to show!

In settings, when I click on a setting requiring the folder dialog (example: start folder), the dialog needs more tha a minute to show.
The same from a click on a thumbnail to edit window.

Everything is delayed and slowed. Unusable.

Hope the developes can solve this issue, I love RT.


(Andrea Olivotto) #17

I tried to disable Windows Defender and to remove the network drives, nothing changed.


(Andrea Olivotto) #18

RT 5.1, same issues.


#19

Do you mean it is DISABLED in the BIOS? because it can be enabled in BIOS and not installed.

I cannot really help you as it runs like a breeze on my W10 (i6700K, 16GB): 3-4 sec to start. Only trying to guess.

@Morgan_Hardwood : perhaps open a bug report in github?


(Morgan Hardwood) #20

Go ahead - I don’t use Windows.