5.9 can not launch external editor

In the latest build Photoshop CS6 will not load as an external from RT. It is not listed in the other applications as well. How can I force RT to recognize the path?

RT is running from the zip file.

Shouldn’t there be something like %1 in the full path to actually give Photoshop a reference to the file it has to load?

In the versions that I’ve been using from @gaaned92, including 5.9-7, the path as shown works fine. However the path is not in quotation marks like it is in the automated release 5.9-56. I am unable to remove them and really don’t know if I should.

The external editor feature received improvements and the existing command may not have been properly converted into the new format. My guess is the backslashes (\) need to be “escaped” by prefixing them with another backslash, e.g. "C:\\Program Files.... It’s possible to edit the name and command by double-clicking the text first. You can also try selecting the entry and using the “Change Executable” button to choose the exe file.

I was able to add the second backslash and that didn’t work.

“Change Executable” enters the path without the double backslash and that doesn’t work.

PS CS6 extended is not showing up on the list of applications.

The option file shows 4 backslashes instead of two in the command line. If I change the option file to show two backslashes, then the command line in RT shows one backslash.

Windows will also internally use forward slashes (/) as path separators. Old versions of command.com wouldn’t accept them, but when used in code they worked and avoided the need to escape backslashes. I just tried it in cmd.exe and it worked. It might be worth trying forward slashes… ?

If the @gaaned92 dev builds work with a single backslash then the automated releases should too. Only since this add on feature has been implemented in 5.9-56 does it not work.

Also I noticed that in 5.9-56 the External editor icon at the bottom of the editor window tries to load an external editor, but stops short after "Highlight Reconstruction with this message


If I click on the down arrow to select the command I placed in preferences, nothing happens, at all.

That’s strange. I can’t seem to reproduce the issue.

This works perfectly fine for me. Downloaded the latest dev build, set the output directory to “Same as input image”, and used the “Change Executable” button. Have you tried removing the external editor entry and re-creating it?

By the way, the thread is about 5.9-rc1, but this is a 5.9-dev topic. Maybe this should be split into a new thread.

@Lawrence37 I downloaded 5.9-57. I tried re-creating the PS path the way you suggested and that didn’t work. I also tried it with Affinity Photo and it woks fine as long as I press the “External editor” icon. If I select Affinity Photo from the drop down list, nothing happens.

Still no luck at all with PS. Does this help?

[External Editor]
Commands=“C:\Program Files (x86)\Photoshop CS6\x64\Photoshop.exe”;

The list is for changing the external editor, so it is expected that the application isn’t launched. Since Affinity Photo opens, there must be something unusual about your Photoshop which cannot be handled by the new external editor feature.

If it can’t be handled by the new external editor feature, then I have a big problem. I’m hoping that this can be fixed since the external editor has always worked perfectly before 5.9-56

I was hoping you might have an idea of what makes your Photoshop different. Anyway, could you supply the following information?

First, let’s determine what the error message is. Run RawTherapee from the command prompt. You can do this by entering the full path of rawtherapee.exe surrounded by double quotes (much like what you have for the Photoshop entry in the external editor command) then hitting enter. After RawTherapee opens, try to send to Photoshop. Switch back to the command prompt. There might be a lot of text, but there should be some error message at or near the end. Tell me what it says.

Next, I want to determine how to fall back to the old external editor code in case of an error. In the earlier version of RawTherapee, did you have Photoshop selected, or was it a custom command? (I’m guessing it was a custom command based on your earlier comments, but I want to make sure.) If it was selected, does it work if you use a custom command instead? The command is the full path of Photoshop (without the quotes, I think).

Using a command prompt. .

  1. I ran the RawTherapee command and it did not run with double quotes. I changed the command to a single quote and it opened.

Same problem occurred where Photoshop does not open from the external editor icon.

  1. I then ran the latest dev executible and once again I was able to open rawtherapee. This time when I clicked on the external editor icon, Photoshop loaded quickly. However, there was no image file in the Photoshop editor.

There were no error messages in command prompt.

In the old version, selecting “Adobe Photoshop Installation directory” does not work. Using command line does.

For the time being, until a solution can be found, I will export in the Queue as a tif and open Photoshop for further edits. It’s not my preferred way to work, but at least I can get the work done. Just a few extra steps.

I don’t know if this is relevant, but: I have a similar behaviour with this version (5.9-57, Win 10) not opening the tif file when using Irfanview as external editor (although RT puts a tif image in the chosen directory). It only works if I choose the partition root directory of the partition where the input image is. Even more strange: with GIMP it works with any chosen directory even with “OS temp dir” and “Same as input image”…

Bingo! That’s exactly what is happening to me. After clicking on the external editor link in RT, the tif file goes to the folder where the RAW file is located, but Photoshop does not open.

Btw; I tried opening RT with a command prompt as @Lawrence37 suggested and after clicking on the external editor Photoshop loaded, but without the tif file showing in the editor. I tried it a second time after closing RT and nothing happened when I clicked on the external editor icon. However, the tif was put into the folder.

@stuntflyer I cannot reproduce your problem using Photoshop 2020. The external program opens fine and opens the image too. That’s probably why a bug wasn’t found before…



Additional data points, if it’s worth anything…

Disclaimer: I don’t currently use RT since I’m a CR3 shooter, but I have the 5.9 stable and 5.9-57-g21afbaf90 dev releases installed on Windows 11 Home. I also use Affinity Photo (not Photoshop) but I ran into a different external editor issue with the dev release: Nothing got launched at all.

I configured these external editors:

  • Affinity Photo direct* - "C:\\Program Files\\WindowsApps\\SerifEuropeLtd.AffinityPhoto2_2.0.3.1688_x64__3cqzy0nppv2rt\\App\\Photo.exe"

  • Affinity Photo redirected* - "C:\\users\\len\\AppData\\Local\\Microsoft\\WindowsApps\\AffinityPhoto2.exe"

  • Affinity Photo launch utility* - "C:\\utils\\aflaunch.exe"

  • GIMP - "C:\\Program Files\\GIMP 2\\bin\\gimp-2.10.exe"

  • XnView MP - "C:\\Program Files\\XnViewMP\\xnviewmp.exe"

  • FastStone Image Viewer - "C:\\Program Files (x86)\\FastStone Image Viewer\\FSViewer.exe"

* Affinity Photo is currently an (MSIX) MS Store app, hence the non-standard exe path (‘direct’). The other two versions are alternate launchers provided by Serif for those having issues with the sandboxed Store app environment. Serif is going to release conventional MSI installers as well, Real Soon Now. My point in trying them (and the other apps as well) was to rule out anything resulting from the Store app context.

At any rate, none of these editors even get invoked as far as I can tell. I kept Task Manager open when I sent the image to them and they never visibly launched, nor did even a glimmer of them appear in Task Manager. The command lines above were picked via the GUI (not typed in) and copied here from the options file. So any quoting, etc., was done automatically.

Also, another small UI thing – In the Change Executable file selector dialog, with image selected it still doesn’t show *.exes. You have to select All Files.

This is the full RT dev info for this version:

Version: 5.9-57-g21afbaf90
Branch: dev
Commit: 21afbaf90
Commit date: 2023-01-06
Compiler: cc 12.2.0
Processor: generic x86
System: Windows
Bit depth: 64 bits
Gtkmm: V3.24.7
Lensfun: V0.3.3.0
Build type: release
Build flags:  -std=c++11 -ffp-contract=off -mtune=generic -Werror=unused-label -Werror=delete-incomplete -fno-math-errno -Wno-attributes -Wall -Wuninitialized -Wcast-qual -Wno-deprecated-declarations -Wno-unused-result -Wunused-macros -fopenmp -Werror=unknown-pragmas -O3 -DNDEBUG -ftree-vectorize
Link flags:  -mtune=generic
OpenMP support: ON
MMAP support: ON
Build OS: MINGW64_NT-10.0-20348 3.4.3-dirty.x86_64 x86_64
Build date: Fri, 06 Jan 2023 05:55:41 +0000 UTC
Build epoch: 1672984541
Build UUID: b462bf75-2ef1-4a88-8ebc-d166986ee680

@stuntflyer Does the “Cannot start editor” popup show when you try to send the image to Photoshop? If it doesn’t, then the issue is harder to diagnose because RawTherapee can’t detect any error. Also, it sounds like Photoshop opens sometimes and other times it does not? Is it random or does it depend on the RawTherapee settings/version, the image name, etc.?

@lphilpot Do those apps work with the stable release?

Does the “Cannot start editor” popup show when you try to send the image to Photoshop?

Yes, it pops up.

Also, it sounds like Photoshop opens sometimes and other times it does not?

I was only able to get Photoshop to start up once and that was from the executable version. After the one time, never again. Keep getting “Cannot start editor”. Also, the drop down arrow selection doesn’t work at all. So, I click on the external editor icon only.