A bit of a moan about not being able to install RT 5.9 in Mint 21

This is a moan by a subscriber who has a long and distinguished track record of being able to perform the rather difficult task to having both feet in his mouth while in a state of having a limited supply of facts, even fewer of which are correct.

While researching my annual task of trying to get GIMP to invoke either of the two main FOSS raw image processors - 2024 attempt - it became clear to me that there is no package for rt 5.9 that can be installed in Mint 21.2, based on Ubuntu 22.04. (I am excluding AppImages and Flatpaks - I personally don’t want them).

Attempts to install all packages for 5.9 that other most helpful contributors to this community have pointed me to all fail with an unsatisfied dependency of some sort, which cannot be satisfied on an Ubuntu 22.04 base - I would need to be using 23.04 at least.

So here we have the embarrassing situation where the current version of what is arguably one of the best raw image processors available in any operating environment, cannot be installed in what distrowatch statistics show to be arguably the most popular Linux distribution. One has to revert to the 4 year old version 5.8 as the newest version of rt available via apt. But it’s even worse than that: Mint is unlikely to move to an Ubuntu 23.04 basis this year, at least. So by the time the current dependency requirements can be met, the newest version of rt that will be installable in Mint will be 5 - or possibly more - years old. And that is in an environment where dt will have made 10 or so new versions available, all running under Mint 21.

Because of my well established ignorance I have no idea how much work is involved in backporting the modules which currently cause an issue (e.g. libatkmm-1.6-1v5) from Ubuntu 23.04 to Ubuntu 22.04, but it doesn’t seem to me to be a hugely demanding project - in terms of complexity, regression risk, collateral damage or man-days of effort. Surely something could be done for the Mint user?

(And yes, I have been advised by those who clearly have sound understanding that it is my choice to use a conservative Linux distro, so I have no reason to moan. But that’s just logic - I don’t need a reason to moan…)

Arguably.

The DistroWatch Page Hit Ranking statistics are a light-hearted way of measuring interest in Linux distributions and other free operating systems among the visitors of this website. They correlate neither to usage nor to quality and should not be used to measure the market share of distributions.

(DistroWatch.com: Put the fun back into computing. Use Linux, BSD.)

Maybe it would be easier to try to build RT from the source code? Though I do not use Ubuntu LTS and derivatives and have no idea if RT 5.9 can be built on that oldish Linux version.

2 Likes

Surely the dependencies will still be there - which cannot be satisfied at Mint 21’s Ubuntu level ? And that ‘oldish’ Linux version was mainstream when 5.9 was released - almost 2 years ago.

A bit more than a year ago:

RawTherapee version 5.9 released on November 27, 2022
(RawTherapee - RawTherapee v5.9)

It is Ubuntu 22.04, on which Mint 21 is based, that is almost 2 years old. And it will be supported until April 2027.

Do you expect developers not to add dependencies that are not present in LTS Linux versions? Yet, at the same time, support the latest file formats and camera hardware? So, for example, projects should not have added any new library between April 2018 and March 2023, the release and end-of-life dates of Ubuntu 18.04? Or between April 2022 and 2027, in case of Ubuntu 22.04 and Mint 21?

You’re correct; I had fixed in my head that it was Feb. 2022 - conflating the release month of 5.8 with the release year of 5.9

No, I really, really don’t.

I do expect them to continue to do what they excel at: developing new functionality and exploiting new capabilities. I just don’t want to be excluded from enjoying these developments because I have chosen a distribution which cannot really be described as ‘oldish’, surely? Mint 21.2 was released 6 months ago and 21.3 is imminent. However I am a little surprised that the Mint team are accepting of the fact of users not being able to install a ‘conventional’ packaged version of rt 5.9, either through synaptic/apt or via a .deb package

21.x is still 21. There are no big changes to the foundations, which come from Ubuntu 22.04 (and are, in turn, based on Debian Testing).

Aren’t there RT appimages somewhere? Or else bit the bullet on flatpaks, they’re well supported in mint.

Yes there are - but, as I said, I would like to avoid them because they introduce problems which are beyond my skill level to resolve when trying to invoke either RT or dt from GIMP to handle raw images.

For running ‘standalone’ I do use the AppImage of 5.9 - I have no other choice if I wish to avoid flatpaks.

For what its worth, I built the current dev branch inside of Windows WSL2 running Ubuntu 22.04 LTS and it built and runs just fine using the build script in the RT wiki (though it runs slightly slower than running it ‘native’ inside of Windows) - so I would think it would build fine on Mint 21

4 Likes

RawTherapee is compatible with Ubuntu 22.04, so its availability depends on the distro’s policy and package maintainers’ interest in the program. I don’t know about Mint, but Ubuntu 22.04 is an LTS release and they generally don’t upgrade packages beyond bug fixes. That means you have to rely on third parties to get the latest version of RawTherapee. As you have discovered, it either doesn’t exist or is hard to find. A good reason to be grateful for all the package maintainers who do distribute RawTherapee to various platforms.

I have no experience with the GIMP plug-in, but the RawPedia page for it says only three things are required:

  • RawTherapee 5.3 or newer
  • GIMP 2.9.6 or newer
  • RawTherapee in your PATH environment variable

You have GIMP and technically RawTherapee too (as an AppImage). I suspect GIMP just invokes the rawtherapee command. If that’s the case, simply renaming the AppImage to “rawtherapee” and adding the directory it’s in to your PATH variable will allow you to use RawTherapee from GIMP. Of course, you can get fancy and go about adding the RawTherapee AppImage to PATH by other means, like moving it to a directory that’s already in PATH or using a symlink (named “rawtherapee”) to the AppImage instead of renaming it.

If that doesn’t work, your best option is to compile RawTherapee yourself. It’s easy if you use the automatic way. The hardest part is making sure you have all the dependencies installed. Fortunately, the AppImage build system compiles on Ubuntu (20.04) and has the latest list of packages needed for Ubuntu-based distros. Note that you still need to install it to a directory that’s in PATH or add the directory to PATH.

1 Like

Thank you for the update. That is most encouraging; I will try it for myself in a ‘native’ Linux environment (but it’s pushing the boundaries of my knowledge and understanding).

The point I was ineptly trying to make is that I am surprised/disappointed that the Mint team haven’t given the necessary attention to enabling RT 5.9 to be installed from the binaries that others have made available. Yes, I understand there is only so much the Mint team can do with the resources available, but I would opine that RT is a rather significant package which should perhaps have a somewhat higher position in the queue for those resources.

Thank you for the additional guidance, too. That now gives me more options to try.

this your rant should probably go at your distro’s forum … you have at least several options

  1. build a RT for yourself - it’s easier task than you think - and eventually start maintaining a RT for your distro - this is how foss community works

  2. change your distro - for example SUSE has it openSUSE Software

I use SUSE almost 20 years and I just love it …

cheers, ~dan

for me it was:

open a terminal window and in there:

sudo apt-get update
sudo apt install git build-essential cmake curl pkg-config libgtk-3-dev libgtkmm-3.0-dev liblensfun-dev librsvg2-dev liblcms2-dev libfftw3-dev libiptcdata0-dev libtiff5-dev libcanberra-gtk3-dev libexiv2-dev
cd ~
wget https://raw.githubusercontent.com/Beep6581/RawTherapee/dev/tools/build-rawtherapee -O build-rawtherapee
chmod +x build-rawtherapee
./build-rawtherapee

And thats it

1 Like

That’s very close to what I did a few hours ago, using the ‘automatic’ method as described in RawPedia, creating RT 5.9-474-something in ~/programs/rawtherapee/ from which location it runs just fine. The compilation was remarkably straightforward with not a single error or warning message. Far simpler than compiling darktable. But there the story comes to an abrupt and disappointing end.

Although this location is in my PATH, rawtherapee cannot be invoked except when I’m in its containing directory.

Furthermore, nothing I have tried in the last 3 hours or so will get GIMP 2.10.36 to find this version - or any version - of rawtherapee - and believe me I have tried placing copies of the executable and symlinks to it in the plug-ins folders in .config/GIMP/… and /usr/lib/gimp/2.0/plug-ins and in all the subsequent directories like file-raw-placeholder and file-rawtherapee. Must have tried 50 or so combinations of places and programs without success.

So, now I at least have an up to date version of RT 5.9 running under Mint 21.2 (as long as I am in the right directory) but GIMP still steadfastly declines to see it - or darktable, Very irritating.

1 Like

There must be something wrong with your PATH setup if it can only be invoked when in the containing directory. That would probably explain the issues with GIMP also

I have not built RT from source, but isn’t the binary in a bin directory under the installation target? If so, that’s the directory you should put on your path.

The RawPedia article on compiling RT is very easy to read and even I can understand it. Two approaches to compiling are described: Automatic and Manual. (Obviously there is also a ‘do-it-yourself’ approach for those with the requisite skills). Using either of the 2 documented approaches results in the executable (named ‘rawtherapee’) being created in the folder ~/programs/rawtherapee. This is quite different to the usual place where, for instance, darktable compiles its executable and associated commands - in /usr/bin or /opt/darktable/bin when compiling for yourself…

I guess this difference doesn’t matter all that much - as long as other programs - like GIMP for example - can be told where to find rawtherapee (or darktable for that matter). As part of this ‘telling’ I assume that GIMP uses the PATH, which is why I have made sure that ~/programs/rawtherapee is on the PATH. So it is a cause of some confusion to me as to why rawtherapee can be invoked only when in that directory (in my installation). The PATH is, after all, simple to check and simple to set - even for me. I have not yet reverted to the Big Red Switch but I’ll have to try that. In the meantime I’m using increasingly emphatic Anglo-Saxon words and phrases.

Yes, quite agree with you: that’s the only logical explanation (I think). But I’m unable to see the flaw.