Art crashes when choosing photos

Hello. Since the last update (1.9.3-3) made under linux mint, when I am in the editor tab, the fact of wanting to change the photo crashes the software, and that is with the keyboard shortcuts F3 / F4 or the arrows, or by double-clicking on a photo in the thumbnail banner. I opened ART using a terminal. Result: Segmentation error (core dumped). Would it come from my system or from the software?
Thank you in advance!

Would you be able to try a debug build and get a backtrace as explained here? How to write useful bug reports - RawPedia


Yes, I read the rawpedia article. There is mentioned a debug version but I do not see any on the ART bitbucket. Should I try this with rawtherapee?

You would need to build a debug version yourself I’m afraid…
Anyone else that can reproduce this?

I can reproduce it. Now making a debug build. Report incoming…

Arf! This is beyond my skills…
Just for information, this behavior is random: sometimes the shortcuts work, sometimes the arrows work. This depending on the photo processing sessions …
Thank you for your reactivity

@agriggio I believe there is a locking issue, because I can only get ART to crash when I either press F3/F4 or double click another image from the film strip while the current image is still loading/processing.

backtrace.txt (94.6 KB)

Alberto, I bisected the issue to this commit:

9c48af96d2e67b8f83a9e5e6ee01615e8698d2cc is the first bad commit
commit 9c48af96d2e67b8f83a9e5e6ee01615e8698d2cc
Author: Alberto Griggio <>
Date:   Mon Jul 5 18:05:33 2021 +0200

    fixed crash when switching images in single editor mode

    Fixes #188

 rtgui/ |  1 +
 rtgui/editorpanel.h  |  4 ++--
 rtgui/   |  3 +++
 rtgui/    | 10 +++++++---
 4 files changed, 13 insertions(+), 5 deletions(-)

Before this commit I can freely press F3/F4 while loading images, but from this commit on ART segfaults.

1 Like

Thanks! I’ll take a look

The problem is solved. Thank you so much!

Not here, typing F3 and F4 twice still crashes Art when in single-tab mode…

Hello Alberto,

First of all, great recognition for your work and your extremely successful adaptation of RawTherapee. Version 1.9.3 also crashes on Ubuntu 20.04. when changing photos. The previous versions worked. I am currently unable to compile these versions. There is always an error message.

Does version 1.9.1 or 1.9.2 still exist in the Linux64 version? I can’t find it anywhere. I would be very happy if you could help me.

Sorry for my bad English. Translated with google.

Very warm greetings

Hi, and welcome! If you can checkout from git the latest version should behave better…
I’ll try to release it as 1.9.4 asap, but realistically not before a couple of weeks…


Did you try this?

Works fine for me with Debian

Hello Alberto, hello Bertrand,

the latest version from git works. No more crashes.
Thank you both very much.

Many greetings

Hi @agriggio, first of all than you a lot for you extraordinary work with ART, this software is the greatest in raw post processing

Iam facing the same issue, ART crashes when I change from one photo to another. Iam working with Canon CR3 raw files. Iam using ART 1.13.2 at Manjaro KDE Linux but iam facing this issue from long time ago in previous versions.

Do you know how to solve this crash issue, it is very frustating when you try to crop lot of images one by one and each random time software crashes. I will apreciate all your help or any one that have the solution. Thanks

Thanks for the feedback!
Can you give me more info? What compiler are you using? What compilation flags? How many cpu cores do you have? Would you able to run a debug build under gdb and produce a backtrace?
(Needless to say but I don’t get random crashes here, otherwise I would have spent most of my ART-devoted time to try and fix this… But maybe my usage pattern is different enough that I don’t trigger the bug)

Hi Alberto, Iam using internal Mangaro repository which do ART compilation automatically based on comunity complation flags and commands. Iam doing right now a manual git installation as mentioned above. I have a AMD Ryzen 5700G which have 8 cores / 16 threads with an integrate Radeon GPU

It is building right now, I will let you know if thats works for me. Let me know if Iam right with that. Thanks

UPDATE: After complilation and install, Iam now at version 6061bdb26 but same issue, randomly when I change from image to image the software crashes. Maybe I need to indicate cpu cores into compliation flags

thanks for your help. To be clear, I was not expecting that a simple recompilation would solve the issue – the goal here is to understand what is going on. So, if you are still willing to help, you can try compiling in debug mode (using cmake -DCMAKE_BUILD_TYPE=Debug) and then run ART from gdb, so that you can create a backtrace when the crash happens. See How to write useful bug reports - RawPedia for instructions.
Also, can you post the content of the AboutThisBuild.txt file that is generated in the build directory?


This is the AboutThisBuild.txt file

Version: 6061bdb26
Branch: master
Commit: 6061bdb26
Commit date: 2022-04-23
Compiler: cc 11.2.0
Processor: x86_64
System: Linux
Bit depth: 64 bits
Gtkmm: V3.24.5
Lensfun: V0.3.3.0
Exiv2: V0.27.5
LCMS2: V2.13
LibRaw: N/A
Build type: Debug
Build flags: -std=c++11 -fno-tree-loop-vectorize -Werror=unused-label -fno-math-errno -Wall -Wuninitialized -Wno-deprecated-declarations -Wno-unused-result -fopenmp -Werror=unknown-pragmas -g -ftree-vectorize
Link flags:
OpenMP support: ON
Mi-malloc: N/A
Build OS: Linux
Build date: 2022-04-26T06:23:58Z