ART -> Gimp -> ART (Back problematic for me)

I like to put a white border around my square (cropped) photos.
Unfortunately ART doesn’t have a module to do this job, I use GIMP. I send the image in gimp (tiff), I create the border.

  • I export by overwriting the previously created tiff.
  • I take this opportunity to export the image also in jpg.
    In the preferences of the software I chose the same folder for the return of images from Gimp as the raw images.

The return images (tiff and jpg) are very bad. Watch the video here:

Do you have this problem?

J’aime mettre une bordure blanche autour de mes photos carrées (recadrées).
Malheureusement ART n’a pas de module pour faire ce travail, j’utilise GIMP. J’envoie l’image dans gimp (tiff), je crée la bordure.

  • J’exporte en écrasant le tiff préalablement créé.
  • J’en profite pour exporter l’image aussi en jpg.
    Dans les préférences du logiciel j’ai choisi le même dossier pour le retour des images de Gimp que les images raw.

Les images de retour (tiff et jpg) sont très mauvaises. Voyez la vidéo ici :

Avez-vous ce problème ?

Hmmm,.that’s weird indeed. I’ll take a look, thanks for the report!

Bonjour, hello,

To make a white border around your crops in ART, you can try the following. Open your photo, make a crop which must be a bit larger (to accommodate the border), then go to the Local editing tab, activate Color/Tone correction, then activate the Area mask and draw a mask over the photo, adjust your borders here to taste. Then say Invert mask, show mask, that’s the area to work on. Go to Highlights under the color circle, set to max to make a white border, set to min to make a black border. Use Feather and/or Blur in Area mask to change the look of the border.

The border isn’t 100% perfect, but that’s Alberto’s fault, not mine! :wink:

(White border doesn’t show up on a white background, so here’s a black one).


Hi @Valmy,
can you please attach the .arp sidecar and your options file?


the link to download the zip with everything in it.

It is complicated. A video to show how?

I specify: the return images of Gimp are very bad in ART. But they are correct in an image viewer outside the ART software.
Sometimes it goes well. The image in ART is correct. Other times it’s bad.
(I am under linux Mint LMDE)

There was indeed a bug which caused art to misidentify some tiff files with an alpha channel as raws. I should have fixed that in the current master. However, I’m not sure that is related to your problem.
I still would like to see your options file, and also understand how gimp is configured. Specifically, is gimp converting your images to its “built-in sRGB” on import, or is it keeping the original ICC profile of the picture? (This can be seen in “preferences → color management” in gimp)

No idea if it’s related, but I ran into an issue a while back with GIMP defaulting to BigTiff format which is largely incompatible with other software I use. I realize it’s being exported as JPG, so I don’t know if that’s even a factor. Just mentioning it…

I’ve tried both methods (keeping ART’s sRGB and then keeping Gimp’s sRGB) it’s still bad in ART. Outside of ART, tiff is better but more yellow.

I updated the other ART (continuous update) the problem is the same. It’s bad.

Have you asked other ART users to do the same manipulation. An image processed in ART then sent to Gimp and back to ART (in the same folder) to see if the display in ART when the tiff returns is all yellow? Maybe it’s from me…

J’ai essayé les deux méthodes (en conservant le sRVB de ART et ensuite en conservant le sRVB de Gimp) c’est toujours aussi mauvais dans ART. En dehors de ART, le tiff est meilleur mais il est plus jaune.

J’ai mis à jour l’autre ART (mise à jour en continu) le problème est le même. C’est mauvais.

Avez-vous demandé à d’autres utilisateurs de ART de faire la même manipulation. Une image traitée dans ART puis envoyée dans Gimp et retour dans ART (dans le même dossier) pour voir si l’affichage dans ART au retourdu tiff est tout jaune ? Peut-être que ça vient de chez moi…

I’ve asked two times before, I’ll ask another time and then move on… I’m trying to help but without more info I don’t know what to do… :man_shrugging:
I did try to reproduce locally but failed (but I thought that was kind of implied – it’s always the first thing I try before asking for more info…)

options.txt (7.2 KB)

Thanks for the info. I see nothing strange… I tried to repeat all your steps, and everything works as expected here :frowning:
A couple of other questions:

  • are you using the “official” linux binary of ART or did you compile it yourself? If so, can you try with the binary?

  • what exact version of GIMP are you using?

I can reproduce. It seems to happen if you do layer stuff and merge them like shown in Valmy’s video in gimp and save uncompressed tiff (like just overwrite) or as deflate compressed tiff. It seems to not happen with lzw compression. It does not happen, if I only paint some brushstrokes and save with overwrite. If I don’t do layer stuff, compression doesn’t seem to matter.

Here are some tiff where I did the layer stuff:

Thanks for testing. I still can’t reproduce though :frowning:

:man_shrugging: :neutral_face:

I just realized there’s a flag in options → performance about tiff files. I’m on my phone now, but maybe you can try with different settings?

There is this serialize reading option, but it doesn’t make a change.

Looks like “Merge Visible Layers” works the way, that the layers somehow keep existing somewhere (not a GIMP user, have no clue). That’s probably the reasong the merged TIFFs are that much bigger, allthough GIMP only shows one layer. If you use Flatten image (probably use this workaround @Valmy ) the file works well. Layered TIFFs uncompressed from Affinity Photo are also no problem. Don’t know if Valmy’s video showed, the problem is that ART handles the files as raws. It loads the raw profile and wants to demosaic them.


For the records: I used newest GIMP 2.99 dev on W11 and official ART 1.16.4 build. Also looked into ART @ tumbleweed which does reproduce.