ART new releases

Thank you @agriggio. This tool is fantastic! very useful and essential :+1: :clin d’œil:

1 Like

New release: 1.3.
No binaries yet, I hope they will follow in a few days.
Thanks to all the people who helped with code, translations, suggestions, and bug reports!


Uploaded at

built with
Exiv2_0.27_cxx_standard2_v0.27.2-255-gc51a8aa8 (AKA 0.27.3 I think)
lcms2_master_lcms2.9-80-gfc0fa79 (generic, skylake and znver2)

great improvments! :grinning:


Thanks! Using the generic build I notice that it has the GTK problem where the lens profile selection (automatic or manual) is disabled.

Could you be more specific with the description of problem : system , meaning of disabled (greyed out no lens displayed…). Provide a raw with pp3 to reproduce. why you think it is a GTK problem?
did you activate “profiled lens correction”?

If you are on windows, locate your options file (I think it’s somewhere in c:\users\USERNAME\AppData\Local\ART and add this (or replace if the entry is already there):


If that works, the next step is to understand what went wrong to make this needed…

Thanks Alberto, that fixed it.

My options file had:


I did not run an installer, just unzipped the Windows generic 1.3 build and started ART.exe.

I must have forgotten to check the profiled lens correction, sorry for causing you trouble.

But what is strange that it is now automatically enabled after I applied Alberto’s suggestion in my options file when I open a previously unedited raw file…

Hello everyone,

THANKS a lot indeed for this release!

Just installed the 1.3 version on Windows 10 (64 bit):
ART_1.3_W64_generic (from today’s builds by gaaned92).

I am stuck with a new option, which is:
Split view (shortcut y)

In short, is it possible to gradually zoom in-out into the 2 images?
I have tried several shortcuts to no avail (e.g. ctr+wheel of the mouse; + - etc)

Is is possible to pan into the images once they are zoomed in?
Zoom to 100% (shorcut z ) works but I don’t know how to pan in the image later on…

Here is my screenshot:

Thanks a lot in advance for any pointer!

to pan, click on the thumbnail of one of the two images and move the mouse over the thumbnail (with no button clicked).
there’s no support for zoom levels other than fit and 1:1 at the moment, sorry

Hello @agriggio

to pan, click on the thumbnail of one of the two images and move the mouse over the thumbnail (with no button clicked).

Ok. Now it works fine!

Thanks a lot again for releasing such a great piece of software! :slight_smile:

I’ve been having the same problem with lensfun profiles on every version of ART I’ve installed so far-- they don’t show up and the manual selection option doesn’t work (Windows 10 generic builds). I tried Alberto’s suggestion above of modifying the options file entry, saving it as a .txt file. However, the original options file (which has no extension-- Windows just lists it as “file”) seems to get recreated when I reopen ART, minus the lensfun directory modification.

I’m sure I’m doing something wrong, but I don’t know what. Really liking how ART is developing, just wish I could get my camera/lens combo to show up.

Do you have ART closed while you modify the preferences?

hi @malonechandler, and welcome!

regarding your problem: don’t add the txt extension, just overwrite options, with no extension. if your editor doesn’t allow you to do that, save as txt but then rename the file

Thanks, Alberto and Mica. I thought I had the program closed when I edited the file, but maybe I didn’t-- anyway it’s working now.

1 Like

I thought that when you have:

then ART should search in the default location ./share/lensfun.
At least it works like that on my PC.

Do you think it is required to add the path in option file?
In this case when building for windows, we will have to use the -DLENSFUNDBDIR=./share/lensfun cmake flag

That’s the intended behaviour, yes. It seems though that something is not working properly, but I don’t know what yet…

Hello everyone, do we know who is building ART’s V1.3 packages for the PPA?

In the mean time, I will add the flag. It should not hurt!

@Carmelo_DrRaw perhaps to be sure, you could add the flag?